Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Community Manager
939 Views

AHCI on multiple ports

Just installed my SSD X25-M SATA II 160GB. It was recommended by tech support to switch from an IDE setting to AHCI setting on the drive. My BIOS list the ports in groups "SATA Port1 - Port4" and "SATA Port5 - Port6" as the options. So to switch Port 1 to AHCI I have to switch all 4. Will my settings on ports 2, 3, and 4 be effected by not being IDE? They are CD-ROM's and DVD drives. Thanks in advance.

0 Kudos
6 Replies
Highlighted
Community Manager
5 Views

No, they will be fine. AHCI mode simply activates advanced capabilities via commands and command options that a 'drive may be able to use. If a device like a DVD drive receives them and they are not applicable to it, they will be ignored. Also, a device must be AHCI capable to use the enhancements, and if it is not, they will be ignored. The only potential affects will be positive, you have nothing to worry about.

0 Kudos
Highlighted
Community Manager
5 Views

I should mention prior to doing this, I used the clone software from intel to copy my current HDD. It was a IDE. I mentioned this to the tech support guy at intel and he said it would be "no problem, just change to ACHI in the bios."

Well, I set the drive to ACHI and booted up. I got failure big time. "Windows failed to start. A recent hardware or software change might be the cause....." Insert the Windows installation disc and restart your computer.." Now I can't get a boot disc to even initiate a windows repair via any boot device.

How do I go from a SSD that was imaged from a HDD IDE to an SSD w/ACHI? It's not as simple as the tech support said.

0 Kudos
Highlighted
Community Manager
5 Views

You are reading much more into this IDE-AHCI thing than actually exists. They are not different formats or file systems, something else is wrong.

What OS are you using, before and after?

0 Kudos
Highlighted
Community Manager
5 Views

Agava wrote:

Just installed my SSD X25-M SATA II 160GB. It was recommended by tech support to switch from an IDE setting to AHCI setting on the drive. My BIOS list the ports in groups "SATA Port1 - Port4" and "SATA Port5 - Port6" as the options. So to switch Port 1 to AHCI I have to switch all 4. Will my settings on ports 2, 3, and 4 be effected by not being IDE? They are CD-ROM's and DVD drives. Thanks in advance.

SATA Mode (IDE, AHCI, RAID) is set at the controller level. All ports on the controller are always in the same mode.

Since you see two different SATA Mode options, your motherboard probably just has two SATA controller. The native one on your southbridge or chipset and a 3rd party one (usually JMicron).

Highlighted
Community Manager
5 Views

Guest wrote:

I should mention prior to doing this, I used the clone software from intel to copy my current HDD. It was a IDE. I mentioned this to the tech support guy at intel and he said it would be "no problem, just change to ACHI in the bios."

Well, I set the drive to ACHI and booted up. I got failure big time. "Windows failed to start. A recent hardware or software change might be the cause....." Insert the Windows installation disc and restart your computer.." Now I can't get a boot disc to even initiate a windows repair via any boot device.

How do I go from a SSD that was imaged from a HDD IDE to an SSD w/ACHI? It's not as simple as the tech support said.

The issue is quite simple.... Windows was installed in IDE mode so it is attempting to use the IDE drivers when it boots up. It doesn't know the SATA mode is now ACHI and that it should use a different driver.

The solution is to force Windows to use ACHI drivers: http://support.microsoft.com/kb/922976 http://support.microsoft.com/kb/922976

0 Kudos
Highlighted
Community Manager
5 Views

Ran the Fixit tool, changed to ACHI in BIOS and it works great now.

Thank you all for the great help.

0 Kudos