Solid State Drives
Support for Issues Related to Intel® Solid State Drives
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
4365 Discussions

ATA Security Enabled Locked X25-M - Help Unlock??

Community Manager

I had 2 x 80 GB X25-M's (80G2GC) in Raid 0 with 128 kB stripe as a Window 7 boot disk for some time. It was starting to have poorer write speeds so I thought it was time for a wipe (and I wanted to try setting the stripe to the recommended 16 kB). I brought them out of the raid and was using Secure Erase in the Intel SSD Toolbox but one of the drives had a "Secure Erase Failure". I didn't worry about the error and restarted the computer to update the firmware. Then I hit problems. Bios indicated "Sata1 Hard Disk Error". The SSD could not be initialized in Windows due to an "I/O device error". I tried to reinstall firmware (one drive worked perfect but the problematic one reported that the drive was locked and firmware could not be updated). I tried power cycling the drive while having the toolbox open. A little searching lead me to HDDErase 3.3 and 4.0, I tried both but couldn't get around the ATA Security (the other drive wiped perfectly). I tried disconnecting power from the locked drive during the USB boot to dos then reconnecting before running HDDErase (again both versions) but kept getting flagged that the drive is in a locked status with high security.

There are options to erase but I need a user password or master password. Thing is I've never set any passwords so I don't know where these came from. Is this drive toast? Can I somehow get rid of this security lock that prevents absolutely all access to the drive? I don't care about what is on the drive as it has all been backed up. Is this a warranty issue?

I don't understand how the drive could have been locked so any help is much appreciated.

0 Kudos
2 Replies
Valued Contributor III

I don't know much about SSD's but here is another post on unlocking password./message/107957# 107957 107957

Community Manager

Yep I saw that post and followed it right through to the end but it didn't help. It looks like it didn't help the original poster either.

I followed the recommendations.

# 1 USE HDDerase version 3.3 (but I tried both 3.3 and 4.0)

# 2 Prior to booting PC unplug power from the SSD but keep the data plugged in

# 3 Start PC and wait for DOS to boot via USB or CD (I used USB after killing a few cd's with DOS boots that didn't work)

# 4 At the A:/ prompt plug the SSD power back in

# 5 Run HDDErase

It ran, recognized my drive (on P0), tried to wipe, tried to unlock, tried 2 known passwords, but didn't succeed only giving me the same options as in the other post:

If selected drive is locked with a non-HDDerase password the user is given the 

option to: 1) unlock with user password, 2) unlock with master password (if high


security), 3) secure erase with user password, 4) secure erase with master


password, 5) enhanced secure erase with user password (if supported), 6) enhanced


secure erase with master password (if supported). If option 3, 4, 5 or 6 is


selected any possible HPA and/or DCO areas will not be reset.

I had bios set to IDE (with compatibility not enhanced) prior to running HDDErase and it wasn't set to ACHI or RAID. I wish I knew how this thing got locked.