Showing results for 
Search instead for 
Did you mean: 
Community Manager

BAD CTX 8MB Brick 160GB "Current" Firmware?


So I am having the BAD_CTX 8mb brick problem with an SSD in a Lenovo T420 laptop. The kicker is, I'm experiencing it on the most up to date firmware - 4PC1LE04. Short and sweet, here is what is going on.


- Lenovo T420 with 160GB SSD. SSD model is: SSDSA2BW160G3L.

- The type is: 4177-CTO.


- The laptop will not boot from the SSD no matter what I try, which has been a lot.

- When checking the SSD with the Intel firmware update utility, the serial number reads: BAD_CTX 000001.

- According to the Intel firmware update utility, the firmware on the machine is CURRENT. It reads as version 4PC1LE04.

- I read that the Intel firmware update utility can have issues with detecting and accurately reporting on Lenovo drives, so I downloaded the latest firmware update utility straight from Lenovo. It also reports the firmware as 4PC1LE04 on the drive and will not let me update it, because it is "current".

- I tried to boot the machine using BartPE to investigate the partition a bit, but this results in BSOD.

- I booted the machine using GParted and it boots fine and detects the SSD. Sadly, it reports the partition as being 8 megabytes in size!

- This is exactly similar to the firmware bug that existed previously for these drives. The difference is that I think my firmware is already up to date... That can't be good...

- The T420 was shipped directly from Lenovo a couple months ago and was shipped with the latest firmware already installed. So, the firmware has never been changed or upgraded on these machines.

Larger Problem:

I have about 16 of these circulating in my company, many of which belong to key employees. If the 4PC1LE04 firmware is truly buggy, then all these users are at risk. There is no firmware upgrade path available, either. So how do I get this bug into the hands of Intel/Lenovo for a potential fix?

I am happy to verify every troubleshooting step I've taken and I'm open to suggestions for further diagnosing this problem. Any advice or help would be greatly appreciated! To my knowledge I am running the most up to date firmware, straight from the Lenovo factory, 4PC1LE04. Obviously I've already lost data for one user... I do not want to lose data for 15 more. Thanks for your help.

Other Notes:

The user who handed this machine off to me said that sometimes he does shutdown improperly by holding the power button, and that the laptop does die by running down the battery on occasion. I am making note of this because in the older firmware it was hinted that the bug might be triggered by unexpected power loss. Perhaps that is also the case on the "current" firmware?

0 Kudos
3 Replies
Community Manager

Just as an FYI, it does seem that an unexpected power-off impacts a drive, even with current firmware. I had this issue this week with the latest firmware. 8MB brick-- I have a different BAD_CTX error code (166), but the behavior is the same.

In my case, the machine shut down suddenly due to heat.

Community Manager

You seem to have more or less same hardware/firmware as I have with latest firmware (4PC1LE04). I have described my whole ordeal and things I tried at Never an Intel SSD again - Roads Less Taken.

In summary, yes its relatively simple to "revive" the disk but this is based on doing a secure erase (all data lost). No, you can't save any data on your own (but some recovery firms claim they can) and no, I don't use this disk anymore - I got another brand - and I will never buy Intel SSD again.

Also, yes, mine got triggered by holding power off because of full "freeze".


I have the identical machine (T420 4177CTO) with the identical SSD and firmware, and the identical crash and error code. It happened after I had to force a power down when my computer froze.

I have no answers for you - just sympathy. I found a way to boot to an external hard disk so I could use the Intel Toolbox, but I can't use Secure Erase to restore the drive because there is a Security Freeze Lock that I can't unlock no matter what I try.