Showing results for 
Search instead for 
Did you mean: 
Community Manager

BIOS does not find my SSD after power loss

Hi folks,

I am proud owner of a 80 GB Intel SSD X25-M (Model: SSDSA2M080G2GC) since mid September. I used the SSD inside a Linux system for /boot, /usr, /var and, regrettably, /home. The system ran fine and it was very enjoyable to work because of the performance of the drive.

I never bothered to install a firmware upgrade. The label on the drive says "FW: 02G9".

Yesterday, I pulled the wrong power jack, so the system lost power suddenly and was not halted and powered down the clean way. Since then, my system doesn't boot any longer.

It turned out, that even the BIOS of the system is unable to find the drive. If, in the BIOS, I try to auto-configure the drive, it takes a few seconds longer than on unconnected SATA ports, but with no result.

I also tried to connect the drive to a Windows laptop via USB (in an external case). Similar effect: The drive didn't show up in Windows' "Disk Management".

Looks like the drive doesn't answer to SATA commands at all.

When booting linux ( from DVD, the drive is not reachable (e.g. via /dev/sda or other). When I unconnect the SATA link cable on the motherboard-side of the cable and put it back, I get the following dmesg output:

[ 268.396559] ata1: exception Emask 0x10 SAct 0x0 SErr 0x1890000 action 0xe frozen


[ 268.396564] ata1: SError: { PHYRdyChg 10B8B LinkSeq TrStaTrns }


[ 268.396573] ata1: hard resetting link


[ 269.135306] ata1: SATA link down (SStatus 0 SControl 300)


[ 269.135314] ata1: EH complete


[ 272.237787] ata1: exception Emask 0x10 SAct 0x0 SErr 0x50000 action 0xe frozen


[ 272.237791] ata1: SError: { PHYRdyChg CommWake }


[ 272.237800] ata1: hard resetting link


[ 278.157731] ata1: link is slow to respond, please be patient (ready=-19)


[ 282.287484] ata1: SRST failed (errno=-16)


[ 282.287506] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)


[ 282.287511] ata1: link online but device misclassified, retrying


[ 282.287515] ata1: hard resetting link


[ 288.213713] ata1: link is slow to respond, please be patient (ready=-19)


[ 292.293434] ata1: SRST failed (errno=-16)


[ 292.293453] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)


[ 292.293458] ata1: link online but device misclassified, retrying


[ 292.293462] ata1: hard resetting link


[ 298.219697] ata1: link is slow to respond, please be patient (ready=-19)


[ 327.331046] ata1: SRST failed (errno=-16)


[ 327.331065] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)


[ 327.331070] ata1: link online but device misclassified, retrying


[ 327.331073] ata1: limiting SATA link speed to 1.5 Gbps


[ 327.331076] ata1: hard resetting link


[ 332.350703] ata1: SRST failed (errno=-16)


[ 332.350722] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 310)


[ 332.350728] ata1: link online but device misclassified, device detection might fail


[ 332.350738] ata1: EH complete

What might "device is misclassified" mean? Looks to me like it is in a maintenance mode or something.

-Has anyone had similar experiences?


-Is there a way to 'reset' the drive? Is it worth removing the cover (and loose guarantee)?


-Is there a secret ata command that puts the drive back to normal mode?


-Is there any chance to access my data? The last backup is a few days old and I don't want to loose some emails.


-If I have to RMA my drive, how can I erase the disk in advance to protect my passwords?

Thanks for any help.



0 Kudos
4 Replies
Community Manager

Sounds like the drive is dead.

As a last resort, I would boot to DOS, in IDE legacy mode, and run the Intel firmware updater. It may bypass the BIOS when searching for the drive. If it doesn't find the drive, then it is probably DOA. If it does see the drive, then updating the drive firmware may clear the problem.

Community Manager

Hi retiredfields,

thanks for your hints. I don't think it has anything to do with the BIOS:

-The drive worked for one-and-a-half months with no problems at all.

-My motherboard (Gigabyte GA-M57SLI-S4) has already the most up to date version (F14) flashed.

-Linux doesn't detect the SSD either.

But right, perhaps the Intel firmware updater bypasses the BIOS and is able to correct the drive and put it back to normal operation mode. Well, since Intel has removed the firmware updater software, I guess I have to wait.



Community Manager

Made another experiment: When I connect the data cable of the SSD to the motherboard's SATA port but don't connect the SSD to power, POST is faster and linux reports "SATA link down". So the drive is not completely dead, at least it makes a difference, if it is connected to power or not.

Community Manager

Sorry to hear about the misfortune.

First, if the device is recognized in linux, then you might be able to boot linux using a LiveCD, then try to do a "FSCK" to repair. It looks like from the messages, that Linux sees that a device is there, but it can't classify it. If a /dev device is created(i.e. /dev/sda1) for it, then you should be able to run fsck and see if Linux can repair the filesystem.