Showing results for 
Search instead for 
Did you mean: 
Community Manager

Cannot Update Firmware from 3.0 to 3.1

I cannot update the firmware for my SSD 330 180gb. I currently have version installed and I have downloaded version 3.1.1. When I run the setup it seems to copy all the files fine, but it freezes when it tries to execute the legacy_uninstall.exe. I have tried to manually uninstall the 3.0.5 version, but I get a Java error and it remains installed. I completely uninstalled Java and tried to reinstall 3.1.5; it still freezes at the same point. I also tried to manually uninstall 3.0 again. No luck. At this point I installed Java 7 Update 9 32 bit. I again tried both installing 3.1 and uninstalling 3.0 manually. No luck with either.

I am running Win7 64 bit Home Premium SP1, Intel SSD 330 180gb Firmware 300i, AMD FX 4100 Quad Core.

Any help would be greatly appreciated.

Tags (1)
0 Kudos
2 Replies
Community Manager

I'm confused by the terminology you are using, and I believe you may be confused about your 330 SSD's firmware.

The current and only firmware available for the 330 series SSDs, is version 300i.

The 3.0.5 and 3.1.1 versions you mentioned are for the Intel SSD Toolbox software. While that software can perform firmware updates, it is itself not firmware for any Intel SSD.

The problem you're having with the Toolbox is likely related to your AMD chipset board, and possibly the SATA driver you are using. Did the driver change since you installed the 3.0.5 version of the Toolbox? Not all SATA chipsets and/or drivers are compatible with the SSD Toolbox. The compatibility of the Toolbox seems to have become more restrictive with the newest version, 3.1.1, possibly related to new features in that version. If that is the case, then a different SATA driver will not make a difference.

The Toolbox requires Microsoft .NET Framework version 3.0 to be installed, but the version of the Toolbox that did work for you would not have worked without it, so you must have it now.

Are you using an AMD AHCI driver now? Did you ever use the Microsoft AHCI driver, msahci, a standard part of Windows 7? Intel SATA drivers cannot be installed on AMD SATA chipsets, but there is a chance that using the msahci driver will allow the Toolbox to work on your system, but I am skeptical that will make a difference, sorry to say.

Community Manager

Thanks for your help, parsec, especially in regards to my terminology. I should have said I couldn't update the Toolbox software.

With the help of a friend, I was able to resolve this, but I'm still not sure what was wrong. My friend suggested I re-install my existing Toolbox version, 3.0.5, right on top of what was already on my machine. Then, try again to install the most current version, 3.1.1. It worked.

Now, as I mentioned in my original post, I had completely uninstalled Java. (I had two instances of it; I don't remember which they were.) I then installed one instance of the most current version for Win7. If I hadn't already done this, would my friend's advice have worked? I don't know. As I said before, when I tried to manually uninstall 3.0, I would get a Java error, so Java may have been a factor.

In any case, problem solved.