Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
2,045 Views

Cannot format Intel 520 180GB SSD

Hey all,

Asus CM6870 series desktop

Windows 8, 64-bit

16 GB

Intel i7-3770 A 3.4Ghz quad core

7200RPM 2G HDD

Intel 520 180 GB SSD, connected to an SATA 6GB/s interface with an SATA 6GB/s cable

I was hyped to get my new SSD ... I plugged it in and it was recognized in the BIOS just fine. However, when I try to format it using the Disk Management tools it comes back with an error saying "Could not complete the operation" and when I check the events I see

Reset to device, \Device\RaidPort0, was issued.

The IO operation at logical block address 40800 for Disk 1 was retried.

The IO operation at logical block address 14f5bfff for Disk 1 was retried.

The IO operation at logical block address 40800 for Disk 1 was retried.

The IO operation at logical block address 14f5bfff for Disk 1 was retried.

The IO operation at logical block address 40800 for Disk 1 was retried.

The IO operation at logical block address 14f5bfff for Disk 1 was retried.

When this first happened I started looing around for diagnostic tools and came across the Intel SSD Toolbox. When I first start the computer and check the drive with the toolbox I see that the SMART indicators are all green and the drive looks otherwise normal. When I try to format it then I see the aforementioned problems.

I've tried different wire combinations (switching the wires from the HDD to the SDD but all to no avail)

I'm just wondering if there isn't something basic I should try, or is it time to activate the warranty and send it back to Intel? Let me know If I left out any vital information.

Thanks in advance

13 Replies
idata
Community Manager
49 Views

OK ... no sooner do I post this message then I have a brainchild: try a different formatting tool!

I tried MiniTool Partition Wizard and the format went ahead perfectly!!

Anyone know why this might be?

idata
Community Manager
49 Views

Same here, Jeffrey! I've been fighting this on a new Lenovo using Lenovo's standard system load of Windows 8 Pro and an Intel Series 525 (mSATA form factor of the 520) for a couple months now, including an RMA and exchange via mail for a new Intel 525 180GB SSD, with same results.

MiniTool Partition Wizard worked where Windows 8 did not. Many, many thanks. I'm no smarter, but I'm much more productive. I would like to find out why this is, too.

Jose_H_Intel1
Employee
49 Views

You can use Diskpart within Windows* to clean and reset your Solid state drives. To use this tool, you can either open up a command prompt window within Windows, or boot from the Windows* installer CD, allow it to load the files, and get to the part where it allows you to choose the time and language.

At this part press Shift-F10 this will load a DOS environment.

Type the following and hit enter after every line:

  • Diskpart (it will display information in regards to the tool)

  • list disk (it will show a list of your available disks with a number next to)

  • select disk # (replace the "# " with the number representing the drive you wish to clean)

  • clean all (after this it will stay at a blinking cursor during about 15 minutes for a 80GB drive)

After this process is completed you may create the partition and format the drive with computer management or the Windows installation disc.

idata
Community Manager
49 Views

Thanks, Joe, but I knew about this solution, tried it, and it failed, too. In addition to all this, I stayed in diskpart also to create the partition and attempt to format it, but the format failed there as well.

I disagree with this solution. There is still a problem here to solve.

Jose_H_Intel1
Employee
49 Views

Is the drive part of a RAID array or connected to a RAID controller? I wonder if it is possible to connect the drive to a native SATA controller as a single drive (if it is not already connected) and run the full diagnostic scan from the SSD Toolbox.

idata
Community Manager
49 Views

 

The Lenovo W530 is capable of RAID and IRST from the factory load, I've allowed all the factory software to remain on the machine and update itself as it wants.

Each time the format would fail, it would cause windows 8 to log in the system event log "Reset to device, \Device\RaidPort0, was issued".

I was able to perform the full diagnostic on the Series 525 card in Windows 8 in this machine without relocating the card. It showed no error, full pass. This is what I would expect, since two identical Series 525 drives, the second shipped in response to an RMA caused the format failure behavior, and the odds that two would fail to format the exact same way are very long, indeed.

MiniTool was able to format this drive in situ, where Windows 8 could not. This tells me that the RMA I performed with Newegg was likely not required, and there is some sort of a problem with the Intel driver installation that MiniTool bypasses. I found references online where some found success in disabling Intel Link Power Management by adding LPM enable/disable DWORD's to the iastorV registry branch. I did not do this, I just used MiniTool.

Jose_H_Intel1
Employee
49 Views

It is good to know you were able to format the drive in the end. The description of the registry entry seems to be related to the SATA controller driver (IRST). You may want to post this subject in the Intel(R) Chipset communities.

idata
Community Manager
49 Views

jfederline, what version of IRST is used in your Lenovo W530?

If you can run the IRST UI that should be listed in Control Panel, do that and click on the Help button. A new window should open, in that find the System Report option, and click that. You should see a report like this:

I'm wondering what version of IRST and which IRST option ROM is being used with Windows 8 on that PC. I've formatted two 520s using Windows 8 and a IRST driver, with no problems. I've noticed that any SSD using a SandForce controller takes longer to format than SSDs using other controllers, but I've never had a format fail on a 520.

idata
Community Manager
49 Views

Um. There is no Intel(R) Rapid Storage Technology control panel icon on this W530. There is an iastorV registry tree, as well as an iastorA registry tree, too.

I am now also getting boot time blue screen periodically (not always) with volume manager.

The system was re-built from the Lenovo W530 system recovery disc image to an Intel 520 - I'm having the issues since I installed the Intel 525 mSATA. The 520 has been gloriously smooth so far, its just the 525 that causes issues.

Tonight, since MiniTool was able to bring it up with a filesystem I could write and read well to, I reformatted it with Windows 8 now. It reformatted (quick) successfully. I'll run this way a bit. In the meanwhile, if you have anything else to try, let me know here! I'm getting subscription emails from this thread.

-Jim

idata
Community Manager
49 Views

You may not be using the IRST driver now. The entry for the IRST UI not being found in Control Panel tends to indicate that. The iaStorA and iaStorV entries in the registry do not necessarily mean that driver is installed and used by the SATA controller. Windows has basic IRST drivers included in it, as well as for AMD chipsets. They are included in the registry whether or not they are used.

You must check Device Manager, under Storage controllers, or IDE/ATA ATAPI..., and check the Driver tab details to confirm which driver is currently in use.

idata
Community Manager
49 Views

It is not the IRST driver in device manager. Why would the W530 not come with it from lenovo? Should it be installed now?

I also noticed the factory build did not include the full Intel WiDi driver control set and wireless chipset driver .controls.

idata
Community Manager
49 Views

Did you find storahci? If so, that is the new Windows 8 AHCI driver. Nothing wrong with it.

Who knows why Lenovo did not use the IRST driver. Could be that Intel only fairly recently released IRST drivers for Windows 8, the IRST 11.6 and 11.7 versions, and another for their new 8 series chipsets. Your Lenovo may be from production before those drivers were released. Or Lenovo was being conservative and did not want to "risk" using the new drivers.

Laptop manufactures tend to be very conservative with their products, stability before all else. They won't use the SATA III ports in some cases, apparently afraid they will cause problems.

You could try the IRST driver, and always rollback if you need to. For Windows 8, you should use IRST 11.6 or 11.7 versions.

idata
Community Manager
49 Views

update:

I decided to run the Lenovo driver update utility again before I went and did direct Intel driver updates. MAJOR round of updates from Lenovo for the hardware, including two BIOS updates and IRST AHCI drivers, among other hardware driver updates for other Intel hardware in this laptop. the magnitude of these updates might imply that my 12/2012 ship date of this w530 contained buggy BIOS and drivers integrated by Lenovo.

Applied and so far, no bugchks in 3 cold starts. Will monitor, I'll try repartitioning and reformatting the 525 mSATA using Windows when I get a chance.