Showing results for 
Search instead for 
Did you mean: 
Community Manager

Drives randomly change from SATA 3 to SATA 2


I have recently purchased (1 month ago) a Dell XPS 8300 dekstop which has an i7 2600 chip on what appears to be an H67 motherboard (made by Dell?) and I separately bought 2 Intel 510 120gb SSDs. My motherbaord has 6 SATA ports, 4 x SATA 2 and 2 x SATA 3. Obviously my SSDs are connected to the SATA 3 ports.

They went in easily and work very well but they do have a habit of changing from SATA 3 (6gb/s) to SATA 2 (3gb/s) for no obvious reason. It can happen to one or both of the drives and 90% of the time a complete shutdown and start returns them to SATA 3. I am using the Intel Rapid Stroage Technology Tool to check the SATA speed.

I'm quite sure they really are changing speed and that it isn't just a reporting issue as I can see a slightly longer load time for windows when the system SSD has started up as 3gb/s. Normally the windows logo only half completes when it's at 6gb/s but when it has gone back to 3gb/s the whole logo forms. When this happens I check the Intel tool and indeed the system SSD is running at 3gb/s.

One of the drives reports firmware PPG4 and the other PPG2 but the problem affects them both equally. I downloaded and booted the Intel SSD Firmware Update Tool which found both SSDs but told me that both firmwares were up to date. That seems a bit odd as one is PPG2 and surely that is not as new as PPG4?

Anyway, they work and even at 3gb/s they are considerably faster than a mechanical drive but I would obviously prefer them both to stay at 6gb/s. I expect no help whatsoever from Dell because when I first asked them about adding SSDs they said it should be possible but they couldn't offer any support as they hadn't tested them out with this system yet.

Does anyone have any idea? I've also sent a message to Intel support outlining this problem but thought I'd see if anyone else put there has come across/solved this problem.

0 Kudos
10 Replies
Community Manager

ian, That is a curious problem, I've never heard of that but that certainly doesn't mean it can't happen. I don't have a quick, obvious fix for you, but you should check a few things so we know what we are working with.

Just to confirm your hardware, you can download CPU-Z (free) here:

Install and run it and check the Mainboard tab to verify your chipset and hopefully identify your mother board.

Since you are using IRST, you have an Intel chipset, but just to be certain which one check with CPU-Z.

Next, do you know which SATA mode you have enabled in the BIOS? Either AHCI or RAID is appropriate, the latter even if you are not using a RAID set of drives. Sandy Bridge mother boards usually are set to AHCI by default, which is good and saves some work enabling AHCI mode.

I have never seen or heard of the need to enable SATA 6Gb/s mode, so that should not be an issue.

I own a 120GB 510, and I have not noticed this issue on an ASUS P67 mother board, although you have me checking it now! My 510 has the PPG4 firmware, but as you said that is likely not the problem. I have noticed a few things about the 510 that may be worth checking.

First, the connector on the 510 SSD for the SATA data cable does not have the locking capability that uses the metal latch on the top of the cable's plug. My 510 came with a SATA cable, and if yours did you can see that one end has a latch, but the other doesn't. I've tried several SATA cables with it, and the ones with latches do not work well with the 510 in my experience. The plugs with latches do not lock in at all and easily disturbed or pull right out. I forgot about this and put a cable with a latch on my 510, which worked fine for a while. After again working on the inside of my PC, I must have moved the cable, and when starting the PC the 510 (my OS drive) was not seen by the BIOS and the PC would not boot. I had a SATA cable without latches and found it fit securely in the 510. My point is you should check your cable/connection to your 510 and make sure it is as firm and secure as possible.

Another possibility is your PC's power management settings. Although the 510 does not use much power at idle, about 1/3 watt according to a test I saw, when reading or writing is uses over two watts, which is a bit higher than some other comparable SSDs. Check your Windows power settings, and try it on High Performance if it is not set there now. I saw a thread in this forum regarding the 510 going to sleep or not responding in an Apple PC, when it's power management feature was active. This may have been on a laptop, I can't recall, but it might be possible that your 510 changes to 3Gb/s mode due to Windows power management feature. That is only speculation on my part, and I've never seen this happen to mine, I have the power management set to High Performance.

If it will make you feel better about running in SATA 3Gb/s mode, check the benchmark results of the Intel 510 at both 6Gb/s and 3Gb/s in this review. The link brings you directly to the most interesting results, but the entire review is worth reading:

If I discover anything else, I'll post it here, and I'd be interested to hear if you figure this out. Post your CPU-Z results and perhaps that will tell us something.

Community Manager

Hi and many thanks for the very helpful reply.

Firstly, my the motherbaord tab on CPU-Z reports:

Manufacturer : Dell Inc.

Model : OY2MRG

Chipset : Intel Sandybridge Rev 09

Southbridge : Intel H67 Rev B3

I've already spoken to Intel and Dell:

Intel suggested swapping cables and also the possibility of Dell having limited the motherboard in some way which apparently some manufacturers do.

Dell said they couldn't really support putting SSDs in this system as they hadn't tested them for themselves which sounds a bit odd. I pointed out that their service manual shows two SATA 3 ports on the motherboard and in that case they should be working. So now someone is looking into whether or not a limitation has been put on the motherboard and will get back to me in a few days.

As for cables: I bought a new pair but when they arrived today I discovered that cables with 90 degree connectors on either end will not fit in my system. So I will order some more. The cables that came with my drives are black and have latches on both ends.As you say, the drive itself does not have a locking mechanism. I removed the latch from one end of the cables and put them back in today. I might get in touch with Intel today and ask them about sending out a better pair of cables as it seems silly to send me ones with latches on both ends!

After removing the latches at the drive end and refitting them I wasn't terribly surprised to see that the problem hadn't gone away. I'll give the cables one more try with some new ones (from Intel or elsewhere) then rule that out as a possible cause.

I had a look at all the power management features on this desktop sysem and couldn't find anything specific to the drives. There are different power plans but they seem to differ only in how long it takes before something is put into sleep mode. I couldn't find anything in the BIOS about this either.

After a lot of shutting down and restarting I am now 99% certain when I say that a cold boot results in both drives at 6gb/s and they stay that way until a restart. The restart will then result in either one or both of the drives going to 3gb/s. Disk 0 is my system SSD and disk 1 is for programmes. Disk 0 goes to 3gb/s in about 25% or less of restarts and Disk 1 in about 90%. Those figures will get more accurate as I seem to be dong a lot of restarts and boots since I got these drives!

I used ATTO to benchmark the drives and in comparison to the 1tb 7200rpm mechanical drive they are both a lot faster even in 3gb/s mode. I compared 3gb/s to 6gb/s mode and although the difference wasn't as large it was still noticable enough. The annoying thing is knowing that they can run at 6gb/s but something is changing them back to 3gb/s.

So I'll wait and see if Dell own up to limiting things and gives new cables a try again. In the meanwhile I'll keep an eye on the starts/restarts and narrow those figures down a bit. If you do discover anything else please let me know but it seems I'm stuck between Dell and Intel waiting for one of them to take responsibility. If Dell say they haven't limited anything then it could just be a motherboard fault which they could fix easily with a new one. If it's not Dell then who knows what it could be? If it's not Dell and not the cables then I'm pretty much baffled.

Thanks for coming on board with this!

Community Manager


A further update - it's not the cable. Have now tried 3 types (great waste of money!) - with and without clasps and no change. Next step - hassle Dell into doing something.



Community Manager

OK - another update. This time I feel I'm getting nearer to the cause but have no idea for a solution.

When I was talking to Dell half an hour ago they suggested something that I really should have thought of first. I have two SSDs and one mechanical drive in the system. They suggested putting the mechanical drive on one of the SATA 3 (6gb/s) ports and testing that. So I put the mechanical into Port 1 and tested. The result was that the problem didn't affect the mechanical drive. The connected SSD in port 0 did eventually change speed to 3gb/s after a few reboots but the mechanical stayed at 6gb/s.

In these circumstances Dell won't help further as they only support the drives that the system shipped with, ie the mechanical one. And as that stays at 6gb/s there is no problem as far as they are concerned. I can't really argue with that much more. Dell also say they aren't limitng the motherboard in any way.

My choices now are:

1) Put up with not using restarts but just cold boots to keep the speed.

2) Try a different brand of SSD to see if it's just the Intel 510 that has the problem.

2) Just be happy with 3gb/s when it happens but my benchmark results from ATTO do show a considerable difference between the SSD on 6gb/s and 3gb/s. Here are the benchmark results: the one on the left is my system drive at 3gb/s and the one on the right at 6gb/s. There's quite a big difference!

So time to research another drive I think? Or give up?

What would you do?



Community Manager

Dell isn't being very nice about disclosing full system specifications, but from what I can tell it looks like the Dell XPS 8300 is one of the systems which uses the latest Cougar Point southbridge. You know, the chipset that,2817,2379241,00.asp was recalled due to SATA silicon-level bugs? More details are also available. Although Cougar_Point_chipset_flaw this sums it up quite nicely, there's also double confirmation Dell systems are affected. This thread will almost certainly interest you, Ian. I say all of this with full knowledge of your previous post where you said "Southbridge : Intel H67 Rev B3". The reason I'm not so sure I believe that is that the same output you stated says "Chipset: Sandybridge". Sandy Bridge is not a chipset; it's a model (code name) of CPU. SATA is driven entirely by the southbridge (code-named Cougar Point). There's even a major news site which said "Sandy Bridge chipset" recently, so don't feel bad -- people keep screwing up the two. :-( So read the Dell forum thread and you might be surprised.

EDIT: Oh, and 19812684 read this one too, particularly the end statement from Dell.

Dell needs to tell you whether or not your model of system is truly running the B3 stepping version of the Cougar Point southbridge or not. It's their responsibility. Dell Technical Support needs to own up to assisting you in this.

Now that I got that out of the way -- is this chipset bug what's causing you all the grief? Impossible to tell. But it is something you need to consider, and something Dell needs to work with you about.

Community Manager

All of this stuff about Sandybridge flaws is very old news and I don't think this is helpful at all.

"Now that I got that out of the way -- is this chipset bug what's causing you all the grief? Impossible to tell."

Enough said.

To return to more practical matters....

Intel have now escalated the case so hopefully they will do some more investigation.

Dell say that they are about to start testing SSDs with this system with a view to offering it as a buyable configuration. This would involve releasing a new BIOS which might address this problem. Sounds like they're almost admitting it is a known problem.

I may well buy a different brand if I see a cheap SATA 3 SSD on eBay and give that a test but for now I wil have to just make sure I do a cold boot if I want the speed.



Community Manager

I just created a new discussion ( that is very similar to this one and in fact I'd say the symptoms are identical. Reading this thread gave me the idea to turn my system off/on and voila! Drive C, which RST had reported as 3Gbs was now reporting as 6Gbs. This is a new system built on the Asus P8Z68 Deluxe motherboard so the whole B3 discussion is irrelevant. Intel ... please help!

Community Manager

I still haven't heard anything more from Intel. It's now been 8 weeks since Intel were first informed of this problem. I guess they just don't give a sh*t?



8 weeks?



It looks like they don't think it's important enough or not enough people have the problem for it to be worth the effort. I recommend just taking the drive back to the retailer and asking for an exchange. It's been proved that there is an issue so they shouldn't give you too much trouble. Howeber, I thought the same of Intel but they've turned out to be utterly useless! /report.php?p=32404585

I am having the same problem with my sata3 intel 7 series controller

sometimes my Crucial m550 ssd drive will work as a sata3 device and get amazing speeds then some times I get sata 2 speeds which are half the sata 3 speeds

Very annoying.

Honored Contributor II

There are multiple components involved in the behavior of SATA drives. SATA downshifts can be caused by different factors.

The focus of this forum is on Intel SSD's, however, SSD's from other brands should behave in a very similar way.

Here are some recommendations you can consider if your system presents SATA downshifts from 6 Gbps to 3 Gbps:

- Check with the motherboard manufacturer and update the BIOS of your PC.

- Update the firmware of the SSD.

- Contact the manufacturer of the motherboard and make sure you use the most current drivers for the storage controller, and chipset. *For Intel products, they can be obtained from Intel® Download Center.

- Replace the SATA cable.

Furthermore, you can try to isolate the possible culprit by using the SSD in a different computer, or trying a different drive in the SATA port where the issue occurred initially. This may help you identify if the issue follows the drive, or the SATA port.

If the issue persists, you may want to contact support for the SSD, or the motherboard manufacturer for additional assistance.