Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
1,201 Views

Error updating firmware on X-25 G2 - drive not found!

Hi everyone,

I have just bought a new computer with a X-25 G2 80 GB Intel ssd installed. I am running GA-770TA-UD3 Motherboard and Windows 7 64 bit.

My problem is that I have found out that I am running the 2HA firmware, and I would like to upgrade it to the 2HD firmware (or the 110902HD88208850 firmware version to be correct) as I have heard that the 2HA firmware can cause problems.

I tried upgrading the firmware by booting on the firmware cd-rom. The program starts up when I am booting, but then tells me that I have no SSD drives on my computer...? In that way I cannot upgrade the firmware!

Do You know what I have to do in order to ensure the firmware cd can "see" my SSD?

I have installed the "Intel SSD Toolbox" but it says "Error connecting to drive", so not much help there....

I am a bit of a noob in BIOS and so on - could there be something preventing the firmware in running? In that case, what do I have to do in order to make it run?

Thanks in advance!

/Henrik

Tags (2)
0 Kudos
2 Replies
MBall5
New Contributor II
83 Views

Hello, what I can recommend is to set the system in the BIOS from RAID to IDE, compatible mode or legacy mode, also you might want to try to change the Solid State Drive from that port to port "0" or "1".

If the issue persist I will suggest to try to update the firmware from a different computer, some BIOS prevent the system to update the firmware or perform a secure erase.

idata
Community Manager
83 Views

Hi - thank you for your reply.

I gave the computer back to manufacturer and asked them to update the drive, and when I asked them how they solved it they basically gave me the same explanation as you mentioned below.

So thank you - and sorry that I haven't given you any feedback before now.

Br Henrik

Reply