Showing results for 
Search instead for 
Did you mean: 
Community Manager

HDD Erase 3.3 HORROR STORY - Anyone else???

After reading posts here and reading part of

AnandTech's article on SSD's, I decided to try

HDD Erase and leave some of my drive unallocated

for headroom. I found an ISO image of HDD Erase

3.3 after quite a bit of searching and

downloaded it from a blog archive in England.

When i ran the cd, it told me my drive was

frozen and said was prohibited in the bios, and

asked would i like to attempt to bybass the

bios. Apprehensive, but i entered yes. it told

me to do a hard reboot and run hdderase again.

which i did. Again it asked me would i like to

"attempt to bybass the bios." yes. the program

ran, and ran - for over 3.5 hours, i went to bed

and when i got up it said "secure erase FAILED"

i took the cd out and booted. it took about five

minutes to go through post, instead of seconds.


Disonnected the SSD and restored an acronis

backup. the post only took seconds and the

backup booted ok.

Put back the SSD and the post took forever and

so did loading windows. I knew my SSD was in

trouble. i tried diskpart from within my backup

and could do nothing with the drive, wouldn't

partition - diskpart responded with "I/O error"

i disconnected and reconnected the drive several

times. with the ssd connected post and boot took

forever, without it - my machiine seemed fine.

anyway to make a very long story shorter, i

finally resulted to trying hdderase again this

time it told me my disk was "locked" and frozen.

it asked again if i wanted to bypass the bios.

yes. Much to my amazement, it ran in minutes and

said the erase had suceeded. Post now took

seconds and my backup loaded normally. i

partitioned the drive, installed windows and

everything was fine.

i have since ran hddererase several times and

each time it tells me my drive is "frozen" and

asks to bypass the bios which i do. Programs

seems fine and no further problems since.

anybody else out there have similar experience,

anybody getting the bypass bios message or bios


I would greatly appreciate any feedback...


thanks for listening to my long story.
0 Kudos
14 Replies
Community Manager

by the way my ssd is x25m 80 gen2 with 02HD firmware and mobo is intel dg965wh


New Contributor I

Hi curiosconsumer,

I have ran hdderase several times on G1 and G2 drives; on G1 drives the program always asked to to a hard reboot and after doing so, everything was fine.

With G2 drives and my mobo, the hard reboot was'nt sufficient to bypass the bios security freeze lock, and i had to go on a workaround method: cut the power of SSD (by unplugging its power cable) and after rebooting with the DOS boot disk, everything was ok.

The Read Me section of very well explains this and other possible issues with hdderase.

I also suppose that the particular behaviour of hdderase depends of the particular mobo and its bios; mine is ASUS Rampage 2 extreme.


Community Manager

I also have a rampage 2 extreme, and experienced same problem a while ago. I tried with the latest bios 1704, not to long ago and bios lock was bypassed on a G2, no need to cut the power. Hdderase only takes a few seconds to complete and it is the recommended thing to do before a fresh OS install.

New Contributor I

Yes Guz, the bios locks i had was with an earlier bios; i have not hdderased any drive with 1704 bios, good to know that, because i updated the mobo with this bios a few days ago.

I also have always had good results with hdderase, the drives returning to its fresh state.

But a word of caution: on a G1 test drive the "enhanced secure erase" increased the number of "bad sectors" of the drive, and i stubborn as i am, tried several times this, and a not "scientifc" result, but i could say that 5 enhanced erases give origin to 3 more bad sectors on the drive, so....not to use enhanced but only secure erase.


Community Manager

Thanks Valdir and Guz for sharing your experiences with hdderase. It's really good to know that other people are having the same bypass bios message. And how they deal with it.


When i did the first hdderase and it locked up i hadn't read the readme or faq docs. But i have since, thanks for the link.

Currently working off an enhanced secure erase drive, because the documentation said it would return the drive to factory specs. Good to know about the bad sectors.

Valdir: Where exactly do you find the bad sector info - i don't see it in the smart data and i can't make heads or tails of the toolbox drive info.

thanks again for the posts. very helpful!!

New Contributor I

Hi Curious,

You can see the information about bad sectors in the Toolbox, under Check SMART Attributes, ID 5, Re-allocated Sector Count.

The number of bad sectors are displayed in a different mode for G1 and G2 drives, accordingly the "Intel SSD Toolbox User Guide" and for instance my G1 test drive has between 28 and 31 bad sectors, created by enhanced hdderases, BSOD's, many installations of OS's and general harsh drive treatment...

Eventhough, the drive works perfectly well and the Media Wearout Indicator shows that it has spent less than 2% of its "working life" (less because the User Guide says that afer the value reaches 1, there yet is significant "life" for the drive... and i hope so...

Another interesting parameter is Power-On Hours Count that aprox. indicates how many hours the drive was active; mine was on the road for 431 hours at that time.

Hope this helps.

Community Manager

HI Valdir,

thanks for the info - great to know what these numbers actually mean. I thought i was rough on my drive with about 5 clean installs in 6 weeks, but i see by your host writes that you keep yours pretty busy!!! Didn't know the toolbox could count that high!


New Contributor I

Yes, the drive has endured bravely and patiently many tests and mistakes i did.

Regarding the Host Writes parameter, somewhere in this forum, there were people claiming that in some cases it was not showing the correct numbers, since their new drive, with only one Windows installation, had over 3 TB of usage!!!!

I don't know if the 1.2 toolbox version has corrected this issue, if it really was an issue...



Community Manager

Hi Valdir,

good to know about the host writes, mine seems to be ok with about 650 gb writes on 5-6 installs and softwware updates.

thanks a lot for your help and sharing your knowledge

- curious

Community Manager

Hello again Valdir,

If you're still listenig to this thread, i have several other questions that i would like to take advantage of your experience and expertise, if you don't mind.

In your post dated 2-5, if i understand correctly, you said on the g2 drives you had to do a hard reboot (push the power button till the machine shuts off) then uplug the ssd power cord and reboot the hdderase disk, and run hdderase again. Does this mean you ran hdderase the second time without the power connected to your drive??? I am a litlle confused about how this works and if this is what you are actually doing- run hdderase the second time without the power connected. shutdown, Then reconnect the power and boot normally.

what i have been doing after my fiasco, is doing a hard reboot then running hdderase and it asks me again if i want to try and bypass the bios, which i do and the program seems to run fine. Says secure erase completed message.

Should i keep doing it this way or try disconnecting the power.???

thanks a lot for your time and help


- curious
New Contributor I

Hi Curious,

Thanks for your kind words but i'm not in any ways an expert, only a "curious" and a little stubborn consumer, but in this Forum do exist people that are truly experts in computer things...

Well, first of all you're doing the correct way, so keep doing this way.

In my post, regarding G2 drives, the old motherboard's bios did not allow hdderase to bypass the bios security freeze lock, and i had to do an alternative way to execute it. And i was informed by Guz that a new mobo bios corrects this behaviour. Nowadays i have updated the bios, but have not hdderased any G2 drive with this bios.

When hdderase is not allowed to bypass the bios lock (not your case) they say there are 3 ways to overcome this:

- to change the drive position, for instance from sata channel 1 to sata channel 4 on the sata mobo plugs (i'm presuming the drive is sata).

- to use another computer to do the secure erase, since the freeze lock depends on bios' behaviour and another computer's bios may not have this issue.

- when none of the precedents ways work, there is a workaround that is a little dangerous to the drive (the hdderase instructions are very clear about the risks involved, but i have never had any problem):

With the mobo's bios set to boot from the drive on which hdderase is, boot with the drive's sata power plug disconnected (and the signal plug connected); after you are on the hdderase DOS program, reconnect the power plug and run the program.

This fools the bios in not detecting the drive and not having a freeze lock command, and hdderase should run normally.

I have done this workaround (for G2 drives) a few times without any glitches, but i'd be more comfortable if i had not to resort to it.

Anyway your're doing the right way, and if you're in AHCI mode with Microsoft W7 drivers, TRIM will keep your drive in very good conditions, without having to hdderase it.



Community Manager

Thanks Valdir for the thorough response. much appreciated!! i guess i'll just keep doing it the way i have been - seems to work ok.

OFF TOPIC, but would like your input. I just emailed customer support with the following:

I bought a retail boxed ssd x-25m 80 gb from an internet retailer, and the product code and serial # on the Retail Box do not match the numbers on the drive itself.

I'm wondering did i pay for a retail box product and recieve a bulk or oem drive????



Prod. Code: SSDSA2MH080G2R5


Serial # : 1TFSRDFRSL



Model # : SSDSA2M080G2GC


Serial # : CVPO9466017W080BGN

Is this an oem or bulk drive, am i covered by intel's 3yr warranty?? Is this an illegal drive?

Please advise - thanks very much

ANY EXPERIENCE with these issues of serial numbers, etc????

thank you for listening

New Contributor I

Hi Curious,

From what i know:

- you have the right drive - the retail, covered by full Intel warranty.

- the retail box come in a box with Intel label and logo, instruction CD, 3.5 to 2.5" adaptor and manual

- the part nº .......80G2GC is the SSD itself, which is the same for the retail and OEM drive.

A full discussion about the terrible way Intel identifies the drives, you can se in the following threads:

- /thread/8492 ( a complete and funny thread with video!!)

- /message/69677# 69677 69677 (an authoritative information: afrosty is an Intel representative)

- /thread/6721?tstart=420 (there is some details of Intel numbering)

By the way, sometimes the customer service is not aware of all numbering details...


Community Manager

Hello Valdir,

I now know my drive is fine. thanks. very informative post with the links, which were very helpful information!!

I don't expect i'll get any reply from custoomer service. they're not very responsive. they never did answer my question aboout the correct offset for their ssd

thanks again

regards - curious