Showing results for 
Search instead for 
Did you mean: 
Community Manager

HP BIOS sees my x18-M, but Vista Install can't. Any clue?

Hi, I have just installed a new x18-M 160GB SDD on my HP 2730p Tablet. Everything seems to work fine. BIOS HDD test runs and answers with a "Passed". I have been able to upgrade firmware to 8820 version. I run firmware upgrade again and it says firmware is already upgraded. Anyway, OS installation can't see the drive.

I have tried the HP restore DVD and it ends with a message "Error 1012". I have tried a Windows XP SP3 installation CD and it says there is no drive to install the OS. I have tried a liveUSB key with GParted Live and the program is also unable to see the drive.

I have turned off TPM and reviewed any BIOS option I know that can be useful, but there are many other options that perhaps can help. I do not know what else I can do. Any ideas?

Thanks in advance.


0 Kudos
1 Reply
Community Manager

Hi, again. I have been looking for answers and finally I think I have them. XP install program seems to lack the needed drivers for this drive. My HP restore disk is either defective or does not support the drive and GParted seems to have the same problem. This has led me to wrong conclusions. My X18-M works fine. I have just installed Windows 7 RC from a DVD and everything has gone fast and smoothly. Now I only have to research if my restore disk is faulty or if it doesn't really support this drive. The latter should be strange, because there are 2730Ps with x18-M drives installed from factory (80 GB ones) and I doubt they have different restore disks.

Thanks for your attention.