Community
cancel
Showing results for 
Search instead for 
Did you mean: 
MKulp
Beginner
1,367 Views

Help connecting an Intel M.2 to a laptop

I've acquired an Intel M.2 SSD with a model # of SSDSCKJF240A5L. I bought a Sabrent M.2 SSD to 2.5-Inch SATA III Aluminum Enclosure Adapter and placed it inside, and then I put it in my Dell Latitude laptop. The UEFI of the laptop recognizes the drive (it sees the serial number), but won't list it as a boot device. If I attach it to Windows with a SATA-to-USB adapter it doesn't show up at all. Any ideas?

0 Kudos
6 Replies
idata
Community Manager
71 Views

Hello hammiesink,

 

 

We understand that have an Intel® SSD Pro 2500 Series (240GB, M.2) that you would like to use as the boot drive on your laptop. In order to do this you have purchased an M.2 to SATA enclosure/adapter.

 

 

Checking on the documentation for your enclosure, it seems to be a passthrough adapter. Meaning the system should be able to see the drive itself. In order to better assist you, we would like to know the following:

 

 

1. Was this SSD purchased used, 'salvaged' from an OEM system, or new?

 

2. Do you have any other computers where you could test by connecting the drive directly via M.2?

 

3. With the drive connected internally or via USB, does it show up at all on Disk Management?

 

1. To access disk management: press the Windows* Key + R to open the run dialog > type: "diskmgmt.msc" and press OK.

 

2. If it's detected here, please share screenshot.

 

 

We look forward to hearing back from you.

 

 

Best regards,

 

Carlos A.
MKulp
Beginner
71 Views

Hello Carlos and thanks for the reply.

1. The SSD is new.

2. I've connected the SSD (inside the SATA adapter) to a SATA-to-USB adapter and attached it to an existing Windows machine, but it does not show up in Disk Management

3. To be clear, the only place it gets recognized is in UEFI under "System Information" - it recognizes the serial # printed on the drive, but it won't show up in the list of boot devices in UEFI or in Windows

idata
Community Manager
71 Views

Hello hammiesink,

 

 

Based on this information we have three possibilities:

 

 

1. There is an issue with your laptop.

 

2. The SSD is a dead on arrival (DOA) unit.

 

3. The adapter is not working properly.

 

 

Option one is the least likely, and easiest to test. For this you'll simply need to test the drive either via SATA or USB on a different PC, where you should experience the same issues.

 

 

Please keep in mind that while M.2 and 2.5" are very different form factors, in this case they both work using the same interface: SATA. Since your M.2 to 2.5" enclosure is advertised as a pass-through adapter, we can expect it to translate one form factor into the next without modifying how your SSD works. Now, the point being that SATA drives have no special setup requirements, so this should not be an issue. All the same it might be good to check with the computer manufacturer for UEFI BIOS updates, which can sometimes help with compatibility.

 

 

Options two and three can be tested together, but would require either a second M.2 to 2.5" Adapter or a second M.2 SSD. If you install a second (known working) M.2 SSD on the adapter and it's detected normally, the issue is your SSD. If the issue persists, the adapter may be the problem.

 

 

If you're unable to perfom these troubleshooting steps, then we can recommend requesting warranty replacements for these devices (SSD and Adapter) either one at a time, or both at once.

 

 

From our end, warranty is handled by the place of purchase during the initial 30 days. If this period has passed or the reseller is unable to help, you may then place the request through our support team:

 

 

- https://www.intel.com/content/www/us/en/support/contact-support.html Contact Support.

 

 

After selecting Memory and Storage as the product, you will be able to choose from our support options.

 

 

We hope this information helps.

 

 

Best regards,

 

Carlos A.

 

 

MKulp
Beginner
71 Views

Ok I tested it on another machine. Strange that both machines see it in UEFI but Windows cannot. Here are photos:

https://goo.gl/photos/HvcYWHpJCovTRD3A7 Shared album - Martin Kulp - Google Photos

MKulp
Beginner
71 Views

Well it suddenly started working. I was able to format it and add files to it. Doesn't make any sense why it would suddenly just start working but there it is. Thanks for your help!

idata
Community Manager
71 Views

Hello hammiesink,

 

 

Perhaps the drive wasn't making proper contact with the M.2 slot inside? Regardless, we're glad to hear the issue has been resolved.

 

 

If there's anything else we can help you with, do let us know.

 

 

Best regards,

 

Carlos A.
Reply