Showing results for 
Search instead for 
Did you mean: 
Community Manager

How I think I Bricked my 520 SSD

I think I figured out how I bricked my 520 SSD. I somehow got an unknown password set in it. There is no way to clear or reset the mystery ATA password in this type of drive so it is dead. I have a lot of experience with hardware drive encryption and have used them many for years. So this was all pretty strange and took a lot of digging to resolve.

I searched the net for others having similar problems and there are a few that apparently did the some thing and lost their ATA password too.



I just want to warn you NOT to do what I did!


1. I was going to simply Secure Erase the drive to replace one version of Linux with another so I wanted a clean disk.

2. I used the usual Partition Magic Boot DVD to erase the drive using the secure erase command. I don't have any computers running Windows anymore so the Intel Windows programs are useless.

3. I turned off the computer, turned it back on, put in the DVD, and the ATA hard drive password prompt comes up.

4. I typed in the ATA password and the computer passed that step and booted off the CD and the tools all came up in Partion Magic. The SSD drive was there all ready to go.

Did you catch the mistake there!? Neither did I... But I NEVER CLEARED THE ATA PASSWORD! Intel's SSD tool box will not secure erase with the password set... But Partition Magic and a whole lot of other disk wiping tools will! They don't care because they will just reset the password to off or "NULL" actually.

5. I performed the secure erase with the option to reset the ATA password to NULL. It took the usual 1 second and reported that it worked just fine with no problems at all.

6. I put in the Linux software loading DVD and hit reboot.

"Reboot" does not ask for the ATA password so I did not notice a problem then.

7. The software loaded to the SSD just fine. I rebooted again and the computer booted off the SSD with the new software installed just fine. I made a few tweeks and updates to the OS no problem at all. It was running off the SSD perfectly.

8. I turned off the computer this time.

9. When I started it again... Now things when all to heck... It asked for the ATA password... Odd... I cleared that when I erased the drive like I had done maybe 50+ times before but with other drives... But I put in the password... WRONG try again.......

I tried every password, default, NULL... But it is none of them. God only knows what secure erasing with an existing password did... But it now has some strange password nobody knows.

I spent a lot of time trying to reset / erase / fix it, but nothing will work as so many of the posts in this forum have told. Once the ATA password is scrambled, the Intel 520 SSD is dead, bricked, useless. Unlike other encrypting hard drives, the 520 locks out with no recovery. Software really can destroy the hardware in this case. Apparently Intel wants it that way...


Only attempt to Secure Erase the Intel 520 SSD with the ATA password ALREADY removed. Apparently people have successfully used other than Intel erase tools to do this. But if the password is set and you try to secure erase it, very very bad things happen. The Intel Toolbox software, very oddly, forces you remove the ATA password first. So there is something going on there.

Tags (1)
0 Kudos
3 Replies
Community Manager

So, I have tried ALL my tricks here to bring the totally bricked Intel 520 SSD drive POS back to life... Nothing worked at all in the sinister hacker modes and all that. Intel really does completely destroy the 520 drive, just in their software, on a lost password event, as far as "I" can tell..

The thing is pretty much just a useless pile of 2oz of fine aluminum scrape metal now...

If anyone wants this worthless POS, for some scientific reasons...

PM me and I will send you what is left of the stupid POS thing for free...

If you can bust the ATA PASSWORD!!! You will see a nice and fresh Linux mint V.14 installation too!!!!!!!!!!!!

'Heck of a job there,' Intel...

I think there is a giant big bug in the Secure Erase function on the Intel 520 SSD drives. Be 'ultra sure' to remove the existing ATA passwords from these drives before attempting a secure erase!!!!!!!!!!!!!!!!!!!!! If you do not... The ATA password get set to some unknown thing... Might have to dig out a logic analyzer to find out WTF it was...

Like, cold dead power up the PC so all the HD reboot ATA passwords are for sure known defeated. If you attempt any form of Secure Erase with a per-existing ATA password enabled on the Intel SSD 520 drive... You will be giving them away as scape metal now, just like me...

Community Manager

piranha wrote:

The thing is pretty much just a useless pile of 2oz of fine aluminum scrape metal now...

The drive has a 5 year warranty. The details on the CD that ships with the drive has all the details. The warranty would exclude "usage not in accordance with product instructions, misuse, neglect, alteration, repair, improper installation, or improper testing." But it's not clear whether what happened to your drive would fall under the exclusions. Maybe just send it back as-is and see what happens.

Community Manager

Today was an interesting day...

As year end inventory comes, I told the interns to take and destroy that old Intel 520 SSD as it was just useless and so sad of a failed test now... Just get it out of here... They used bolt cutters on on the nine main chips and had a lot of fun! The aluminum shell was sent to the Al scrap can...

And so ends the experiment to see if the Intel 520 SSD was good or bad... Far far less than worthless in the end...

But then I got one of those, GET the f*** up here calls... An FDE encrypted laptop where the employee, bailed, jumped, quit , or did the usual equivalent... NO pass available... But an old style mechanical drive on a very expensive laptop machine... The drive maker was one of those "ocean door" highly reliable drives...

Of course, the all of information was destroyed in resetting it back to being useful... But simply secure erasing the drive reset the passwords and made all the hardware just fine and ready for action again. Reloaded the OS and the machine was perfectly good as new for the next user...

A very sad comparison... To makers like Intel that don't seem to understand that destroying the hardware with odd software is just a very stupid waste...

Quite honestly,... There is no reason at all not to make hardware recoverable in ALL cases...

I will not be buying anymore Intel hardware here if I can help it...