Showing results for 
Search instead for 
Did you mean: 
Community Manager

How to change your OS drive? - to Intel SSD G1

I have just bought a 1st gen Intel 80GB drive (yes I know, it does not support trim and so on... It was cheap and was what I could afford at the moment )



Searching the intel forums, I can see that this might be a bit more complex than I assumed.



Basicly, I have the Gigabyte GA-X58A - UD3R 2.0 and the OS disk is now a 160GB 7200rpm drive.


I also have a RAID 0 configuration with 2x Velociraptors, which I'm keeping



How should I install the new SSD?



1) connect to what port?


2) start W7 as usual, and flash drive with new FW in W7?


3) how to (best) transfer the OS image from the existing OS drive?


a) I have downloaded the Intel program for this (data mighration SW?)


b) I also have a WHS server - I know I can use this to restore the computer image completely to the drive.


4) how to setup in the BIOS?


a) IDE mode?


b) AHCI mode? (By the way - what is AHCI? )


5) I see there is also some posts about registry changes for the IDE/AHCI part. Is it possible to do this before I install the SSD?
Tags (2)
0 Kudos
10 Replies
Community Manager

I've installed it now - but is not "happy" about the speeds I get with HD Tune?

Did a run with both ATTO and HD Tune pro.


First with AHCI enabled, then with Raid enabled.



HD Tune Pro: INTEL SSDSA2MH080G1GC File Benchmark

Drive C:

File Size: 64 MB

Block size Read speed


0.5 KB 11687 KB/s


1 KB 22441 KB/s


2 KB 40681 KB/s


4 KB 72083 KB/s


8 KB 114692 KB/s


16 KB 162116 KB/s


32 KB 186515 KB/s


64 KB 200009 KB/s


128 KB 94637 KB/s


256 KB 73575 KB/s


512 KB 74384 KB/s


1024 KB 66946 KB/s


2048 KB 79359 KB/s


4096 KB 165475 KB/s


8192 KB 240802 KB/s

Block size Write speed


0.5 KB 8703 KB/s


1 KB 13763 KB/s


2 KB 23319 KB/s


4 KB 44040 KB/s


8 KB 31531 KB/s


16 KB 27887 KB/s


32 KB 33967 KB/s


64 KB 35554 KB/s


128 KB 36027 KB/s


256 KB 38978 KB/s


512 KB 40382 KB/s


1024 KB 56613 KB/s


2048 KB 66366 KB/s


4096 KB 67929 KB/s


8192 KB 82139 KB/s

I get better speeds from my Velociraptor Raid0 array (especially at the write part)

Have I done anything wrong?

Community Manager

Pics blocked at work.

The important metrics are the small file performance. Your VRaptors were getting 13MB/s for 1KB files?

Since you have HD Tune Pro, run the random performance benchmarks. This is where SSDs shine (and consider that 90%+ of OS/app disk usage is random).

Community Manager

Thanks both of you, I'll look into the "random test" part DuckieHo.

I'll just pressed "start", I can see now that this was with 64mb files or something?

Seems to be better results with the Raid controller enabled also (I can see somewhat better writing speeds on the SSD there)

Community Manager

SSD speed with Raid controller enabled

Community Manager

With the Intel RAID driver, which also enables AHCI (Advanced Host Controller Interface), the read and write results are better, although they also changed depending upon file size. AHCI enables NCQ (Native Command Queuing) which allows multiple IO requests to be executed at the same time on a drive, and also puts the IO requests in an optimal order. The latter function is not applicable to SSD, but is useful in HDDs. SSDs really must have NCQ enabled via AHCI/RAID in order to take advantage of their capabilities. Otherwise, the SSD may literally be waiting for the rest of the PC to use the data returned to it. With NCQ, the SSD processes more IO requests and has the data ready for use by the PC when it is ready for it. Since you had the RAID driver installed and active before using your SSD, you don't need to do anything to enable AHCI functions, you have them now, nothing more to do.

We should have mentioned that performing a Secure Erase on your G1 SSD would have returned it to it's optimal "new" state, or close to it. Your numbers look good IMO, and I imagine you have noticed it is overall faster than your HDDs. Or is that the case?

Community Manager

Thanks, this confirms my thoughts: my SSD is installed correctly And is working like it should.

You are right in your assumptions, my OS is now booting up much faster and is much more responsive. This compared to a 160GB 7200rpm disk.

(BTW, I did set it to "new state" with the secure erasing tool in the "Intel Toolbox")

Now, I have to try to update the FW of it. It seems to be a newer FW

Community Manager

Yes, you sure can't beat a SSD's IOPs and access speed. A forum member here that owns G1 SSDs likes them and seems to not have problems due to the lack of TRIM support. You might find his post's if you look at some of the older posts in the SSD forum.

I have done firmware updates on my G2 SSDs, and they worked fine, just follow the directions. I did them on multiple OS drives, and I never lost any data or compromised the OS, they booted right up after the update. I don't know if the G1 FW update info states otherwise, and the G2 FW update info did not guarantee zero data corruption, but I never had any issues.

The G2 FW update I performed didn't improve all aspects of the SSD's performance, and actually traded a little performance in one area to improve another. So just don't assume there will automatically be a big difference, some owners can have unrealistic expectations and are let down when it doesn't happen.

You might like to try another benchmarking tool designed with SSDs in mind. It's called AS SSD Benchmark, available here free:

With this you can view more specific SSD performance parameters, such as IOPs, before and after the FW update. It's also easier IMO to detect any significant performance decrease over time.

Community Manager

I'll check out that one, might be a better tool to check the SSD for the performance on a regular basis.

I suppose I (if I see a significant decrease in performance) just do the "Secure Erase" part and I can restore my SSD backup image from my Windows Home Server?

regarding the update of the FW:

I tried the FW update yesterday, I got an error when Freedos loaded.

Something with a error of the parameter? Strange- I will take some snapshots and post later.

Thank you Parsec, your insight and comments are highly informative and very helpful.

I browse a lot of forums, and people like you really help sharing good information.

Community Manager

Well thanks, I appreciate that! Yes, restoring from an image is what people usually do, the only potential problem is the alignment of the SSD, but using Win 7 to format the SSD after the erase should be fine.

Your FW update problem is curious, I don't know what to tell you about that. In some FW updates, the SATA mode needs to be changed, such as from AHCI to IDE, but that should be stated in the instructions. Did the release notes or readme mention anything like this? You might want to double check them and see. You may need to switch from RAID mode which you are using, correct? Maybe just a glitch in the iso disk? Post those screen shots if possible.

If you use AS SSD to check your SSD's performance, it's common to see small variations between test runs, either up or down. That's normal given what I have seen and nothing to be concerned about. You'll know when the SSD needs a refresh, both in use and testing, as the numbers will drop significantly.

Community Manager

I'd say the numbers you are seeing in the benchmarks are right for a G1 80GB SSD. The smaller Intel G1 and G2 SSDs did not have spectacular write speeds, as can be seen in the reviews of those products. In writes, they are out-performed by good HDDs whether in RAID or not. The G2 80GB SSDs are rated at 80MB/s at best. Check the specs and performance of the Intel 40GB SSDs in writing, they are not very good.

SSDs are much more variable in speed depending upon the size of the files compared to HDDs. It's the same for the reads with SSDs, more so with earlier models.