Community
cancel
Showing results for 
Search instead for 
Did you mean: 
OSiu
Beginner
1,419 Views

INTEL 750 PCIE SSD no longer detected

Hello,

I recently purchased an Intel 750 series PCIe 400GB ssd. I do not use it as a boot drive, just a secondary drive for storage/games. It was working fine for about a month and a half or so, but just today it is no longer detected in my bios or in my computer as a secondary drive. The LEDs on the back of the ssd slot is still lighting up as if its operational. Anyone know if this may be a faulty unit? I have tried moving the drive to other PCIe 3.0 slots and it still does not detect it. It just stopped working all of a sudden today when I booted up my computer, tried reinstalling the drivers and even made sure my PCIe slots were all still in working condition by swapping my gpu. Any assistance is appreciated.

Computer specs/hardware.

i7 3770K cpu

Gigabyte z77x UP7 motherboard

0 Kudos
3 Replies
ASouz7
Honored Contributor II
120 Views

Snorex1,

In this particular case that you tried the SSD in different computers and check all the slots in order to check if they are all operational and yet the SSD was not detected. We recommend that you contact your nearest Intel Contact Center for other options of support. Click on this link: http://www.intel.com/content/www/us/en/support/contact-support.html Contact Support

OSiu
Beginner
120 Views

Hello Aleki,

Thank you for the reply. I have submitted a service request but I am having trouble viewing it. I keep getting error messages when I try to login to view my update on the request.

Can you please look into my request # 00228789 and provide the updates here or by a message to my inbox. Thank you!

ASouz7
Honored Contributor II
120 Views

Snorex1

Thank you for the information. This case number 00228789 is already under the care of one of our technician. He already sent you an email. Please check your inbox at your earliest convenience and reply accordingly for proper support.

Reply