Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
972 Views

Intel 320 freeze problem

I have a problem with Intel 320 80GB. Several times I have had system freezes (from 10sec to 30sec). I own drive from two months.

I'm using linux.

DMESG:

http://shorttext.com/TyBZxD http://shorttext.com/TyBZxD

hdparm -I

http://shorttext.com/EAfvZ1 http://shortText.com/EAfvZ1

fdisk -l

/dev/sda1 * 1024 41945087 20972032 83 Linux -- xfs

 

/dev/sda2 41945088 46140415 2097664 82 Linux swap / Solaris

 

/dev/sda3 46140416 156301311 55080448 5 Ext

 

/dev/sda5 46140448 47779839 819696 83 Linux -- reiser

 

/dev/sda6 47779872 51975167 2097648 83 Linux -- reiser

/dev/sda7 51975200 156301311 52163056 83 Linux -- ext4 with discard (TRIM)

smartctl

http://shorttext.com/jxBTik http://shortText.com/jxBTik

Controller

00:05.0 IDE interface: nVidia Corporation MCP55 SATA Controller (rev a2)

I tried with other SATA cable, didn't help.

Any help please.

Tags (1)
0 Kudos
3 Replies
idata
Community Manager
62 Views

Drive looks to be in perfect health according to all of the SMART attributes. Your issue is probably due to daemons running on Linux in the background which are doing I/O to your drive. dmesg, smartctl, df, etc. aren't going to help diagnose this. Things like sar or iostat or top -b in a while loop logging to a file might. Furthermore, you should investigate TRIM support on Linux -- it is something you do have to turn on, if I remember right (I'm a FreeBSD guy, not Linux).

idata
Community Manager
62 Views

usr wrote:

Controller

00:05.0 IDE interface: nVidia Corporation MCP55 SATA Controller (rev a2)

There's your problem. There are compatibility issues between nvidias fake-AHCI and SSDs. The usual solution is to run the controller in IDE mode and make sure to disable Command Queueing in the driver. How you would do on Linux I have no idea.

idata
Community Manager
62 Views

Thanks for replies.

I'll check the TRIM.

Two years ago I had a Kingston SNV125-S2/40GB with Intel's hardware inside but without TRIM support and that issue didn't occur... (the same controller and operating system). What do you think now ?

Maybe it's elevator=noop ?

cat /sys/block/sda/queue/scheduler

 

[noop] deadline cfq

I'll check it too.

Beside I forgot to write about the scenerio this issue. It happens (rarely but...) when I unpacking kernel or installing compiled app/package.

Reply