Solid State Drives
Support for Issues Related to Intel® Solid State Drives
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
4365 Discussions

Intel 520 (120gb) does not read in BIOS

Community Manager

Hey there, newbie to SSDs here. About a couple of months ago I installed the SSD as my boot drive. No issues really at the time, but I did not realise you needed to update the firmware.

Then last week as I was installing a new HDD, the computer would not boot. I opened it up and everything is connected fine, I even swapped a few sata cables to see if that was it. My other drives ALWAYS read ok. At first the Intel SSD was only intermittently working. When I would load it up, it would be incredibly sluggish to the point that after about 30mins I would have to shut it down. Now the drive hasn't read in about a week. I've tried resetting the cmos to get the drive to read, it worked for a while but not long enough for me to download and run the Firmware update.

Any ideas what's up with it? Don't think the drive is faulty as such, but rather something I'm doing. Any ideas on how to get the drive to read long enough to run the update? Or is there another way?

0 Kudos
1 Reply
Community Manager

I've been using a 520 for several months, as far as I am aware there has never been a firmware update for the 520 series drives, the current firmware is 400i. There have been updates to the Intel SSD Toolbox, the current version is 3.1.1. And it would be through the toolbox that the firmware updates but again, even after a few releases of the toolbox there have been no firmware updates. My drive has been rock solid reliable.

Not much more to offer other than installing the latest toolbox, make sure you are using a good SATA cable and everything is connected up firmly. If you can get the drive working run the toolbox, run a quick diagnostic scan, and of course you should have been running the optimizer function weekly.