Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Community Manager
1,658 Views

Intel 520 60GB Slow Write Speed issue

Hello,

I bought an Intel 520 60GB SSD yesterday. I have a Maximus IV Gene-Z board. Plugged SSD to my sata3 connection. I am using Sata mode in RAID.I had checked with different benchmark tools. AS SSD Seq Read Speed 450MB/s which is normal i guess but my Seq Write Speed is 90MB/s which is much lower. Also i had tried to connect to Sata2 connection and Seq Read Speed down to 260MB/s but Seq Write Speed still 90MB/s.

Intel Toolbox installed and all seems normal. Firmware is 400i. There is nothing on the SSD, my system is on 2xSata2 Caviar black @ RAID 0 128K Stripe mode. Is this problem related with the Sata RAID mode? Cause i did not check with AHCI mode. Or the SSD is not working correctly?

Anyone have a opinion about this issue?

Thanks.

0 Kudos
4 Replies
Highlighted
New Contributor II
10 Views

that's the correct performance for that drive when dealing with incompressible data.

0 Kudos
Highlighted
Community Manager
10 Views

Thanks for the reply mistermokkori,

Could you also check if these scores are normal? Cause it seems not normal to me?

0 Kudos
Highlighted
New Contributor II
10 Views

the scores look about right. what scores are you expecting to see?

sandfarce-powered drives like the 520 will show lower than advertised write speeds when run with benchmarks like as-ssd and crystaldiskmark that use incompressible data. the lower capacity drives - especially the 60gb versions - are hit hard by this.

if you want a faster 520, buy the 120gb or 240gb version. if you want to see benchmark numbers that match the drive's advertised speeds, run a different benchmark that doesn't use incompressible data. if you want a drive that performs the same regardless of the compressibility of the data, buy a different drive that isn't powered by sandforce.

otherwise, stop benchmarking the drive to death and just use it.

0 Kudos
Highlighted
Community Manager
10 Views

Also i want to use this SSD for Intel Smart Response to accelerate my RAID 0 disks. When Smart Response turned off, my RAID Read 240 and Write 190 MB/S but when turned on, Read down to 110 MB/s and write to 90 MB/s. So where am i doing wrong for Smart Response?

0 Kudos