Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
1,448 Views

Intel 520 SSD (120 GB) cannot install Win 7 / Win X

Hi!

My Intel 520 SSD seems to be recognized, sort of, but I cannot selected it to install Windows on it.

My build:

MOBO: GIGABYTE GA-970A-UD3 (rev. 1.0)

CPU: AMD FX-8350

RAM: Corsair 16GB DDR3 1866MHz (2x8) Vengeance

SSD: Intel 520 SSD Series - 120GB

 

BIOS settings:

SATA: AHCI

S.M.A.R.T.: Tried both enabled and disabled.

What i found:

  • When i select boot priority in the BIOS, the Intel SSD shows up.
  • When i try to install Windows 7, the SSD is not in the list of drives you can install on.
  • When i browse for drivers in the install walkthrough I get a list of drives; one of which is the SSD! When I select the partition (here drive C:) I get the following message:

"You need to format the disk in drive C: before you can use it.

Do you want to format it?"

When selecting "Format disk", i get this message:

"Windows can't format C

Check to see that the disk and drive are connected properly, make

sure that the disk is not read-only, and then try again. For more

information, search Help for read-only files and how to change them."

Troubleshooting:

Tried installing Win7 x64/x86, Win XP x86. Neither could select the Intel 520 SSD for installation.

Tried with only the SSD and DVD-reader connected.

 

Connected another HDD to the build using the same power and data cables in the same slots, and successfully installed windows 7 on it.

Questions:

  1. Am I supposed to provide a driver for the Intel 520 SSD during Windows installation?
  2. Am I doing something wrong?
  3. Is the drive defective?

Tags: Intel 520 SSD (120 GB) cannot be formatted/selected for install - Win 7 x64 - Win 7 x86 - Win XP

Tags (1)
0 Kudos
3 Replies
idata
Community Manager
56 Views

arnemahl wrote:

When i try to install Windows 7, the SSD is not in the list of drives you can install on.

Questions:

  1. Am I supposed to provide a driver for the Intel 520 SSD during Windows installation?
  2. Am I doing something wrong?
  3. Is the drive defective?

I believe I know what the problem is. Your motherboard isn't Windows 7 supported natively in AHCI mode. You need to go to the Gigabyte website and download the AMD SATA AHCI Driver (not RAID) F6 driver for your motherboard model. Also make sure you have the SSD connected to SATA port 0 and it's set to native mode, not legacy or RAID.

idata
Community Manager
56 Views

Thanks for the reply. However, I'm still not getting it to work.

I downloaded the newest AMD SATA AHCI driver, but during Windows 7 x64 installation, it's claiming there are no signed drivers. I have tried putting it on a USB-stick, another HDD and on a DVD. I can browse (folders, not files) and see the the other HDD and the DVD, but Windows doesn't recognize the driver.

Even when i uncheck the box for (quote unquote) 'show only hardware-compatible drivers', there's still nothing.

How am I supposed to supply the driver to the Windows installation?

idata
Community Manager
56 Views

I found a solution!

Using GParted*, I partitioned the Intel 520 SSD.

  1. Create partition table (I chose msdos)
  2. Add partition (I added only one (1), spanning the whole disk. Filetype NFTS)
  3. Click 'Edit' -> 'Apply all operations'

After that, Windows 7 installation found it right away!

Anyway, thank you for the help, I had all but given up yesterday!

Also creds to Darryl Licht for suggesting it here.

*Tip: I ran Linux Mint off of a DVD. Linux Mint includes GParted. That way, you don't have to plug the HDD/SSD into another PC to format it.

Reply