Solid State Drives
Support for Issues Related to Intel® Solid State Drives
4376 Discussions

Intel 520 Series 120G SSD random BSOD's - please help

idata
Community Manager
4,432 Views

Gday guys,

just wanted to humbly ask for some help. I've recently fitted a new 520 Series SSD into my PC and im getting random BSOD's. I've had 2 today so far after loading a fresh installation of Windows 7 Ultimate 64 early this morning. I wasnt doing anything taxing (just using Firefox and copying files to another PC over ethernet).

My hardware:

Gigabyte P67A-UD7-B3 running 2nd latest BIOS.

8Gb Corsair Vengeance RAM

2x GTX570's in SLI

2Tb WD RE4

1.5Tb WD Green

72Gb WD Raptor.

LG Blu-ray

History:

I had an OCZ Vertex 2 fail completely in my machine last week. No history of any problems before that. I fitted a backup SATA HDD till i received the Intel 520 i planned to replace the Vertex with. No issues with the backup SATA HDD running in IDE mode.

I fitted the intel 520 and initially set it up using IDE. Realising i should have set it to AHCI, i tried the registry tweak trick but it didnt work and wouldnt load windows on reboot anymore. So re-installed Windows fresh using AHCI. Loaded the latest Intel inf drivers, RST drivers and the other mobo drivers from Gigabyte. I also flashed the BIOS to the most recent non-beta version.

First issue was the extremely slow boot times (2 mins to desktop). After i was at desktop, there didnt appear to be any problems except for the first BSOD. Tracked the slow booting problem down to the 1.5Tb WD drive. If i remove it, the boot time is only about 20 secs. Fit the drive, and its back to 2mins. I plan to replace that drive this week but will leave it fitted for now to remove data from it.

Most annoying issue atm is the random BSOD's. The first time it happened, it was too quick and i didnt see the code/ file. No dump file either. I changed windows settings to catch the next one and it happened a few hours later calling a MSRPC.SYS file.

Problem signature: 

Problem Event Name: BlueScreen

 

OS Version: 6.1.7600.2.0.0.256.1

 

Locale ID: 1033

Additional information about the problem: 

BCCode: 7a

 

BCP1: FFFFF6FC4000CA68

 

BCP2: FFFFFFFFC0000056

 

BCP3: 0000000127165860

 

BCP4: FFFFF8800194D780

 

OS Version: 6_1_7600

 

Service Pack: 0_0

 

Product: 256_1

Files that help describe the problem: 

C:\Windows\Minidump\020412-120214-01.dmp

 

C:\Users\cylon2\AppData\Local\Temp\WER-121867-0.sysdata.xml

Read our privacy statement online: 

http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409 http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline: 

C:\Windows\system32\en-US\erofflps.txt

Im not sure what to do now. Im just waiting for it to crash again to gather more data i guess. I've read that the Sandforce controllers can cause BSOD issues but i would have thought intel would have ironed those issues by now if theyre using it on their new 520 series. You guys have any thoughts on this?

Apart from swapping the HDD out with another one, is there anything else i can do to narrow down/ force the problem? Maybe its the AHCI playing up? Maybe its not the SSD, but the history of events points towards it. Am tempted to try installing Windows again in IDE mode to see if that changes anything. Is there any special "drive erase" that i should do before reloading windows in IDE mode? Ive just been formatting the drive as per normal.

Would appreciate any advice at all guys. Bit disappointed and have had my head in the pc case for some days now and quite frustrated. Need to get up and running to continue my work. :-| Thanks for reading so far.

Cheers

Anthony

0 Kudos
33 Replies
Vegan
New Contributor I
133 Views

Hook them up as just a bunch of disks and then download the Intel SSD Toolkit and use it to check each drive individually for problems.

Use AHCI mode, no need to use the legacy EIDE mode.

Do not use RAID for this test procedure.

idata
Community Manager
133 Views

I'll try that on the weekend, I've tried running with c-state off and on, is there any bios options that might help?

maybe Load-Line Calibration?

I'm running a P6T mobo, i7 920

3 x WD - raid 0 - 1 x ssd (boot) 64k

if anyone can do a google search for ASUS P6T Deluxe OC Palm Edition X58 Motherboard

the site goes into all the bios options, or google image search for p6t bios options and there pretty much exactly the same for my stock P6T

I had it running for about 3 days with no bsod, i then returned everything to stock bios since i was trying to OC at the same time, and now everything is at stock and i'm getting a bsod nearly every day.

I did add that reg tweak - turning off LPM, should i remove it?

idata
Community Manager
133 Views

I have 3x 520 Series SSD's (240 GB Cherryville's)

I have 2x 535 Series SSDs(240GB)

I have never observed a Bsod from any of these SSDs. I have had them hooked up to a 2500k/Z68A, and now their all Raided up on a Devils Canyon 4690k/Z97 Sabertooth Mark 2.

The 535 Series are a hair slower than the previous 520 Series Cherryville, which I'm not happy about, but they were a meer $87 each.

Intel makes the fastest and most reliable SSDs on the market today, yesterday, and 10 years ago, before Samsung knew how to make SSDs......

ExtremeTech.com completed a SSD torture test, a simple on/off test, with ONLY Intel's SSDs coming out with a NEVER-FAIL result.

All other brands; Crucial, Samsung, Sandisk, OCZ, etc, all failed the simple on/off torture test.

Here's the test results-

http://www.extremetech.com/computing/173887-ssd-stress-testing-finds-intel-might-be-the-only-reliabl... SSD stress testing finds Intel might be the only reliable drive manufacturer | ExtremeTech

GVasi
Beginner
220 Views

Hello guyz,

I am experiencing 0x0000F4 random BSOD's with an Intel 520 240GB.

The disk is connected to the Sata 3 port of a Gigabyte P67 UD4-B3.

I've tried this:

1)Secure Erase via Intel Toolbox,

2)LPM Fix,

3)v10.8 & v11 Intel RST Drivers,

4)Modded BIOS with updated Intel ROM,

5)C3/C6 State Disabled,

6)Different SATA/Power cables,

7)The install of Windows 7 is fresh (AHCI),

Any other Ideas??

The Drive performs normally, but It seems to me that it suffers from the SandForce Bug too.

GVasi
Beginner
220 Views

No one knows smth?

A also tried to set Power Options to High Performance (this definitely disables LPM).

But NO Luck at all.

Also i got BSOD after the intel optimizer runs.

idata
Community Manager
220 Views

Looks like I'm not the only Intel 520 SSD (120gb) owner suffering with the dreaded 'F4 BSOD'.

The main reason I bought this drive was that Intel's firmware had supposedly fixed this (once common) Sandforce bug, according to anandtech's review. So I was somewhat disturbed to get the F4 crash the first time I left the PC to idle overnight. It has only happened twice since, but I rarely use the PC for more than an hour or two before switching it off.

I'm 99.99% certain it's caused by the SSD, as restarting after the BSOD 'loses' the drive (in BIOS), which returns after a power off/power on cycle - the 'classic' Sandforce symptoms. Plus I've never had any BSOD's before (in over a year of use), except when trying overambitious CPU overclocks (the SSD problems have occurred since I set the CPU back to stock).

 

I'm running Windows7 x64 Ultimate, a clean install with AHCI enabled. The SSD is connected to the Intel 6gbps (Port0), and is the OS drive, ie not used for cacheing. Intel SSD Toolbox > System Tuner is happy with everything.

My system is :

 

i5-2500K @ 3.3MHz (stock)

Gigabyte Z68X-UD3H B3 (Rev. 1.0) - F11 BIOS

16gb (4x4) Samsung Green 30nm @ 1866MHz/9-9-9-27-1T

120gb Intel 520 - 400i Firmware, Toolbox 3.0.2, IRST 10.8.0.1003

+WD HDD's, Corsair HX650, MSI 6870 Hawk etc.

Any ideas?? I haven't tried the 'LPM fix', as

1) it's suggested for a SSD with a Marvell controller,

2) I'm wary of touching the registry, and

3) I don't like disabling power management features.

P.S. I get the same Power Cycle Count = Unexpected Power Loss = Unsafe Shutdown Count 'niggle' that has been raised by others. Any news?

P.P.S. @skiman re: poor write speeds in ATTO - If you're using the Foxconn SATA cable supplied with the SSD, try a new cable. The flat cable is folded far too tightly, and caused me a headache until I replaced it with a decent one (that came with the mobo). It gave a very similar ATTO report, where the write speed peaks around QD32/64 and then drops off, never reaching 500MB/s. Intel should know better!

DShar11
Novice
220 Views

Not sure guys, I have had no bsods with these drives that I am aware of. They have actually been much more resilient than I thought they would be. It seems from your posts that you have done what can be done. I might try to toss the irst drivers and just go with the achi drivers to see if that helps.

idata
Community Manager
133 Views

"I might try to toss the irst drivers and just go with the achi drivers to see if that helps."

I would have hoped that when getting an Intel SSD to talk to an Intel chipset, the Intel drivers would be good-to-go, rather than generic M$ ones. But then I'm an optimist.

Maybe some of these 'fixes' will help somewhat (AHCI vs IDE, msahci vs IRST, LPM/sleep/hibernate states etc.) but I'd like a definitive answer or firmware fix. OK so I'm not running a multi-national company on this PC, but I regard any stability issues with my primary OS drive as very serious, however occasional and recoverable. That's why I paid 50% more for an Intel product, believing these issues had been resolved (according to anandtech at least) :

http://www.anandtech.com/show/5508/intel-ssd-520-review-cherryville-brings-reliability-to-sandforce http://www.anandtech.com/show/5508/i...y-to-sandforce

"...although Cherryville performs very similarly to other SF-2281 drives, it should be more reliable."

 

"The BSOD is Back, but Not on Intel"

 

"Switching to Cherryville caused Brian's BSODs to go away."

 

"Whatever Intel has done with the 520's firmware seems to have fixed problems that still remain in the general SF-2281 firmware."

Other sites/reviewers were equally impressed, but this one went into detail of how Intel's validation testing (over 10-12 months) had finally eliminated the Sandforce BSOD. And while the Intel 520 is probably one of the best of the Sandforce drives, there are plenty of unaffected SSD's generally using the Marvell controller (which I won't list on this forum, but include a Motorway joining London and South Wales ).

Overall, my disappointment with this SSD has cancelled out the awe for my i5-2500K, which any SandyBridge owner will tell you is quite considerable.

idata
Community Manager
133 Views

Just want to clarify. What you are saying is that 520 series has issues with Sandy Bridge? I have an HP Envy 17 with HM67 chipset and am about to drop some $$$ on the Intel 520 / 240 GB SSD. Is this BSOD issue random or P67/H67/HM67 related??/

Thanks

idata
Community Manager
133 Views

The BSOD is not related to any particular chipset, AFAIK it can affect Intel/AMD/Mac systems, and Windows/Linux/OSX etc. It relates to the Sandforce (specifically SF-2281) SSD controller, which is used in the majority of SATA-3 (6gbps) SSDs on the market.

NB - Don't confuse SandyBridge with Sandforce.

SandyBridge is a great platform with varied chipsets (H61,H67,P67,Z68) and some truly awesome CPUs (eg. i5-2500K and i7-2600K) which offer unrivalled price/performance, massive overclockability and adequate integrated graphics.

Sandforce make the fastest SSD controllers (thanks to on-the-fly compression which increases transfer speeds while reducing NAND wear) but which still suffer from compatibility/stability issues. This is the controller used in the Intel 520 series.

Personally I'd avoid all SF-2281 drives for now. You might be lucky and have no issues or... you could play it safe and get a non-Sandforce SSD. (I'm not even sure if your HP laptop will support SATA-3, in which case a SATA-2 drive would be fine.)

idata
Community Manager
133 Views

Wasn't confusing the two. I just noticed that some of the issues are with those who have P67 chipset...so I asked. I had no intention of any Sandforce controlled SSD, until the 520 series was released. Supposedly, Intel figured out the issue and fixed it...guess not.

My Envy is SATA III on Port 0 and SATA II on Port 1. SATA III drives work full speed.

Thanks

GVasi
Beginner
133 Views
DShar11
Novice
133 Views

In W8 the drive optimizer no longer works for me, not on a single ssd or an R0 array. It did before so I guess MS nerfed it with an update for now.

Thought it was funny that MS could figure out how to trim an R0 array but Intel cannot.

Reply