Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
5,798 Views

Intel 520 freezes on MacBook Pro/Mac OS X Snow Leopard

Hi all,

I installed an Intel 520 SSD (240GB) in my MacBook Pro yesterday. After reinstalling the system, I moved my datas.

I encounter freezes! A few seconds freezes/hangs. Quite often actually.

It seems a bit random but it is really annoying! The whole computer is frozen.

I noticed it happens more often when a lots of datas are going in and out. Browsing the web doesn't do much things. Copying a file from a disk image (DMG) to desktop, it freezes… sometimes.

The SSD has the 400i firmware. I installed the drive in the HHD bay. Negotiated Link Speed is 6 Gigabit. MacBook Pro EFI is up-to-date. Software is up-to-date.

I haven't activated the "Trim Enabler" software (Mac OS X doesn't manage for 3rd party drives).

I cannot run the SSD Toolbox from my Mac. I'll try to install Windows and see if it hangs up.

Have you heard about these problems? What can I do? I don't want to keep a drive behaving like this!

Thanks for your help,

Tags (2)
36 Replies
idata
Community Manager
211 Views

Same issue here. I'm on a MacBook Pro 5,1 running Lion. Just installed a 520 Series 240 GB Intel SSD, and am noticing irregular and unpredictable complete stalls of the system. Everything freezes. Cursor still moves, but everything else freezes. Other times, only a particular app will freeze (beach ball). Any help would be much appreciated.

idata
Community Manager
211 Views

I have noticed in the Activity Monitor, that during the course of these "stalls" that I/O activity on the drive completely drops to zero for the duration of the stall. Is this an issue with the SSD or an issue with Mac OS X Lion?

idata
Community Manager
211 Views

Hi Mark,

You perfectly described the problem. It is like that on my MacBook Pro too. I didn't find a specific reason for the hangs and freezes. I seems random.

I also noticed that I/O activity drops to perfect 0 during the hangs.

I have a MacBook Pro 8.2 and I am running Snow Leopard. So I would say, whether the driver is really bad or there is a problem with the controller. Some says the SandForce controller behaves badly with Mac systems.

I called the Intel support yesterday and they told me that I had to contact Apple and ask them if they knew about issues with this specific model of SSD. I am planning to do that today.

idata
Community Manager
211 Views

Well, without any sign of a solution, and the problem completely rendering this MacBook Pro unusable, I exchanged the Intel 520 for a Crucial M4 256GB and everything is working perfectly. So, there's clearly something wrong with the Intel firmware or controller that is conflicting with the Mac hardware or OS. Could be a million things. Hope this helps.

idata
Community Manager
211 Views

Thanks for your reply.

I contacted the Intel support who told me to contact the Apple support and ask if they knew about incompatibilities. The Intel support also told me that it should whether work at the first time or not at all as there are no ways to tweak things around (which is the case on the MacBook Pro).

The support at Apple wasn't very helpful "as it is not a part coming from us, we do not do support for this". I was just asking for a yes/no answer about "do you have feedbacks about this drive". Apparently, they don't. Apple said they will investigate the case but I think it would have to call them back and talk to a senior adviser to be sure about it.

I now have a case open at Apple as well as a ticket number at Intel.

If there is someone from Intel reading this, I would be very happy to help to test a new firmware or a new solution.

idata
Community Manager
211 Views

im having the same issue. Mac freezes randomly with spinning beach ball of death, I even reinstalled Lion and same issue happening still, I never had this problem with spinning HDD. I hope they are working on fix for this, as it is really annoying having to restart all the time.

Please update us on your progress, as it would be great to get a fix for this! Thanks

idata
Community Manager
211 Views

I have the same problem with an Intel 330. I'm trying to use fs_usage, so that when the OS freezes I will have a clue of what's happening.

idata
Community Manager
211 Views

Same issue with 520 on lion with and without trim enabler.

I hope Intel is looking into this, as it seems to be either a firmware or a hardware issue. It should not be caused by Lion, as it would just use the SATA interface of the disk.

Let me know if you need any debug information.

idata
Community Manager
211 Views

I am also encountering 15-second beach-ball freezes when OSX 10.7.4 writes memory pages to disk on an MBP 5,2 with 8GB of RAM. I used the Intel SSD 520 180GB without issue from April through the beginning of July. TRIM is not enabled. The drive is filled to 70% of capacity.

In my case, I believe this is just the Intel SSD performing internal housekeeping and garbage collection because TRIM isn't enabled in OSX. Keep your SSDs at below 50% capacity and performance should increase. I am enabling TRIM and I'll report back if anything changes.

EDIT: Enabling TRIM support fixed all "beach ball" issues in OSX 10.7 and 10.8.&# 13; http://www.groths.org/?page_id=322 http://www.groths.org/?page_id=322

idata
Community Manager
211 Views

I put a 240GB 520 into a MacBookPro5,1 running 10.6.4 and encountered this exact problem. After poking around the internets and figuring how to enable TRIM the problem seems to have gone away and I am getting solid 100MB/s write performance.

Let's hope this sticks.

/nqp

idata
Community Manager
211 Views

There's also a thread about the 330: /message/163142 http://communities.intel.com/message/163142

People experiencing exactly the same problem.

It's really a shame no one from intel is looking into this :-(

idata
Community Manager
211 Views

I have the same problem with 520 on Mac OS 10.8 (Mountain Lion), which makes using 520 counterproductive (it's beachballing all the time).

I thought it might be fixed by firmware update, but I couldn't find any references to current 520 firmware version, is it 400i?

idata
Community Manager
211 Views

Same exact problem here ... Intel 520 SSD running on a MacBook Pro Early-2011 15" 8,2. What's interesting is that when this happens I try to into "System Report" under About This Mac and when I click on the Serial-ATA section nothing shows up. All the other sections appear fine.

idata
Community Manager
211 Views

I do not have this problem, mine shows up allright and with correct info.

idata
Community Manager
211 Views

Mathias, Do you have an Early-2011 Macbook Pro 15"?

idata
Community Manager
211 Views

I have the 13", primo 2011, so i believe it is the same controller.

idata
Community Manager
211 Views

I found the issue. I had a corrupted Time Machine USB disk and when the backups would start it would lock everything up. As soon as I removed the bad USB drive everything went back to normal. Hasn't locked up since!

idata
Community Manager
211 Views

I have 15" early 2011 as well. Actually, I have tried to put a drive into another laptop of the same model with a clean OS install -- same problems, so it's clearly reproducible.

idata
Community Manager
211 Views

After dicking around with the TRIM tools I came into conclusion they have nothing to do with the hangs. With MBP 5,1 running 10.6. there seems to be no sensible way to avoid the 20s beach ball once every 5 minutes.

The spookiest bit I found was someone doing hacked EFI images that "should fix" the issue but gladly there wasn't one available for 5,1 so I skipped that. Back to spindles it seems