Solid State Drives
Support for Issues Related to Intel® Solid State Drives
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
4365 Discussions

Intel 660P 2TB M2 drive not showing up at all

emorimiku
Beginner
356 Views

About a year ago I built a new computer and as part of that I got a Intel 660p 2TB M2 drive from a friend. But after I put everything together I had difficulty getting the drive to work. I think I've only seen it in the BIOS menu once and even then I wasn't able to get it to work in windows. But after I saw it in the BIOS maybe twice the drive no longer appears and I haven't been able to figure out any solution to the problem. I was planning on just trying to get a replacement drive, but I'm uncomfortable with that without really knowing that the problem is the SSD or if I broke it somehow.

 

Any help is appreciated

0 Kudos
5 Replies
LeonWaksman
Super User
340 Views

I haven't enough information about your system. In order to get better information about your system, please download the Intel System Support Utility (SSU). Run the SSU scan and save the results. The .txt file with the results please attach to your post. However, form the attached image it's looks to me that UEFI boot is disabled in your BIOS. The Intel 660P Series SSD is an NVMe drive. It's requirement for NVMe drive to have UEFI boot enabled and Windows installed accordingly.

Leon

emorimiku
Beginner
302 Views

I added the SSU text to my original post. After I made that file I changed my boot disk to GPT and I think I enabled UEFI on my BIOS (I disabled CSM Support). The Intel is still in my machine, but I'm still not seeing it represented either on the BIOS menus or in windows.

n_scott_pearson
Super User Retired Employee
297 Views

I am catching nothing odd in the SSU report. I would check to see if the drive is properly inserted in the M.2 connector. Be prepared: You may simply have a bad drive. 

...S

Vegan
New Contributor I
286 Views

try removing the SSD and reinstalling it again just in case the connection has some foreign material that may be affecting the connector

make sure your BIOS is set for UEFI

 

 

emorimiku
Beginner
274 Views

Seems like the SDD isn't working. After I realized that I don't have some of the information to get a warranty replacment I ordered a new SSD (Samsung 970 EVO) and it arrived this morning. I installed it into my computer and when I opened Disk Manager I was given formatting options. Instead of formatting the drive immediately I tried one last time to get the Intel SSD to work by swapping the drives and not changing anything else with my setup. But after the swap I still couldn't find the drive in my BIOS or or Disk Manager.

Reply