Showing results for 
Search instead for 
Did you mean: 
Community Manager

Intel 80GB G2 will not boot, hangs on POST

Hi everyone, I bought my Intel 80GB G2 last September, and it has died, kind of... I've had the intel drive running in my Dell Studio 14z the whole time up until about last month when the drive stopped working, I tried to turn the computer on and it would just hang on the POST screen for a few minutes then state that there was no drive found. If I tried to get into bios the laptop would lock up if I look at current connected drives. Mind you the hard-drive is also password locked via BIOS. Thinking it was maybe the laptop I tried putting the hard-drive in another laptop.. I tried in another dell, even a MacBook Pro and every time the same thing has happened.

I then tried another approach which has left me very confused. I plugged my solid state into my desktop computer running windows and hooked the SSD up to it via the onboard SATA controller.. Again the POST just hung.. So I pulled out my ThermalTake BlacX which is USB and hooked it upto my desktop and plugged the SSD into the BlacX. Well if I do that, Windows detects the drive properly as an INTEL80GBxxxG2 and if I go the drive manager under windows I can see that the drive has 74.5GB of space that is unallocated. I've tried to format it, but I can't, it fails each time. The drive also shows up on my macbook pro when hooked up via USB, but it too can not do anything to the drive.

So my question is, what is up with my solid state, why can I view the drive name and capacity in windows/mac when hooked up via USB but not in bios or windows/mac when connected to a SATA controller? I've thought about buying another BlacX with an eSATA connection to try and send an ATA command to it to remove the bios password thinking that might be causing the problem?



1 Reply
New Contributor II

Hello, I would like to suggest that please perform a secure erase to this Solid state drive, that should solve this problem; you can get the bootable tool from the following link: that you can try to initialize the SSD at the windows "Computer management" / "Disk management" and then select initialize.