Community
cancel
Showing results for 
Search instead for 
Did you mean: 
DMagu
Beginner
1,062 Views

Intel 900p 280 GB not being recognized on a ASUS Z370-E

Hey guys! I recently purchased an Intel 900p 280 GB and I've installed it into my ASUS Z370-E motherboard but not matter what I do I can't get it to be recognized and assigned a letter by the system. The Intel SSD Toolbox recognizes the drive and everything appears to be fine diagnostic wise but Windows 10 64 bit simply won't recognize it and the NvME Installation Setup won't detect the drive either. Any help you all could give me would be very appreciated!

0 Kudos
2 Replies
idata
Community Manager
63 Views

Hi DanielMaguire,

We understand your situation regarding the Intel® Optane™ SSD 900P Series.

In order to better understand your situation could you please provide the following information:

-Are you using the specific https://downloadcenter.intel.com/download/27231/NVMe-Drivers-for-Intel-Optane-SSD-900P-Series NVMe* driver for the Intel® Optane™ SSD 900P Series?

-Could you please confirm if you have the U.2 version of the SSD or the add-in card version?

-Do you have another NVMe* SSD connected to the motherboard?

- Please download and run the https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility Intel® System Support Utility on one of these computers (or both). Run the scan selecting "Everything." Save this report and upload. To enable attachments, make sure to select the option to "use advanced editor" while replying.

We look forward to hearing back from you.

Regards,

 

Junior M.

 

idata
Community Manager
63 Views

Hi DanielMaguire,

 

 

We would like to know if you read our previous post. If you have any other questions, we'll be waiting for your response.

 

 

Regards,

 

Junior M.
Reply