Community
cancel
Showing results for 
Search instead for 
Did you mean: 
TYan3
New Contributor I
949 Views

Intel SSD 530: How to Disable Workload Timer/Offline Data Collection?

Before I ever ran `smartctl -t vendor,0x40 /dev/sdX`, the Timed Workload attribute data are as follow:

ID# ATTRIBUTE_NAMEFLAGVALUEWORSTTHRESHTYPEUPDATEDWHEN_FAILEDRAW_VALUE226Workld_Media_Wear_Indic0x00321001000Old_ageAlways-65535227Workld_Host_Reads_Perc0x00321001000Old_ageAlways-57228Workload_Minutes0x00321001000Old_ageAlways-65535

This is already a bit weird. Since according to the spec, if Workload_Minutes is still 65535, Workld_Media_Wear_Indic and Workld_Host_Reads_Perc should be both 65535 as well, because the timer is never started (or the cycle is not finished yet).

After I ran `smartctl -t vendor,0x40`, the data was reset. All three become 65535. But as long as it's powered on long enough, the data will be updated according to some statistics.

My question is, is there anyway to stop the Timer, so that when I reset it again, they will remain at 65535 and stop being updated?

Also, the statistics that the Timer depends on seems to be the (Auto) Offline Data Collection. According to the Self-Test Logs, it seems that the Collection is always running because whenever it's powered off, a host reset interrupt will be logged. This happens even before I ever ran `smartctl -t vendor,0x40`, and when I disabled SMART check in my UEFI setting.

So, is the Offline Data Collection mainly for the Workload Timer attributes? Can it be stopped as well?

I can see "Auto Offline Data Collection: Disabled" and "Auto Offline data collection on/off support." in smartctl, but when I try `smartctl -o on` or `smartctl -o off`, the following errors show up:

SMART Enable Automatic Offline failed: scsi error badly formed scsi parameters

SMART Disable Automatic Offline failed: scsi error badly formed scsi parameters

If I add `-d ata`, the error will be:

Error SMART Status command failed: Input/output error

SMART Enable Automatic Offline failed: Input/output error

Error SMART Status command failed: Input/output error

SMART Disable Automatic Offline failed: Input/output error

Here is an output of `smartctl -x`: https://ptpb.pw/bBEj https://ptpb.pw/bBEj

0 Kudos
1 Reply
jbenavides
Honored Contributor II
85 Views

Hello Tom Yan,

The counters for the Timed Workload indicators cannot be disabled, only reset for the user needs to perform endurance testing.

We are looking for additional details about this functionality and will provide more information as soon as it is available.

Reply