Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
945 Views

Intel SSD 600p speed problem

I've get a less that half of advertised speed of Intel intel SSD 600p using m.2 port on MSI Z170A Krait Gaming 3X motherboard using Intel i5 6600k. I updated all the motherboard drivers and running windows 10 pro and still get only 750 mb/s seq read . Does anybody has any ideas what i can do before return ssd back?

0 Kudos
7 Replies
idata
Community Manager
42 Views

Hello PiterParker,

 

 

We understand your SSD is not performing at the speed it was advertised, we would like to know first what is the model of SSD you have or capacity of it?

 

 

Checking at the motherboard's downloads, please make sure the BIOS version of your motherboard is version: 2.7 - Found in http://download.msi.com/bos_exe/7A11v27.zip this link

 

 

We will be waiting for your response.

 

 

Regards,

 

NC
idata
Community Manager
42 Views

Hi there!

I use 2.7 version of BIOS and actual drivers for whole system.

The capacity of the SSD is 512 Gb.

Here is the screenshot of speed that I've get

idata
Community Manager
42 Views

Hi PiterParker,

 

 

Thanks a lot for the information provided.

 

For now we would like to research about this situation, in the meantime, could you please provide us more specs of your computer? (Motherboard, CPU, Memory, Brand and Model, etc)

 

 

Also, are you using this SSD as a boot drive or storage?

 

 

We will be waiting for your response and we'll be working on our research as well.

 

 

Regards,

 

NC
idata
Community Manager
42 Views

Hello PiterParker,

 

 

We would like to know if by any chance did you notice a change on the speed after upgrading the BIOS version of the motherboard? Or if it was running at that speed from day one?

 

 

Please also let us know if the drive is used as boot drive or just for storage.

 

 

Regards,

 

NC
idata
Community Manager
42 Views

Hi! So here is some update information.

I bought drive adapter (M.2 NGFF SSD PCIe to PCI Express) and connected ssd through PCI port. And finally got correct speed. So i guess it was some issue with mobo. But MSI support told me "Make sure you have an updated Intel Rapid Storage Technology driver and Intel Chipset driver, also check any pending updates from windows 10 updates because the Intel SSD 600P driver come bundled with Windows."

I've try to find any ssd 600p drivers but i didn't find anything.

I use the ssd drive as boot drive, correct.

My system specs:

processor - i5-6600k

motherboard - MSI Z170A KRAIT GAMING 3X

graphic card - ZOTAC Force GTX 1060 6GB

memory - 2*Ballistix Sport LT 16GB Single DDR4 2400 MT/s

idata
Community Manager
42 Views

Hi Piterparker,

 

 

For this series of SSD, you don't need to install any additional driver for the drive to work better, since the drive uses the inbox driver included in the operating system.

 

Please let us know if you need any further assistance.

 

 

Regards,

 

NC
idata
Community Manager
42 Views

Hi PiterParker,

 

 

We are following up and we'd like to know if you require further assistance about this thread. We will be waiting for your response.

 

 

Regards,

 

NC
Reply