Showing results for 
Search instead for 
Did you mean: 
Community Manager

Intel SSD Optimizer crashes HDD; PGP; 02M3 doesn't want to replace 02L0

Every time my SSD Optimizer runs it knocks down my system. The symptoms are different:

sometimes it's a BSOD + reboot, sometimes it's BSOD + machine gets stuck on reboot and says there are no HDDs (I need to turn it off manually and let it "cool down" for a couple of seconds), sometimes the picture on the screen freezes. The only thing that's constant is that it's related to SSD Optimizer.The SSD diagnostics tells everything is fine. Q1. Does anyone know what the heck is that? Q2. I suspect that it conflicts with PGP 10 with mounted virtual drives. A couple of times that I tried optimizer manually and unmounted PGP disks it worked fine. Most of the times it ran at night on schedule, so the disks were mounted. Did Intel or somebody else test such a set-up? Whatever the bug is, I don't think it's pure PGP problem, because PGP can't make the machine temporarily tell there are no bootable drives after the restart. It does look like an issue on the SSD chip.Q3. I have a stock 02L0 firmware that came installed on my Lenovo X201 machine. Does it have known issues?Q4. I tried to install 02M3. The firmware update tool told me that "Intel SSD is not attached or is disabled.... contact Intel Support". Is it the expected behavior on Lenovo X201? How do I upgrade to the bug-free firmware? P.S. Windows 7 x64, Lenovo X201, Intel SSD X-25M 34nm 160Gb
0 Kudos
1 Reply
New Contributor II

if the ssd came with the laptop, then lenovo provides support, not intel. try the ssd firmware updater from lenovo.