Solid State Drives
Support for Issues Related to Intel® Solid State Drives
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
For the latest information on Intel’s response to the Log4j/Log4Shell vulnerability, please see Intel-SA-00646
4374 Discussions

Intel SSD firmware and speed problem

idata
Community Manager
2,408 Views

.

4 Replies
vt5
New Contributor I
176 Views

Hi ancile90, you can double-check if superfetch is disabled from your win7, also ensure you're using AHCI.

idata
Community Manager
176 Views

I disabled Superfetch, it was enabled. My bios is set at IDE, when I switch it to AHCI, Windows wont boot.

vt5
New Contributor I
176 Views

if it's not that inconvenient suggest you back-up your data and re-install your OS with AHCI to take advantage of NCQ to yield better SSD performance

idata
Community Manager
176 Views

Hello,

You can switch the AHCI mode without re)installing the OS. You should go to the reg edit and set msahci.sys to 0 . See Microsoft link below.

After the registry change you can change the SATA setting in your BIOS to AHCI. Maybe do the same for iastor.sys and iastorV.sys.

I have done this personnaly and this works fine.

http://support.microsoft.com/kb/922976 http://support.microsoft.com/kb/922976

Reply