Showing results for 
Search instead for 
Did you mean: 
Community Manager

Intel X25-M G1 Drive Will Not Boot Anymore

I have an intel X25-M G1 with the 8820 firmware that my wife used in her laptop. She has windows vista home basic 32 bit installed and one morning she was surfing the internet and she started to experience intermittent "hangs" in the OS. After a while, the computer flashed a black screen up that said that the hard drive was no longer bootable. After trying multiple restarts, the system would not let me get anywhere, it would not even give a message that there was no drive, or that there was no partition or that the drive would not boot, the bios would POST then I would just get a black screen with a blinking cursor in the top left corner.

I took a look in the bios and it still detects the drive. I booted into Parted Magic from the UBCD and I managed to mount the drive but I really don't know what I am doing in there enough to even browse around for any files. All I managed to do was run a diagnostic that said my drive was fine....which it wasn't because I still could not boot up.

I tried putting the dive into my desktop using a spare SATA connection but then my PC would not boot into my OS. It would hang at the windows splash screen forever. I tried booting into safe mode but it hangs at disk.sys, which means whatever is trying to load after that was causing a problem. At this point I am running out of ideas. My wife has a lot of very important files on that drive and I am wondering if anyone has any other ideas to try and recover the data from this X25-M.


0 Kudos
1 Reply
Community Manager

Adam, are you able to boot off your original OS partition with the SSD plugged into the PC? After booting up, can you then explorer the SSD?

How much disk space was used and how long has it been since the SSD was reformatted?