Community
cancel
Showing results for 
Search instead for 
Did you mean: 
JT_th
Beginner
1,405 Views

Intel X25-V 8Mb LBA and NO_SPACE serial problem

I got this SSD as it is, already "bricked". I gave ~3$ for it when somebody asked for help but he did not feel like he is able to try and possibly fix it for himself.

I though I am familiar with the "Intel SSD with 8Mb space bug" but it seems I wasn't lucky with this drive.

First I tried to do an ATA Secure Erase with hdparm. I got very suspicios after a few seconds and it was really strange that it took about 30 minutes and nothing changed. The drive remained in high security mode, I had to unlock it manually with hdparm.

As a second attempt, I tried to do a dco-restore but hdparm couldn't do that because this drive has an active HPA (about 40Gb) and thus the command failed. I could not use hdparm to disable the HPA. But I managed to set it disabled with HDAT2. Then I suddenly had 40Gb LBA space but it was unreadable. But now I could issue the dco-restore command with success. I still had unreadable 40Gb space (and theoretically right dco config with re-enabled SMART as well). I issued a secure_erase_enhanced command which took ~30 minutes again with no luck.

SMART is disabled now. But it seems I can read some SMART data after a fresh dco-restre command. It says this drive has zero amount of host writes and absolute max number of bad sectors.

It wasn't easy at all (the official Intel tools didn't recognise this drive as an Intel SSD which is applicable to any firmware updates) but I finally managed to update the drive's firmware from *2HD (the original factory one) to *2M3 (the lates public one). I repeated the HDAT2, hdparm, dco-restore, secure_erase with this new firmware but the result is the same: after a power cycling, the drive has 8Mb LBA space, even if I leave the HPA disabled.

Well...

Any other ideas how to bring this SSD back to life?

Note that this driver has NO_SPACE serial, not BAD_CTX and the new name of the SSD is Intel Postville (the developer codename of this SSD family). So, it seems to be a different problem, not the infamous "8Mb bug" with the BAD_CTX serial.

root@ubuntu:/home/ubuntu# hdparm -I /dev/sdf

/dev/sdf:

ATA device, with non-removable media

Model Number: Intel Postville

Serial Number: NO_SPACE

Firmware Revision: 2CV102M3

Transport: Serial, ATA8-AST, SATA 1.0a, SATA II Extensions, SATA Rev 2.5, SATA Rev 2.6

Standards:

Used: ATA/ATAPI-7 T13 1532D revision 1

Supported: 7 6 5 4

Configuration:

Logical max current

cylinders 16383 16

heads 16 16

sectors/track 63 63

--

CHS current addressable sectors: 16128

LBA user addressable sectors: 16384

LBA48 user addressable sectors: 16384

Logical Sector size: 512 bytes

Physical Sector size: 512 bytes

device size with M = 1024*1024: 8 MBytes

device size with M = 1000*1000: 8 MBytes

cache/buffer size = unknown

Nominal Media Rotation Rate: Solid State Device

Capabilities:

LBA, IORDY(can be disabled)

Standby timer values: spec'd by Standard, no device specific minimum

R/W multiple sector transfer: Max = 16 Current = 1

DMA: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 udma4 udma5 *udma6

Cycle time: min=120ns recommended=120ns

PIO: pio0 pio1 pio2 pio3 pio4

Cycle time: no flow control=120ns IORDY flow control=120ns

Commands/features:

Enabled Supported:

Security Mode feature set

* Power Management feature set

* Write cache

* Look-ahead

* Host Protected Area feature set

* WRITE_BUFFER command

* READ_BUFFER command

* NOP cmd

* DOWNLOAD_MICROCODE

SET_MAX security extension

* 48-bit Address feature set

* Device Configuration Overlay feature set

* Mandatory FLUSH_CACHE

* FLUSH_CACHE_EXT

* General Purpose Logging feature set

* WRITE_{DMA|MULTIPLE}_FUA_EXT

* 64-bit World wide name

* IDLE_IMMEDIATE with UNLOAD

* WRITE_UNCORRECTABLE_EXT command

* {READ,WRITE}_DMA_EXT_GPL commands

* Segmented DOWNLOAD_MICROCODE

* Gen1 signaling speed (1.5Gb/s)

* Gen2 signaling speed (3.0Gb/s)

* Phy event counters

* Software settings preservation

* Data Set Management TRIM supported (limit 8 blocks)

* Deterministic read ZEROs after TRIM

Security:

Master password revision code = 4

supported

not enabled

not locked

not frozen

not ex...

Tags (1)
0 Kudos
1 Reply
Jose_H_Intel1
Employee
133 Views

I am really sorry to know about this issue. The drive appears to be defective.

Please note that the warranty is applicable for the original owner and it is not transferable.

Reply