Showing results for 
Search instead for 
Did you mean: 

Latest SSD firmware update tools buggy

I have tried unsuccessfully to update various model Intel SSDs using the latest Data Center Tool (3.0.2) for Linux, and the Firmware Update Tool (2.1.6) ISO.

We have a number of servers running a mixture of S3700, S3710, S3610, S3500, and Intel 320 SSDs. Many of these are attached to LSI MegaRAID adapters, and some are attached to LSI HBAs (running with either IT or IR firmware). So far, I have encountered the following show-stopper bugs:

- DCT hangs indefinitely when trying to scan for drives on "LSI adapters" (presumably MegaRAID), when running with EnableLSIAdapter=true. The log file indicates that it is sending ioctls to the MegaRAID and it apparently does see some drives, but it the command never completes, and in fact blocks IO to the MegaRAID whilst it is hung, until I eventually kill the isdct process with kill -9.

- FUT ISO fails to start X11, and lands back at a Linux console login prompt.

Since our systems are headless Debian 8 servers, we of course do not install a GUI on them, but I was able to eventually get the FUT to recognize and update some Intel 320 SSDs behind an LSI HBA, by doing the following:

- extract the issdfut binary from the FUT ISO and copy to target system

- add i386 multiarch support on server (dpkg --add-architecture i386)

- install libqt4gui (apt-get install libqtgui4:i386)

- ssh to target system with X11 forwarding (ssh -X

- run issdfut tool from within SSH session

This is a pretty hefty amount of work to do on a large number of systems. Since we have to reboot the systems for new firmware to take effect anyway, I have nothing against booting the FUT ISO via IPMI virtual CDROM - if it would only work!

The affected systems are predominantly AMD Opteron 62xx systems, however one is an Intel Xeon system. All are running Debian Linux 8 (Jessie), amd64, with kernels 4.6 - 4.8.

If the officially supported tools don't work, what are the chances of getting hold of the plain firmware blobs, to download with tried and true tools like sg3-utils?

0 Kudos
3 Replies
Community Manager

Hello Dswarbrick,



Regarding this situation you are experiencing, we can tell you that the LSI* Mega RAID adapters are supported with Intel® Data Center Tool, as you can see on page 8 of the user's guide.


The only inconvenience we see is that Debian is not a supported operating system, reason why it may be hanging during the process.



About the Firmware Update Tool, there is no support while the drives are connected through a RAID adapter.



Is there any way you may try to use the Intel® Data Center Tool with a different supported operating system? (Windows* Server 2012 / R2, Windows* Server 2008 / R2, Windows* 7/8/8.1/10 or Linux* (RHEL 6.5/6.6/6.7/7.0/7.1 and SLES 11.3/11.4/12.1)



During the research, we found the following link from a different site, this one includes some sort of workaround, in case you would like to give it a try as well.



Note: Any links provided for third party tools or sites are offered for your convenience and should not be viewed as an endorsement by Intel® of the content, products, or services offered there. We do not offer support for any third party tool mentioned here.






Hello NC,

I am aware that LSI MegaRAID adapters are supported by DCT, as per the docs. I suspect however that it is not supported on newer kernels. We have other machines running older Debian release (Wheezy) with kernel 3.12, and this apparently works. Obviously we cannot justify downgrading our systems to an obsolete Debian release just to upgrade SSD firmware.

Being a systems developer myself, I am familiar how the MegaRAID firmware interface (MFI) ioctls work, especially with regards to SCSI passthrough. As I said, it appears from the DCT log that it is at least attempting to talk to the drives attached to the MegaRAID, and I can even see Intel vendor strings and model numbers in the log. I don't know why it ultimately hangs. It would be very helpful if Intel published a list of kernel versions that it is compatible, since not everybody uses Windows, Red Hat or VMware. Notably missing from the list of supported systems is Intel's own Clear Linux, which as far as I know uses very recent kernels. How do Clear Linux users update their SSD firmware?

Can you explain why the bootable Firmware Update Tool ISO does not successfully start the X11 session? Have others reported this? We have numerous systems that simply have SSDs attached to LSI HBAs (not MegaRAID), as I wrote in my first message, this appeared to work, albeit with a lot of extra legwork that we'd like to avoid. We have a few hundred servers, with SSDs numbering over 2000, so we need to streamline this process.


Daniel Swarbrick

Community Manager

Hi Dswarbrick,



Thanks for replying back.


We would like you to please check your private messages and let us know from there.