Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
2,762 Views

Question about SSD performance

I bought SSD x25-m G2 like a month ago, I'm using AHCI, windows 7 64x, My SSD WEI score dropped from 7.8 to 7.6. I wanna know is there anything I can do to get WEI score 7.8 again? I tried to use SSD toolbox, reformatted my OS, but it didnt help, my SSD WEI is still 7.6

11 Replies
idata
Community Manager
53 Views

When u used the Toolbox, how long did it take? Is System restore turned on? Have you taken a Crystal Diskmark score yet?

idata
Community Manager
53 Views

Toolbox took less than 50 secs to completed. Yes, System restore was turned on, I always leave it on. Should I turn off system restore?

Here's a link about my crystal diskmark score http://img59.imageshack.us/i/crystaldiskmarkp.jpg/

idata
Community Manager
53 Views

Your score is perfect...no probs whatsoever.

idata
Community Manager
53 Views

my ssd is doing great BUT the 4k read/write is 10-12mb/s !!!!!

i did everything from intel etc etc. ahci, you name it. could my drive be faulty? all the other vakues are higer than i have seen anywhere. i get seq write of 110 etc. but my 4k is horrible

idata
Community Manager
53 Views

It is impossible to help without seeing a Crystal score and being told about your system setup. Can you provide some information?

idata
Community Manager
53 Views

ASUS notebook G73JH - Mobo H55M

core i7, ati hd 5870m, 8gb ddr3 ram

 

Seq: R:251 W:104

 

4K: R:13 W:19

 

4K64: R:143 W:65

 

Time: 0.113 / 0.185

everything is AWESOME. but the 4k is damn terrible. what could be doing this?

 

other than my 4k these numbers are some of the best i have seen

idata
Community Manager
53 Views

Boot your system into safe mode and then do a crystal Score IN safe mode and get back to me with the results.

idata
Community Manager
53 Views

-----------------------------------------------------------------------

CrystalDiskMark 3.0 x64 (C) 2007-2010 hiyohiyo

Crystal Dew World : http://crystalmark.info/

-----------------------------------------------------------------------

* MB/s = 1,000,000 byte/s [SATA/300 = 300,000,000 byte/s]

Sequential Read : 261.523 MB/s

Sequential Write : 108.279 MB/s

Random Read 512KB : 198.173 MB/s

Random Write 512KB : 109.771 MB/s

Random Read 4KB (QD=1) : 20.272 MB/s [ 4949.3 IOPS]

Random Write 4KB (QD=1) : 43.443 MB/s [ 10606.3 IOPS]

Random Read 4KB (QD=32) : 156.165 MB/s [ 38126.2 IOPS]

Random Write 4KB (QD=32) : 96.324 MB/s [ 23516.7 IOPS]

WOW. 4K twice as good just like that!!

ok so what does it mean that safe mode makes it go so much better. can i duplicate these results out of safe mode or does it just show my ssd is ok?

what is different in safe mode that changes this and can i turn it off in normal?

thanks!

idata
Community Manager
53 Views

This simply means that your SSD is A-OK and that your problem exists in the OS installation somewhere.

I have run across this plenty and it usually occurs when someone has cloned the OS when changing to a SSD vice doing a fresh installation. In any case, the problem is in there somewhere. Maybe your mode is not in AHCI, maybe your Buffer Cache is checked..or unchecked.

The good thing we know is the SSD is good and the problem lies in the OS. Personally, I would do a fresh install.

Les

http://www.thessdreview.blogspot.com The SSD Review

idata
Community Manager
53 Views

what if the allocation units are offset. could this cause this latency?

if so and in general anyway, how do i completley wipe the ssd + recovery partition in order to set the alignment perfect on a fresh install. last fresh install i did the alignment is a liiiitle off.

thanks

idata
Community Manager
53 Views

You do not need to worry about wiping or aligning with Windows 7. A fresh install sets it all up for you.