Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
1,433 Views

SSD 320 hangs after prompting for password

I have a 160gb 320 SSD in my Lenovo W510 laptop. It has worked well, but today, win7 suddenly hung with the drive light on. After a few minutes I cold-booted the machine.

The SSD has the ATA password set, and the prompt came up as normal. However, once I hit enter after typing in the password, the machine hangs, again with the HDD light on.

If I remove the ssd, replace it with another identical 320 ssd and boot from the replacement, then insert the original non-functional ssd into the drive bay, intel RST identifies the faulty drive, its size, serial number, firmwaver version and that it is locked. It also provide the unlock functionality, but it seems to have a lower limit of characters available for providing a password than does the Lenovo BIOS - so it failed the attempt to unlock the drive from RST.

Drive model: INTEL SSDSA2CW160G3

firmware: 4PC10362

Is there anything else I can try, or is the only solution to return the drive as defective?

Thanks!

Tags (1)
0 Kudos
3 Replies
idata
Community Manager
55 Views

funny, it looks like I was able to enter a 35-character password via the Lenovo Bios (it did not allow 36). This has worked for months and months with no problem, and still works for the drive that is functional.

the RST allows only 32 characters for the ata pwd, which is according to specification.

I have no idea if this has anything to do with it - I would suppose not, since the other drive works fine with such a long password.

Any ideas?

idata
Community Manager
55 Views

Did you ever find a solution to your problem? or perhaps contacted customer support?

I am in a very similar situation, i experienced a BSOD in windows 7 on my laptop (thinkpad t410). and now it just stalls after i input the correct password (that i have been using daily for the last year).

I also have the same symptom, that i can not enter BIOS when the SSD is plugged in.

idata
Community Manager
55 Views

The same problem with Lenovo Thinkpad x201 and intel ssd 320. Guys have you solve it?

Reply