Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,471 Views

SSD Data Center tool in ESXi 6.5 not detecting NVMe P4600 4TB

Hey guys, I have two NVMe (P4600 4.0TB) connect on a Dell 720, OS ESXI 6.5U2 (Iso provided by Dell).

I am running a fresh ESXI installation. Here are the steps per instructions:

esxcli software acceptance set --level=CommunitySupported

esxcli software acceptance get

CommunitySupported

esxcli software vib install -d "/tmp/intel_ssd_data_center_tool_3.0.11-400_OfflineBundle.zip" --no-sig-check

Installation Result

Message: Operation finished successfully.

Reboot Required: false

VIBs Installed: Intel_bootbank_intel_ssd_data_center_tool_3.0.11-400

VIBs Removed:

VIBs Skipped:

[root@XXXX:/opt/intel/isdct] ./isdct show -intelssd

No results

So I upgraded the firmware to version QDV10710 Bootloader=QB1B0122 for both NVMe, but the problem persists.

Enable logging:

./isdct set -system LogFile = 'log.txt'

./isdct set -system EnableLog = 'true'

[root@xxxx:/opt/intel/isdct] vi log.txt

17:37:35:191645 [debug] tdk_interface_dll.cpp(287) SendXMLMessage: Entering

17:37:35:193646 [debug] TDKInterface.cpp(345) scan: Entering

17:37:35:193666 [debug] DeviceFinder_NVME.cpp(63) scan: Entering

17:37:35:193678 [debug] DeviceFinder_NVME.cpp(100) scanPhysicalDevices: Entering

17:37:35:193784 [error] Connection_Path.cpp(91) open: vmk_MgmtUserInit error: 19

17:37:35:193811 [error] DeviceFinder_NVME.cpp(134) scanPhysicalDevices: Failed to connect to device. Ignoring intel-nvme0

17:37:35:193864 [error] Connection_Path.cpp(91) open: vmk_MgmtUserInit error: 19

17:37:35:193880 [error] DeviceFinder_NVME.cpp(134) scanPhysicalDevices: Failed to connect to device. Ignoring intel-nvme1

17:37:35:193917 [error] Connection_Path.cpp(91) open: vmk_MgmtUserInit error: 19

17:37:35:193931 [error] DeviceFinder_NVME.cpp(134) scanPhysicalDevices: Failed to connect to device. Ignoring intel-nvme2

17:37:35:193967 [error] Connection_Path.cpp(91) open: vmk_MgmtUserInit error: 19

17:37:35:193981 [error] DeviceFinder_NVME.cpp(134) scanPhysicalDevices: Failed to connect to device. Ignoring intel-nvme3

17:37:35:194017 [error] Connection_Path.cpp(91) open: vmk_MgmtUserInit error: 19

(...counting by 98)

17:37:35:198600 [error] DeviceFinder_NVME.cpp(134) scanPhysicalDevices: Failed to connect to device. Ignoring intel-nvme98

17:37:35:198609 [debug] DeviceFinder_NVME.cpp scanPhysicalDevices: Exiting

17:37:35:198620 [debug] DeviceFinder_NVME.cpp scan: Exiting

17:37:35:198633 [debug] TDKInterface.cpp scan: Exiting

17:37:35:198762 [debug] tdk_interface_dll.cpp SendXMLMessage: Exiting

17:37:35:198775 [debug] tdk_interface_dll.cpp(331) ReceiveXMLMessage: Entering

17:37:35:198850 [debug] tdk_interface_dll.cpp ReceiveXMLMessage: Exiting

17:37:35:198864 [debug] tdk_interface_dll.cpp(331) ReceiveXMLMessage: Entering

17:37:35:198897 [debug] tdk_interface_dll.cpp ReceiveXMLMessage: Exiting

Any ideas how I can fix it?

Thank you!

Regards,

Lucas

0 Kudos
8 Replies
Highlighted
Community Manager
9 Views

Re: SSD Data Center tool in ESXi 6.5 not detecting NVMe P4600 4TB

Hello Lucas,

Thanks for posting in our communities. We understand that your Intel® SSD P4600 are not being detected by ISDCT (Intel SSD Data Center Tool).

Please make sure you have the https://www.vmware.com/resources/compatibility/detail.php?deviceCategory=io&productid=43955&deviceCa... latest NVMe driver to match your ESXi* and SSD firmware version.

If the issue persists, please let us know the following:

- How are the drives connected to the server (through some kind of adapter or directly to the motherboard PCIe slots)?

 

- Are these SSDs part of a RAID array or other storage configuration?

 

- Do you have the chance to test the drives on a Windows* or Linux* system? We would like you to update the firmware on the SSDs. The latest firmware version for these drives is QDV101B1 and its available on https://downloadcenter.intel.com/download/27778?v=t ISDCT version: 3.0.12.

Best regards,

 

Eugenio F.
0 Kudos
Highlighted
Beginner
9 Views

Re: SSD Data Center tool in ESXi 6.5 not detecting NVMe P4600 4TB

Hello Eugenio

Thanks for your reply. It seems I am using the latest drive available.

[root@XXXX:/opt/intel/isdct] esxcli software vib update -d "/tmp/VMW-ESX-6.5.0-intel-nvme-vmd-1.4.0.1016-offline_bundle-8307340.zip"

Installation Result

Message: Host is not changed.

Reboot Required: false

VIBs Installed:

VIBs Removed:

VIBs Skipped: INT_bootbank_intel-nvme-vmd_1.4.0.1016-1OEM.650.0.0.4598673

However, I could not find download link for the firmware QDV101B1 for ESX or OS independent. This link https://downloadcenter.intel.com/download/27778?v=t Download Intel® SSD Data Center Tool is for Windows and Linux only. The latest firmware available for OS independent is the version QDV10170 found here https://downloadcenter.intel.com/download/26491?v=t Download Intel® SSD Firmware Update Tool.

Here are the answers:

- How are the drives connected to the server (through some kind of adapter or directly to the motherboard PCIe slots)?

It is connect directly to PCIe. No adapters.

 

- Are these SSDs part of a RAID array or other storage configuration?

No, I am using it as a single ESXI datastore.

 

- Do you have the chance to test the drives on a Windows* or Linux* system? We would like you to update the firmware on the SSDs. The latest firmware version for these drives is QDV101B1 and its available on https://downloadcenter.intel.com/download/27778%3Fv%3Dt ISDCT version: 3.0.12.

I did not test on a Windows or LInux system yet. This is a production ESXi server, so it is not possible for me to change the OS.

Regards,

Lucas

0 Kudos
Highlighted
Community Manager
9 Views

Re: SSD Data Center tool in ESXi 6.5 not detecting NVMe P4600 4TB

Hello Lucas,

 

 

Thanks for providing the requested information.

 

 

According to the https://www.vmware.com/resources/compatibility/detail.php?deviceCategory=io&productid=43955&deviceCa... VMWare* compatibility guide, you should install NVMe driver version 1.3.2.8 to match the current firmware version (QDV10170). Please https://kb.vmware.com/s/article/2079279 downgrade the driver to the corresponding version.

 

 

Just to to confirm, other than ISDCT are the drives being properly recognized by the server?

 

 

Best regards,

 

Eugenio F.
0 Kudos
Highlighted
Beginner
9 Views

Re: SSD Data Center tool in ESXi 6.5 not detecting NVMe P4600 4TB

Hello Eugenio,.

I removed the latest driver, and installed the version 1.3.2.8.

[root@XXXX:/tmp] esxcli software vib remove -n intel-nvme-vmd -f

Removal Result

Message: The update completed successfully, but the system needs to be rebooted for the changes to be effective.

Reboot Required: true

VIBs Installed:

VIBs Removed: INT_bootbank_intel-nvme-vmd_1.4.0.1016-1OEM.650.0.0.4598673

VIBs Skipped:

[root@XXXX:/tmp] esxcli software vib install -d /tmp/VMW-ESX-6.0.0-intel-nvme-1.3.2.8-offline_bundle-7726576.zip

Installation Result

Message: The update completed successfully, but the system needs to be rebooted for the changes to be effective.

Reboot Required: true

VIBs Installed: INT_bootbank_intel-nvme_1.3.2.8-1OEM.600.0.0.2768847

VIBs Removed:

VIBs Skipped:

Now it seems workable

[root@XXX:/opt/intel/isdct] ./isdct show -intelssd

- Intel SSD DC P4600 Series BTLE736105YY4P0KGN -

Bootloader : 0122

DevicePath : intel-nvme0

DeviceStatus : Healthy

Firmware : QDV10170

FirmwareUpdateAvailable : Firmware=QDV10190 Bootloader=QB1B0122

Index : 0

ModelNumber : INTEL SSDPEDKE040T7

ProductFamily : Intel SSD DC P4600 Series

SerialNumber : BTLE736105YY4P0KGN

- Intel SSD DC P4600 Series BTLE73810A2T4P0KGN -

Bootloader : 0122

DevicePath : intel-nvme1

DeviceStatus : Healthy

Firmware : QDV10170

FirmwareUpdateAvailable : Firmware=QDV10190 Bootloader=QB1B0122

Index : 1

ModelNumber : INTEL SSDPEDKE040T7

ProductFamily : Intel SSD DC P4600 Series

SerialNumber : BTLE73810A2T4P0KGN

0 Kudos
Highlighted
Community Manager
9 Views

Re: SSD Data Center tool in ESXi 6.5 not detecting NVMe P4600 4TB

Hello Lucas,

 

 

Thanks for your reply. It is good to know ISDCT is now recognizing the SSDs after downgrading the NVMe driver.

 

 

Please let us know if there's anything else we can do for you.

 

 

Best regards,

 

Eugenio F.
0 Kudos
Highlighted
Community Manager
9 Views

Re: SSD Data Center tool in ESXi 6.5 not detecting NVMe P4600 4TB

Hello Lucas,

 

 

Thanks for your reply. It is good to know ISDCT is now recognizing the SSDs after downgrading the driver.

 

 

Please let us know if there's anything else we can do for you.

 

 

Best regards,

 

Eugenio F.
0 Kudos
Highlighted
Beginner
9 Views

Re: SSD Data Center tool in ESXi 6.5 not detecting NVMe P4600 4TB

Thanks so much for all assistance provided Eugenio.

One last question.

Is it possible to do a self-test for NVME? I would like to make sure those NVME are 100% health for production.

Regards,

Lucas

0 Kudos
Highlighted
Community Manager
9 Views

Re: SSD Data Center tool in ESXi 6.5 not detecting NVMe P4600 4TB

Hello Lucas,

 

 

You can monitor the drive health by checking its S.M.A.R.T. details using either ISDCT Heath Sensor and Show SMART commands, or https://kb.vmware.com/s/article/2040405 ESXi* own SMART commands.

 

 

Please refer to the ISDCT User manual to get more details for each command syntax:

 

 

- https://www.intel.com/content/www/us/en/support/articles/000020016/memory-and-storage.html User and Install Guides for Intel® SSD Data Center Tool

 

 

Best regards,

 

Eugenio F.
0 Kudos