Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
930 Views

SSD with fde refuses to unlock after installing a Linux kernel via lilo

Hi,

yesterday I received my 320 Series SSD (modell no. ssdsa2cw120g3 )

I enabled fde with my Sony vaio BZ12VN within the bios as hard disk password. I tried to install Slackware Linux. First Boot gave some strange sata module related kernel panic. But rebooting resolved that and installtion went fine. I copied all my backups to ssd and did some final touches. Severall unlocks in between, no problem.

After rebooting several times, the ssd refuses to unlock anymore with my Sony Laptop.

I think this occured after I installed my 2nd kernel via lilo. (However this can't be the reason, right?) I did a fdisk -H 224 -S 56 (as recommended by a linux kernel developer)

I put the ssd in my Windows machine. The ssd toolbox recognizes the ssd but I'm unable to perform any action listed. When I click on the options, just nothing happens.

The toolbox works fine for my other hdd with the non-ssd related options. This machine has a promise fastrack 378 sata controller.

Booting up the latest Ubuntu Live cd display the following error:

ata1: EH complete

ata1.00: exception: Emask 0x0 SAct 0x0 SErr 0x0 action 0x0

ata1.00: port_status 0x20200000

ata1.00: failed command: READ DMA

ata1.00: cmd c8/00:08:00:00:00/00:00:00:00:00/e0 tag dma 4096 in

ata1.00: res 51/04:08:00:00:00/00:00:00:00:00/eß Emask 0x1 (device error)

ata1.00: status { DRDY_ERROR}

ata1.00: error { ABRT}

ata1.00: configured for UDMA/133

..repeats severall times

I can't unlock the ssd with hparm. (I/O error)

It this related to the specific controller?

How can I do a secure block erease now?

What was I doing wrong?

Tags (1)
0 Kudos
0 Replies
Reply