Community
cancel
Showing results for 
Search instead for 
Did you mean: 
PMatt1
Beginner
909 Views

SSDSA2BW16G3H, 8MB "bug", and impossibility to SET_MAX_ADDRESS

Hi everyone,

this SSD has been struck by the 8MB "bug"/behaviour, I'm desperately looking for a way to recover as much data as possible

(therefore, I guess that the security erase procedure is not the best fit for the problem).

It is currently at firmware level 4PC10362 that - iirc - is the latest available from the Intel site for this family (and the update tool says it's already updated).

I tried to run hdparm -N /dev/sda (that actually queries the SSD for the current and max possible address) and I get a reasonable response: 16384/nnnnnnnnn (that is: currently set to 16Kblocks, that is, 8MBs, and the maximum value matches the maximum capacity).

unfortunately, if I try to run hdparm -N nnnnnnnnnn /dev/sda (temporary setting) or hdparm -N pnnnnnnnnnn /dev/sda (permanent setting), even with lower block counts,

hdparm says that SET_MAX_ADDRESS is failing for "input/output error"

I tried to also run the unofficial HDAT2 bootable iso but it appears that it cannot remount itself and make the commands actually available "or something", I guess that anyway it cannot do any magic itself and would resort to SET_MAX_ADDRESS or the like.

any suggestions?

thanks a lot!

0 Kudos
1 Reply
Jose_H_Intel1
Employee
62 Views

Hi prm, I am sorry for this inconvenience.

In this case we can only suggest taking the drive to a data recovery service. We are unable to guarantee that the data will be recovered but by contacting a company that is Intel partner, such as the ones linked below, you can be sure the Intel® SSD will keep its original warranty.

NOTE: These links are being offered for your convenience and should not be viewed as an endorsement by Intel of the content, products, or services offered there.

Reply