Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
1,044 Views

The driver detected a controller error on \Device\Harddisk0

Hello Intel Community,

I have recently installed Intel 330 Series 120GB as my system drivein to my old desktop. The firmware version is 300i. My SSD is partitioned into two:

C: SYSTEM 50GB

D: DATA 61.79GB

After working well for a few weeks, my PC had a crash today. I was surprised to find quite a large number of these messages in the Event Log - System:

"The driver detected a controller error on \Device\Harddisk0\D". Event ID: 11. Source: Disk

and

"A parity error was detected on \Device\Ide\IdePort0." Event ID: 5. Source: atapi

I am using the latest Intell SSD Tool box 3.1.2. Ran "System Tuner" which disabled Prefetch/Superfetch. I do not use Defragmenter on the SSD.

I run the "Intel SSD Optimiser" from this tool on the weekly basis.

The system information is below:

I have come across to this Microsoft technote that suggests to switch to PIO Only Transfer mode for IDE ATA/ATAPI Controller in order to fix that issue:

http://support.microsoft.com/?id=262448 Disk Error 11 and ATAPI Error 5 Using DMA Transfer Mode for ATA66 Hard Disk

I am going to try it tonight but I really do not understand how it could fix it.

I am worried that my new Intel SSD may be failing or not compatible with stardard itapi driver or SATA controller. I am using pretty standard Gigabyte GA-965P-DS4 motherboard with 8 SATA ports (3 GB/s). The SSD is connected into the first (SATAII0) port.

I hope that somebody could share their knowledge and help me with that issue.

Many thanks in advance,

Tech_Art

Tags (2)
0 Kudos
2 Replies
idata
Community Manager
102 Views

I have to reply to myself now as I gathered a bit more information.

The PIO Only Transfer mode for IDE ATA/ATAPI Controller (Primary IDE channel) as suggested in Microsoft technote seemed to fix the issue with "The driver detected a controller error on \Device\Harddisk0\D" and "A parity error was detected on \Device\Ide\IdePort0" errors in the System Event Log. However, it is not conclusive because I have used the PC in this mode only for one day. Also there was considerable performance degradation in this mode. In my estimates, Windows logon, application startup and even refreshing icons on the desktop was taking 5-10 longer than before. I have also noticed that disk I/O operations such as opening folders or files was slower on SSD drive with PIO Only transfer mode than on my second Seagate HDD which was still operating in the DMA if available transfer mode.

 

It all made sense to me when I read more about these tranfer modes in yet another Microsoft article (why not Intel), see More Information section there:

http://support.microsoft.com/kb/555282 Transfer mode for Device 0 on secondary IDE channel set to "PIO Only" in default configuration

I decided to switch back to the DMA if available transfer mode for IDE ATA/ATAPI Controller (Primary IDE channel) to which my Intel SSD is connected and see how it goes.

PS. Still waiting on some feedback from more experienced collaborators on this Intel forum.

Jose_H_Intel1
Employee
102 Views

Thank you very much for posting.

Have you tried to run a full diagnostic test with the Intel® SSD Toolbox?

You may also want to reinstall or update the chipset/SATA controller driver.

If the issue persists you may contact Intel® Customer support for further assistance:

http://www.intel.com/p/en_US/support/contactsupport http://www.intel.com/p/en_US/support/contactsupport

http://www.intel.com/p/en_US/support/contact/phone http://www.intel.com/p/en_US/support/contact/phone

Reply