Showing results for 
Search instead for 
Did you mean: 
Community Manager

Updating X25 Firmware on new iMac

So I put an X25 in place of my Superdrive in my new i7 iMac. I had no problem booting off the Snow Leopard disc form an external USB DVD drive. The Intel disc won't boot however. If I hold C during boot the disc spins like it wants to boot then I get the flashing Apple/? sign. I installed Refit and it sees the disc but when it boots it fails and I get a message that says that newer EFI Macs have trouble booting legacy operating systems from USB devices.

I tested the disc in my MacBook Pro and it booted fine and saw the X25 in there. So anyone have a workaround for this besides pulling the drive out and doing it in another system?

0 Kudos
3 Replies
Community Manager

Hi NetJunkie,

I'm having the exact same issue, except I'm on a Macbook Pro (mid-2010, Core i7). I've experienced this behaviour with other bootable CD/DVD's also. I'm also running of a USB connected CD drive, since I've replaced my SuperDrive with a 2nd harddisk. I wonder if bringing the SuperDrive back into the Macbook would solve that issue.

I do believe however that this has something to do with EFI versioning..

Anyways, how were you able to boot into the Intel firmware CD with your Macbook? I'm thinking you might have an older Macbook model..

Community Manager

restor harddriv lost date

Community Manager

try going into disk utility and load the .ISO to a USB Thumb Drive. to do this:

open Disk Utility

select your Thumb Drive

Select Restore

for Source drag the .ISO to that feild

for Destination drag your Thumb Drive from the list

hit restore

at boot try holding ALT you will get a list of drives. select the Thumb Drive or try ALT with the CD/DVD loaded to your external. also what FW is listed under:

System Profiler:Serial-ATA then Revision Number for that drive? if it says M3 your current no need to update.

I have a 2011 MBP with the X25-M I booted from a CD on my internal (super drive) so I know it will work as i tried the CD in my late 2010 iMac just to see if is a problem. I then tried it with my external (USB HP DVD/CD Drive) and it would not see it. booting to USB Thumb Drive i have not tried, but this should work if you hold the ALT key