Solid State Drives
Support for Issues Related to Intel® Solid State Drives
Intel Customer Support will be observing the Martin Luther King holiday on Monday, Jan. 17, and will return on Tues. Jan. 18.
For the latest information on Intel’s response to the Log4j/Log4Shell vulnerability, please see Intel-SA-00646
4374 Discussions

X-25M G2 80GB -- RAID0 capped at 150mb/s

Community Manager


Recently purchased two X-25M G2 80GB SSD's to run in RAID0. My motherboard supports SATA II, but not RAID, therefore I purchased a Rosewill controller card, using chipset Sil3132. ( RAID array was created successfully, Windows 7 64-bit installed successfully, however when benchmarking the SSD's...

Am only getting a seq. read speed of ~150mb/sec, write speed of ~150mb/sec. Write speeds are on par with what's expected, however read speed is extremely low. Other sources indicate this is due to the PCI-E connection for the RAID controller? Settings show drives are running in Ultra DMA Mode 6 -- could this be an issue as well? Have tried various drivers for this controller card with no changes in results.

Tried using just one SSD, connected directly to SATA II on motherboard with AHCI enabled. With this setup, speeds are what's expected, at ~250mb/sec read, and ~80mb/sec write.

If anyone has some insight on this issue, please advise. I'm dying to get this RAID0 up and running! If any additional system info is needed, let me know.

BTW, even a single SSD is amazing coming from a standard 7200rpm drive!

0 Kudos
2 Replies
Community Manager

What about connecting one up to the card what speeds do you get then?

Updated the driver? Any write-back cache options with the cards app or driver tab?

Community Manager


Crappy $30 controller card was limiting raid performance. Card is unable to set drives in AHCI mode, which proved to be an issue.

So what did I turn to? Windows 7 software raid! From all reviews I've read, windows software raid is actually quite fast, especially when paired with a fast and capable CPU. I tried it out and everything is running smoothly. Now getting ~480mb/sec and ~180mb/sec seq. read/write, couldn't be happier with this!

BTW, thanks for the input PeterUK. You are right though, write-caching does need to be enabled.