Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
1,327 Views

X-25M SSD and ICH8M/965Express SATA Issues

I've got a Dell Inspiron 1720 laptop that I just plugged a new X-25M 80GB G2 SSD into. It's only operating in SATA 1 mode. I believe this laptop can operate in SATA II mode....I just can't make it work. I'm running in ACHI mode with Windows 7. My details are below:

 

OS Name: Microsoft Windows 7 Home Premium

 

OS Version: 6.1.7600 Build 7600

 

System Manufacturer: Dell Inc.

 

Processor: Intel(R) Core(TM)2 Duo CPU T7500 @ 2.20GHz

 

BIOS Version/Date: Dell Inc. A09, 07/11/2008

Intel(R) Matrix Storage Manager

Intel Serial ATA Controller: Intel(R) ICH8M SATA AHCI Controller

 

Number of Serial ATA ports: 2

 

 

Driver Version: 8.9.0.1023

 

Serial ATA Plug-In Version: 8.9.0.1023

 

Language Resource Version of the Serial ATA Plug-In: 8.9.0.1023

 

ISDI Library Version: 8.9.0.1023

 

 

Hard Drive 0

 

Status: Normal

 

Device Port: 0

 

Device Port Location: Internal

 

Current Serial ATA Transfer Mode: Generation 1

 

Model: INTEL SSDSA2M080G2GC

 

Firmware: 2CV102G9

 

Native Command Queuing Support: Yes

 

Size: 74.5 GB

I've got everything up to the latest driver/firmware/rev, that I can find. I was just under the impression that this level of hardware was SATA II capable. Unfortunately, the HDD I pulled out was only SATA 1, so I can't compare there. I'm going to try in the Dell community as well, to see what they may know.

Anyone have a similar situation or have some insight?

Thanks!

Tags (1)
0 Kudos
2 Replies
idata
Community Manager
142 Views

Below are my benchmark results, first in AHCI mode and after, in ATA mode (changed the setting in the BIOS and didn't have to reimage the SSD). You can see a huge improvement. I'm assuming it's in SATA II mode now since it exceeded 150 MB/s. It's still shy of the 250 that the SSD is rated for, but it's much improved. The Intel Matrix drivers won't load now, so I cannot get that official report this time. I'm not sure what else I can tweak to get the 250 out of it.

--------------------------------------------------

 

CrystalDiskMark 2.2 (C) 2007-2008 hiyohiyo

 

Crystal Dew World : http://crystalmark.info/

 

--------------------------------------------------

Sequential Read : 134.304 MB/s

 

Sequential Write : 75.134 MB/s

 

Random Read 512KB : 121.948 MB/s

 

Random Write 512KB : 74.171 MB/s

 

Random Read 4KB : 16.043 MB/s

 

Random Write 4KB : 28.129 MB/s

Test Size : 100 MB

 

Date : 2009/10/21 9:58:44

 

--------------------------------------------------

 

CrystalDiskMark 2.2 (C) 2007-2008 hiyohiyo

 

Crystal Dew World : http://crystalmark.info/

 

--------------------------------------------------

Sequential Read : 200.909 MB/s

 

Sequential Write : 79.837 MB/s

 

Random Read 512KB : 151.993 MB/s

 

Random Write 512KB : 79.951 MB/s

 

Random Read 4KB : 16.365 MB/s

 

Random Write 4KB : 30.887 MB/s

Test Size : 100 MB

 

Date : 2009/10/21 21:42:43
idata
Community Manager
142 Views

I had a similar experience. I have an X-25M G2 160 and a 2Ghz C2D Dell Precision M4300 with ICH8M. Running XP Pro SP3 and aligned partition.

First, scores with standard IDE:

Now, with XP forced driver over to Intel AHCI driver 8.9.0.1023 (June 4 2009), then AHCI enabled in BIOS:

Note: The Intel AHCI driver has only worked on 1 out of 3 XP machines I've tried it on, definitely a "try at your own risk" because you may end up with a system that won't boot.

Reply