Showing results for 
Search instead for 
Did you mean: 
Community Manager

X25-E Secure Erase w/o User and Master Password

Hi folks,

a few weeks ago i bought a used X25-E which at this time worked perfectly. After some time i decided to run a secure erase via the Intel SSD Toolbox 2.0.2 on an ICH5 based SATA controller (ASUS P4P800 SE Mainboard). Sadly the secure erase did not finished successfully. Every time a try to secure erase the SSD it will go to 1% than 95% and after another few seconds it just returns the status "failed" - without any further details about what caused it.

Since this time the SSD is not usable because ATA SECURITY is enabled and it is LOCKED - but i don´t know either the password set for user nor for master - i never set any, the master password is still unchanged.

I tried HDDERASE 3.3 (still have to enter a password for secure erase and enhanced secure erase - so this is not an option for me), HDAT2 and HDPARM (received an I/O error after --security-set-pass, --security-unlock or --security-erase) which all seems to "repair" some broken SSD´s with a similiar history, but i´m not able to succesful secure erase my X25-E or at least disable security.

As Scott wrote in another thread:

Unplugging the drive does not unlock the drive, it just removes ATA SECURITY FREEZE LOCK. In order to secure erase the drive, the SECURITY FREEZE LOCK needs to be removed and after that, drive needs to be unlocked using a master/user password

So with the power unplug method (or sent the pc to sleep and wake it up again) i will just be able to remove the FREEZE LOCK, to perform a secure erase i still need a password which i don´t know, because the toolbox itself set it.

I tried to secure erase the SSD on another computer (Dell Optiplex 755, ICH9 SATA controller AHCI/ATA/LEGACY mode makes no difference) over the Intel SSD Toolbox, but it still failed multiple times.

Any hints?

Tags (2)
0 Kudos
2 Replies
Community Manager

I still need some help here. A few days ago I also wrote an email to tech support, but did not received any feedback yet.

Community Manager