Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
1,010 Views

X25-M performance issue in Windows 7

I installed Windows 7 on my brand new X25-M, everything went smoothly.

 

I tried to run ATTO disk benchmark to make sure the drive was performing as expected but I was shocked to see reading speed of 140-150MB/s.

 

Then I plugged back my old HD as primary and the X25-M as secondary, booted under XP, it detected the drive, ran the same becnhmark and I got 250-258MB/s reading speed!

 

Because I can get the expected performance under XP I am 100% sure my bios and cable settings are correct. I tried to update the chipset drivers under Win 7 but it still performs poorly.

 

Then I though Win7 was operating my drive as a SATA 1 device but when I turned off Write Caching I could reach 170MB/s reading speed which is a little more than the SATA 1 interface limit.

 

I am now clueless.

 

Any help greatly appreciated.

OS: Windows 7 RC 7100 

Motherboard: Asus P5B-VM (Intel G965 chipset)

 

Drive: X25-M (firmware 8820)
0 Kudos
1 Reply
idata
Community Manager
69 Views

**** Update ****

I decided to take a bet and to buy a new motherboard (P5E-VM with a ICH9R chipset) in the hope to solve the problem. It worked! I can now reach the expected fast read speed (250-260MB/s). One could think that it doesn't make a real difference in daily usage but its wrong! I can feel that everything is a little bit faster!

PS: Why not just go back with XP you may ask? After a few days with Win7 I could not go back with XP, it seemed suddenly very old and patched!

Reply