Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Community Manager
1,669 Views

X25M Fail to update firmware: please remove A: in config.sys

Hi

I downloaded the latest firmware update for the X25MG2 160GB, burned the corresponding ISO, but the update won't boot properly.

See screen capture here:

http://barre.nom.fr/temp/x25m-firmware-problem.jpg http://barre.nom.fr/temp/x25m-firmware-problem.jpg

CONFIG.SYS error in line 0

DEVICE=A:\HIMEM.EXE

My machine chokes on the hardcoded reference to A:, and I assume it would likely fail on this line as well:

SHELLHIGH=A:\command.com /P

Unless I'm wrong, A: is useless here; can you point to or re-issue a firmware devoid of this drive letter?

This is on a Dell Precision T3400, in AHCI mode (though there isn't any other compatibility mode to set it to).

The same CDROM boots properly in another (older) Dell machine at work.

I tried modifying the ISO using winimage + magic-iso, tried creating a USB boot disk as well, but without success.

I guess I can connect my SSD to another machine, but I don't really want to move my SDD back and worth between home and work each time I need to upgrade it, so I figured I would mention what seems like an easy problem to fix...

Thanks

Tags (1)
5 Replies
Highlighted
Community Manager
18 Views

Try going into your BIOS and check to see that your cd rom is the first boot device. If not, set it to be the first boot device and then try it. After the firmware updates, go into the boot device priority and change it to be the SSD. Also some people (including myself) have had to change to IDE for the update and then switch back to AHCI (BEFORE YOU REBOOT AFTER THE UPDATE).

0 Kudos
Highlighted
Community Manager
18 Views

Thanks Rick, I did try that already, assuming this would bump the CDROM to A:, without success though.

As mentioned previously, my BIOS doesn't have any compatibility mode like IDE to use (or I missed it).

I'm going to give yet another shot at creating a USB key, following these instructions:

http://communities.intel.com/message/76167# 76167

Highlighted
Community Manager
18 Views

Do you have a floppy drive installed? Are you booting with a USB stick in the computer? Either one of those can be seen as the A: drive. You might try disabling those temporarily. Are you doing this on xp or win7?

0 Kudos
Highlighted
Community Manager
18 Views

I don't have a floppy drive installed, and I'm using any of the 8 USB port available on that machine...

I'll check if I can disable all the USP ports. I'm using Win7.

Thanks

0 Kudos
Highlighted
Community Manager
18 Views

The USB boot key instructions worked. Great. I had overwritten command.com in a previous attempt yesterday, or maybe my other USB key was at fault. Your advice may have helped as well, the USB diskette was set to ON in the BIOS, even though I didn't have any; that may have hijacked A: in the past. Thanks!

For what it's worth, http://www.steelbytes.com/?mid=20&cmd=download&pid=1&lang=eng HD-Speed reports between 220 and 240 MB/sec on read. It's about twice as fast as my previous drive, a pretty decent 300GB SAS Hitachi UltraStar at 15,000 RPM on a dedicated SAS controller. And oh so much quieter. Though it's likely that if you set two of those 300GB in RAID0 you might achieve the SSD performance for cheaper, i.e. about $600.

0 Kudos