Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
1,879 Views

bios hangs when detecting X25-M G2 in AHCI mode

I've waited for up to 10 minutes for the bios to detect the SSD in ACHI mode. It just does not happen. I have to unplug the PC from the wall and the SSD from the motherboard to regain control. The SSD is recognised in IDE mode but the install of windows 7 hangs straight after the first reboot (finishing installation). Again I've waited for up to 20 minutes for the install to complete but no success. Several times there has been a blue screen but they have been so fast that I've not been able to read them. I have an WD velociraptor which works flawlessly in ACHI mode and takes windows 7 install without issue. I believe I've tried everything to make it work: using one stick of ram at a time, updating bios, using a different SATA port. Any other ideas or is the SSD faulty?

0 Kudos
3 Replies
OJIME1
Beginner
75 Views

I have a x25-m G2 in a Fujitsu-Siemmens Xa3530 laptop with the same problem that you. I think it´s a intel issue

idata
Community Manager
75 Views

As far as I know, when changing to AHCI mode in BIOS, you should always reinstall your OS. I got the same error as you when trying to change mode without reinstalling my os.

But then everything worked fine after reinstalling. Ofcourse you have to change it in BIOS THEN reinstall not reinstall first..

idata
Community Manager
75 Views

That's exactly the behavoir I got after flashing my SSD to 02HA.

Slow booting / freezing in every PC in AHCI mode.

And IDE works for a few minutes then it fails to recognize the SSD completely.

Do you run the latest (buggy) firmware 02HA, too?

Let's just hope Intel manages to bring out a bug fix to repair those SSDs without the need to RMA them...

Reply