Showing results for 
Search instead for 
Did you mean: 
Community Manager

firmware update software v 1.9 not working for multiple 320 and X25 ssds

Hi everyone, I purchased 4 320 series ssds and 1 X25 series ssd from in May of this year.

The drives are installed in three desktop and two laptop computers. I have not experienced data loss associated with the 8mb crash. All the drives are working fine.

I downloaded the version 1.9 firmware update ISO and ran it on these various machines. One is even a very old Dell optiplex computer. The firmware software sees the drives fine on all the computers, but regardless of which computer, I get the same error message that states that it cannot update my firmware as my SSD has a pre production firmware on it.

The X25 drive has the 02M3 firmware which the notes from intel indicate is correct and should be able to be updated.

My 160 gb 320 drives have firmware 0302.

I have tried the update on all the sata ports on the old dell computer, a newer asus p67 motherboard desktop, and an evga sr2 motherboard desktop, a lenovo x1 thinkpad lap top, and an acer 3810t laptop.

I even made a bootable usb stick and tried the same process for all the systems.

I have contacted intel and my case number is 8000303339.

They represenative said that intel will have to get back to me. This was several days ago.

Do I really have pre production firmware? How could I have purchased these drives from a fairly large etailer with pre production anything on them if this is the case.

Or is it possible that the firmware fix software is just buggy itself?

Hopefully Intel will keep its promise and get back to me.

I feel like I am rolling the dice keeping these drives in service

What does everyone else think?

many thanks in advance,


0 Kudos
1 Reply
Community Manager


The problem was that the ISO file was partially corrupt, so the update program would launch and instead of crashing it would fail to update the firmware and give the pre release firmware error. Nathalie R. in support sent the the file size for the key program in the iso (issdfut.exe) that I noticed the problem. Win764bit burns the iso file and this file becoms 877kb whereas the original file is 1.4mb. Surprising the program ran and the pre release firmware error was a false lead. Using WinRAR, I extracted the issdfut.exe file from the iso and copied it to a bootable USB stick. then I ran the executable file and the firmware updated .