Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,670 Views

7260AC disconnecting every 5 minutes

As the title suggests my 7260AC is dropping the connection every 5 minutes (I have timed it), but only on this certain network (other networks are fine), I am the only one on the network that loses connection.

The router is an D-Link DHP-308AV.

I am guessing some kind off compatibility issue.

I cant stand it since I cant play anything online without getting DCed.

I have the latest drivers installed.

Please help.

0 Kudos
10 Replies
Highlighted
New Contributor II
3 Views

List all of the following and maybe we can help:

Driver version

Advanced settings of the adapter properties. There's about a dozen. List them all.

Power Management tab settings for the adapter.

Windows settings for wireless adapter in Control Panel>Power Options

Router settings. For both bands (if two).

0 Kudos
Highlighted
Beginner
3 Views

(these are translated from Swedish so it may or may not be correct)

802.11n-channelwidth for 2.4GHz - Auto

802.11n-channelwidth for 5.2GHz - Auto

Ad Hoc QoS-mode - WMM Inactivated

Ad Hoc-channel 802.11b/g - 1

Activate on Magic Packet - Activated

Activation on pattern match - Activated

ARP-disburden for WoWLAN - Activated

Bluetooth(R) AMP - Activated

Prechosen band - 1. no preferred

Flowthroughbooster - Inactivated

GTK-keyupdate for WoWLAN - Activated

HT-mode - VHT-mode

Incompatible with 40MHz-channel - Inactivated

NS-disburden for WoWLAN - Activated

Packetmerging - Activated

Roaming-aggressiveness - 3.Medium

Protection for mixed mode - CTS-to-self activated

Support for U-APSD - Activated

Wireless mode 6. 802.11a/b/g

Sleepmode on WoWLAN-disconnect - Inactivated

Transfer energy - 5. Highest

--------------------------------------------------------

Driver version: 17.1.0.19

--------------------------------------------------------

Everything unchecked in power management tab of adapter.

--------------------------------------------------------

Windows energy settings:

Battery: High saving

Connected to net: High performance

--------------------------------------------------------

Unfortunately I have no access to the router settings

0 Kudos
Highlighted
New Contributor II
3 Views

Ok, let's start by matching your settings to mine. My AC7260 works without issue. So if we sync up as best we can, then, if you're still having trouble, we can investigate further.

First, in the next post, I'm going to link to a driver file. This forum requires moderator approval of links. It's a national holiday in the US, so I don't know if any of the mods are working today. You might have to wait to be able to see it. The posts don't appear in the forum until they approve. You can try the fixes below alone right now, but the driver has been found by many of us to fix a lot of performance issues with this card. I recommend that you install the driver first.

In Control Panel, uninstall ProSet software. Let Windows manage your wireless. Restart.

In Device Manager,

After you've extracted the driver folders that I've linked in the next thread, click to update the driver and point to where you extracted the driver files. Windows will load it. I'm using Windows 7 and the driver version is 17.12.0.4, dated 28/8/2014.

Make the following changes in your settings:

Ad Hoc QoS to WMM ENABLED. This often has a corresponding setting in routers. You should try to see that it's enabled there.

Power Mgt: Allow the computer to turn off this device to save power ENABLED

Windows energy: High Performance battery AND connected

Try these changes and the new driver. Good luck.

0 Kudos
Highlighted
New Contributor II
3 Views

Download this driver: https://www.crc.id.au/files/Intel%20AC-7260%20v17.12.0.4.exe https://www.crc.id.au/files/Intel%20AC-7260%20v17.12.0.4.exe

It is version 17.12 that another member downloaded from an OEM site. This is a self-extracting zip file that includes the drivers for the various Windows flavors.

Edit: Wow, that was fast. Guess somebody is on the job today. Hello mod, wherever you are. Happy Thanksgiving.

0 Kudos
Highlighted
Beginner
3 Views

OK thanks for your help, I will try these settings and the new driver, will return with results

0 Kudos
Highlighted
New Contributor II
3 Views

One other thing to play with if you need to. The setting for U-APSD. Some peeps do better with that one disabled, but I don't think that there's a consensus. Mine is enabled and I've never changed it.

0 Kudos
Highlighted
New Contributor II
3 Views

Well, shoot. I edited my post with the link and that set it back to requiring moderation.

Sorry.

0 Kudos
Highlighted
Beginner
3 Views

dont worry, already downloaded

0 Kudos
Highlighted
Beginner
3 Views

Thanks, it worked, now only getting really small lag (might be because of slow speed) and NO DROPS YAY. Thanks GattoNero for all your help!

0 Kudos
Highlighted
New Contributor II
3 Views

If you can get to the router, make sure that WMM is enabled and, especially, that security is WPA2-AES. Don't use TKIP. You need WPA2 and AES, otherwise the router is locked down to 54Mbps.

0 Kudos