Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
6718 Discussions

AC-3165 Shows as connected but drops to limited connectivity frequently


Note: This is the exact same issue that I had on an older 6100 series intel wifi chip. That was only solved by using the 16 series driver, sadly this new chip does not have a driver that seems to fix this.

Recently my boss upgraded to a new Lenovo laptop from an older Samsung. From the moment we powered this unit on it would connect to the internet on our company WiFi (using TP-link EAP120's with the October 2015 firmware ) but randomly would show "Limited connectivity" and "Unknown Network" and the only way to get it to browse the internet was to restart the adaptor.


  • This computer is using windows 10 x64 with all patches and updates from MS and Lenovo.
  • This is not a sleep mode related issue as the problem pops up in the middle of surfing.
  • Event log shows the lack of connection to a DNS server (just telling me the connection is lost) and event ID 5060 along with the reconnect attempts.
  • The problem happens randomly every 5mins-2 hours.
  • The network runs perfectly stable on all other devices (sometimes hundreds of them). The only other time this has happened is with the old laptop that also had an intel wifi chip in it (w7 Samsung from 2013).

Odd note: If I run a continuous stream of data from say a looping ping test then it is 100% rock solid for hours and hours.

I have tried:

On the AP's:

Changing the SSID to broadcast

Different SSID

Adjusting the group key update period (including disabling it)

Multiple different Ap's

On the wifi card:

Every driver available from the default windows 10, through the 17 and 18 series always using clean installs. Also tried just the driver as opposed to the proset.

Forcing the ip address


Enabling and disabling:

"Allow this computer to turn off this device to save power"

VHT mode

U-Apsd Support

Wake on magic packet

On the laptop in general:

Setting power profile to maximum

Setting wireless power profile specifically to maximum.

As it is the WiFi is unusable so we are forced to hardwire. So if you have any gems please let me know. I took and tried (without success) every suggestions from the very long 7260 thread as the issues were very similar.

0 Kudos
10 Replies
Honored Contributor II


Intel recommends that you always contact the computer manufacturer in order to obatin the latest customized drivers: http://www.intel.com/content/www/us/en/support/topics/OEMs.html Computer Manufacturer Support Websites

We also would like to inform you that we have recently released a new driver version (18.32.0) for the Intel® Dual Band Wireless-AC 3165 which contains a lot of fixes. Could you confirm whether you have tried this new version? If you haven't tried it yet, here is the link to it: https://downloadcenter.intel.com/download/25683/Intel-PROSet-Wireless-Software-for-Windows-10 Download Intel® PROSet/Wireless Software for Windows® 10 - File name: Wireless_18.32.0_PROSet64_Win10.exe size: 96.08 MB.



I perhaps was not clear enough so I will elaborate.

These are the drivers that I have tried:

From Intel Direct (note driver only and Proset were tried separately for each driver)









From Lenovo:

(Whatever version came with the unit, I did not notate the version)

For the previous laptop with the 6150 (i think) the driver version that fixed the issue was from the 14 series. So whatever was added in the 15's + borked the entire line as evidenced by the hundreds of pages of posts on similar issues (mostly from standby) spanning a huge array of cards from intel.

Honored Contributor II


Since you have tried our latest driver version and the issue still persists, please check this link from Microsoft* as they offer a procedure that might resolve the limited connection: http://answers.microsoft.com/en-us/insider/forum/insider_wintp-insider_web/limited-connectivity-issue-with-windows-10/d92fa635-4cca-4268-8202-22f4eb903d0d?auth=1 Limited connectivity issue with WIndows 10, Internet working fine. - Microsoft Community



The issue is not that it simply displays "limited connectivity" there is no internet when it does this. It shows as connected, even shows the network and a speed but the status screen shows no internet and no network traffic happens.

Honored Contributor II


Limited connection implies that your computer detects that a network is present and operating and it also implies that your computer request for an IP address went unanswered and therefore may not be related to the wireless adapter. Please try the following:

1. Go to Control Panel >> Device Manager >> Network Adpaters

2. Select the Intel® Dual Band Wireless-AC 3165 and right click on it.

3. Select Properties and click on the tab that says Power Management and uncheck " Allow the computer to turn off this device to save power."

Additionally, try resetting TCP/IP and DNS, the instructions are below:

1. On Windows®10, open the search bar or Cortana and type CMD, once it pops up, do the following:

2. Type the following command: ipconfig /release and press Enter, this will release the current IP configuration.

3. Once you have done this, type the following command: ipconfig /renew, this will renew the IP configuration.

4. And last but not least, you can flush the DNS cashe and renew them again by typing the following command: ipconfig /flushdns

5. *Please note that there is space between ipconfig and the / only, what comes after is together with the slash with no space.



I appreciate your continued responses but please understand that I already tried the "3. Select Properties and click on the tab that says Power Management and uncheck " Allow the computer to turn off this device to save power."" suggestions as stated in my original post and it is frustrating to have typed out what I have done and what the problem is just to have it ignored.

Additionally renewing the ip and the flushing dns is a nice diagnostic trick but it is achieved by disabling the adapter, either forcibly, via "airplane modes", or reinstalling the drivers which I have done dozens of times. I did try that trick when the connection drops out and while it does fix the issue (faster to enable airplane mode, count to 10, then disabling it) it is not viable to tell the user to do that 1-10 times per hour.

Remember, as I said before, this is exactly the same issue hundreds of people have posted about across a large swath of intel adapters, that I myself have seen before and was only fixed by reverting to the 14 series driver. Sadly, this card has no driver that is free of the issue.

And before you ask in the mean time I have tried restoring windows 10 and installing a fresh (clean) copy of win 10. The problem persists.

We have moved to a wired setup for this machine but would like a better solution.

Honored Contributor II


Probably we will have to engage a higher level of support for your specific issue. In the mean time, before we move into the next step, could you confirm if you have gone through these solutions?

http://www.intel.com/content/www/us/en/support/network-and-i-o/wireless-networking/000006057.html Current Top 10 Frequently Asked Questions for Network and I/O

http://www.intel.com/content/www/us/en/support/network-and-i-o/wireless-networking/000005585.html Advanced Wi-Fi Adapter Settings for Network and I/O

http://www.intel.com/content/www/us/en/support/network-and-i-o/wireless-networking/000005582.html?wapkw=technote Resolving Wi-Fi Connection Issues for Network and I O

http://www.intel.com/content/www/us/en/support/network-and-i-o/wireless-networking/000005493.html Quick Checks That Might Improve or Fix Connection Issues for Network...

http://www.intel.com/content/www/us/en/support/network-and-i-o/wireless-networking/000006042.html Improve Your 802.11n Wireless Performance for Network and I/O

http://www.intel.com/content/www/us/en/support/network-and-i-o/wireless-networking/000006697.html Data Rate Will Not Exceed 54 Mbps When WEP or TKIP Encryption is...

Honored Contributor II


Another thing that can be done is to check if Power settings are disabling the connection settings in the Power Saving Mode. Please make sure the U-APSD is disabled completely. Regarding the AP, have you checked if there is any settings that could be turning the connection off when there is no handshake for certain period of time. Could you also try this without authentication and see how it behaves.


I have the same problem on my Lenovo Yoga 700-11ISK laptop with the AC-3165 module. The wireless connection tends to seemingly randomly drop, with Windows displaying the "connected, no Internet" status. I tried updating all the drivers, disabling the PROSet/Wireless Zero Configuration service, some tweaking in the adapter's advanced settings - but no luck. I still haven't found a satisfying solution, but I seem to have isolated the root cause.

The times of dropout seem to correspond with the times when the residential gateway switches between 20MHz and 40MHz 802.11n HT modes. I have a Thomson TWG870UG at my house (it's an ISP-owned DOCSIS modem-router), and when I looked at its event log, I saw messages like these:

Tue Aug 16 00:57:14 2016 Notice (6) WiFi Interface [wl0] set to Channel 1 (Side-Band Channel:5) -...


Tue Aug 16 01:02:48 2016 Notice (6) WiFi Interface [wl0] set to Channel 1 (Side-Band Channel:N/A)...

Times at these logs seem to correspond to the times of the dropouts. Interestingly enough, dropouts does not seem to happen when manually switching channels (even between bands) and HT modes, so it might be somehow related to interference from other networks. It might also be related to the fact that the sideband channel was set in router's UI to be below the control channel, but, as you can see, the automatic channel selection was setting it to above the control channel anyway. Weird things happen on those routers...

After I disabled the PROSet/Wireless Zero Configuration service, Windows started to be able to automatically restart the adapter and reconnect to the network when the dropout happened, but it was taking it an unnacceptable couple of minutes. The Event Log shows two "WLAN AutoConfig detected limit connectivity, performing Reset/Recover adapter." messages in that case, the first having "1 0xC 0x4" code, and the second, suspiciously, "2 0xDEADDEED 0xEEEC".

I'm currently attempting to work around this issue by switching my home network to a manually selected channel in the 5 GHz band (as it seems to be much less crowded than the 2,4 GHz band here). Still, it'd be nice for this problem to be resolved properly. While this seems to be partly an AP-related issue, it isn't happening with other computers/adapters.

Honored Contributor II


What OS do you have installed?

Please, try to reset the router and try the connection again.

Let us know as soon as you can.

best regards,