Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7512 Discussions

AX200 160MHz slow download but normal upload speed


HI all

I got the new AX200 intel card from Asus.
Runnning Intel Driver:
Windows Version 10 20H2

Wifi Signal is 1.9 Gbps - 2.4 Gbps - screenshot

AccessPoint is: Unifi 6 LR

Speedtest says: 550-600mbit download & 900-940Mbit upload

I got fine 930 download and 930 upload, with Cable in my Computer.

Im running on HE160, and is 3 meters away from the AccessPoint. - screenshot.

Im living in a house, with no neighbor on the same channels.

I have tryed another old Intel driver, with the same results.
I have tryed windows build-in driver, with the same results.
I have tryed setting the Channel to HE80. Same results.

Any ideas ?
Or can AX200 not running higher than 600mbit download ?

0 Kudos
9 Replies
Valued Contributor I


You don't mention the type of PC or laptop you are using. If the PC/laptop has an Ethernet port have you tried the speedtest using cabled Internet instead of wireless? You also don't mention what network card was in the PC/laptop before - I am guessing the AX200 is a replacement for something else since you indicate you received just that part from Asus.

Would you please download and run the Intel System Support Utility. Then leave the default settings and click Scan, save the results and post the file back as an attachment. The link to the SSU is here: https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-

I am also attaching a link to the Intel knowledge page that provides details on the settings of the adapter. You will need to pair these settings with the settings on your access point. The information is here: https://www.intel.com/content/www/us/en/support/articles/000005585/network-and-i-o/wireless.html


0 Kudos

Ty for getting back.

Im using a PC
And yes, I got 930/930 on cable, as I also mention in the top

Old Wifi:
I was using a USB dongle, to the old setup, and a old Unifi LR.
I have got a new ISP, so now I have 1000/1000
So i have upgraded my AccessPoint and Wifi card, to wifi 6, to be cable to use my new ISP speed.
Cable testing says 930-940 download and upload.
So thats the speed we are looking for.

As mention, i can run 930mbit Upload, just fine over the new wifi.
Just wanna be sure, if its correct, my download cant get over 600mbit for some reason.

I have uploaded the SSU file.

I  have allready read the knowledge page.
All settings are fine.
I dont have any neighbors or wifi noise.
And i can only see my own wifi network, when i scan for others wifi

0 Kudos

Ive have done some LAN testing to, between my PC and my Server.

Screendump attached.

When I transfer 10GB temp files over LAN network, i have about 900-950 MBIT in Download and Upload.

But when testing from speedtest, I still only get 600Mbit download and 930Mbit upload.

My conclusion is, Its working fine from LAN network.
I have testet the cable again, where the AccessPoint is conenct to. 
Then speedtest says 930/930

Thats very weird why my speedtest over wifi, only have 600mbit download on the Internet.
But Local Network, i still have the 900+mbit download

No idea why this happends

0 Kudos
Valued Contributor I


You should look through both the access point and router and see if there is anything active for QoS or Quality Of Service. Additionally, your router may have some type of load balancing. Essentially, load balancing and some implementations of QoS act to throttle inbound or outbound traffic to prevent a single device from consuming all the bandwidth. This helps to assure there is sufficient bandwidth for other purposes such as gaming or streaming. Since you get full bandwidth when bypassing the access point, that would make the access point the likely culprit.


0 Kudos

Ive have been looking my devices, and found that QoS/Quality Of Service is disabled.
Ive done some testing with a few others settings, like Turning off DPI scan, and Hardware Offline on the USG router.
Its still the same.

But there is something i dont understand here.
If i running with a cable, there is NO problems.
Running on Wifi, its only the download to Internet, that is on 500Mbit.
If its works fine on cable, its should not be any config/settings on my router.
I also have around 950mbit in download and upload from the Wifi, If im sending data to my server on my LAN network.

I will ask Community Forum in the Unifi universe for help with this issue to.

New Speedtest from Wifi.

My understanding is, Wifi is OK on LAN site, since i can get round 950mbit from moving files from local servers, but something is blocking my download to 50% of speed, when comming from wifi and going to the Internet
There must be some kind of a firewall/settings in the Unifi USG Security Gateway
I will ask the Unifi community about this to

0 Kudos

Just to follow up.
I have never bypass my accesspoint.

I have testet file transfer over wifi, to my lan server.
Then i have around 930/930 mbit in download and upload, over the wifi.

But doing speedtest, i only got 500 download but still 930 upload.
I will try bypass my Unifi router later today. Perhaps some performance settings on that.

0 Kudos

Hello AndersDK,

Thank you for posting on the Intel* Community.

We have been checking your thread, here are some recommendations from Intel* when having a slow download speed:

  • Perform a clean install to avoid driver conflict with older versions. See article Clean Installation of Wireless Drivers
  • After installing the latest driver if the issue persists, you may need to change the network configuration for the router or client. If the router&client are using different wireless standards, Wi-Fi speeds will be limited by the lower of the two standards. Please contact the router manufacturer for instructions.

Also, we noticed that you said that you will try to bypass your Unifi router, please let us know the outcome.

Best regards, 

Maria R.  

Intel Customer Support Technician 

0 Kudos
Hi Maria

I have bypass my router, to see the speed on a high Performance mikrotik. Download speed is still 600mbit and upload is full speed at 930 Mbit.

Remember, its only if i speedtest to the internet/wan i only have the 600mbit download.

If i speedtest with files on local network, over the WiFi, I can do 930/930 both ways over the WiFi.
So its only when speedtesting to wan.

I dont think its the driver or something with the Intel ax200 card since i fine can run full speed on the local network.

I have also a ticked in unifi community where they try help.
Lets close this ticked, becouse local test is fine.

0 Kudos

Hello AndersDK, Thank you very much for sharing those details.

Sure, no problem at all, it is great to hear that the local test is fine, we will proceed to close this ticket as you requested.


Any other inquiries, do not hesitate to contact us again.


Albert R.

Intel Customer Support Technician

0 Kudos