Wireless
Issues related to Intel® Wireless Adapters and technologies
5758 Discussions

AX200NGW not working on Ubuntu 20.10 (Kernel 5.08)

Pablo_
Beginner
2,034 Views

Hi, i'm trying to make work the module 'AX200NGW ' on Ubuntu.

Sometimes fail to load the driver others starts ok but stop working after a while and others freezees the sytem.

 

It seems to be related with drivers, so i've already tried:
- This version of Ubuntu tries to load 'iwlwifi-cc-a0-XX.ucode' where XX = 56 until XX = 39 from '/lib/firmware'.
Already tried with versions from 55 to 46 from 'https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/tree/'. None of them make a difference.

 

Attached there are several files:


- Generated file from the script 'Intel® System Support Utility (Intel® SSU) for Linux* operating system' . Also showed this on te console:

This product is not supported on this operating system.
Would you like to try to scan? (y/n)
y
The None missing package is recommended to retrieve ethtool details.
Would you like to try and install it now? (y/n)
y


- A photo of the module

- Log from 'dmesg | grep iwlwifi' when the driver is loaded ok. First tries to load version 56, but as far as i saw there is no such version, so starts looking for version 55.


Here goes some other info:

 Is this the original adapter that came pre-installed on your computer or did you change/install the adapter to this one?   

I added the adapter (photho attached)

 Is the Bluetooth working?   
All the test have been done with bluetooh off just in case it could make any interference.

Is this a laptop or desktop computer? 
Is an 'all in one'. The motherboard is :
https://seavo-com.translate.goog/en/products/info_219_itemid_103.html?_x_tr_sl=en&_x_tr_tl=es&_x_tr_...


 Have you update your drivers and BIOS? 

No

 

lspci | grep Network
01:00.0 Network controller: Intel Corporation Wi-Fi 6 AX200 (rev 1a)


modinfo iwlwifi

.

.
firmware: iwlwifi-cc-a0-56.ucode

.

.

 

lsmod | grep iwlwifi
iwlwifi 368640 1 iwlmvm
cfg80211 782336 3 iwlmvm,iwlwifi,mac80211


dmesg | grep ASSERT   
[ 2672.659502] iwlwifi 0000:01:00.0: 0x0000109E | ADVANCED_SYSASSERT
[ 2718.774723] iwlwifi 0000:01:00.0: 0x20101058 | ADVANCED_SYSASSERT


This commands have been tested when all is working. When it fails to load the driver the error is:
0x00000071 | NMI_INTERRUPT_UMAC_FATAL
Microcode SW error detected

If there is any other information / test i coould done, let me know.

Thanks!

0 Kudos
22 Replies
Pablo_
Beginner
100 Views

Hi Alberto_R_Intel,

Thanks for the extra information. Maybe my explanation wasn't clear. I've got a AX200NGW connected to the main board. I wondered if i need any extra adapter (apart from which i'm using to connect the AX200). I guess this asnwer my question anyway: 
Still, you can always check that the System Interface Type of both cards is Wi-Fi(PCIe), BT(USB) and the Board Form Factor is M.2 2230, M.2 1216.
Both wireless modules seems to have the same interfaces so i'll be able to reuse the adapter i've got.

I'll keep in touch for any update. 

Thanks!

Alberto_R_Intel
Moderator
97 Views

Hi Pablo_, You are very welcome, thank you very much for confirming that information.


"Both wireless modules seems to have the same interfaces so i'll be able to reuse the adapter i've got.", yes that is correct, in that case, you should be able to reuse the same adapter.


"I'll keep in touch for any update. ", sure, no problem at all, any other inquiries, do not hesitate to contact us again, we are glad to help.


Regards,

Albert R.


Intel Customer Support Technician


Reply