Issues related to Intel® Wireless Adapters and technologies
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
5655 Discussions

Blue screen when using phone as hotspot

Community Manager

This is the best I can deduce. I am moderately inept with computers, but not totally! tl;dr I am getting a blue screen error when I connect to my ATT wifi hotspot.

Specs of all parties involved:

Phone - HTC One X running Android 4.0.4 - ATT says no updated needed

Laptop - Win7 Home Premium 64bit, Service pack 1. Dell XPS L702X - intel i7-2620 @2.7ghz. 8gb ram

Wireless adapter - intel centrino wireless-n 6150

A few weeks ago windows 7 auto-updated, and afterward I would lose internet connection intermittently. I am on a netgear wifi router, connected to a comcast modem. Windows said no drivers needed updating, so called comcast.

Comcast told me the modem was bad and to exchange. Did this, no fix. Internet still went out frequently. Searched for fix, found another guy having the same problem, went to intel's website and let their auto scanner look at my drivers. Lo and behold I needed driver updates. Updated, swapped out a faulty coaxle, and have not had even a second of internet connectivity issue since - when using the netgear wifi router or hard-connected to modem.

But, it seems to have created a new error. When I try to use my phone as a wifi hotspot, I connect and then immediately get a blue screen error. This is both annoying and concerning - I use my phone for wifi regularly while working and blah blah blah.

ATT's website had one thread with a guy having the same problem, no solution. It suggested I debug the .dmp generated by the blue screen, and look on this forum for help.

So, installed windbg, followed the steps listed at [URL="http://windows7themes.net/how-to-open-dmp-files-in-windows-7.html http://windows7themes.net/how-to-open-dmp-files-in-windows-7.html"]http://windows7themes.net/how-to-open-dmp-files-in-windows-7.html[/URL] http://windows7themes.net/how-to-open-dmp-files-in-windows-7.html[/URL] and here is what the thing spit out at me (that I can't decipher):

[quote]Microsoft (R) Windows Debugger Version 6.12.0002.633 AMD64

Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [C:\Windows\Minidump\012513-42042-01.dmp]

Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*C:\Symbols*http://msdl.microsoft.com/download/symbols http://msdl.microsoft.com/download/symbols

Executable search path is:

Windows 7 Kernel Version 7601 (Service Pack 1) MP (4 procs) Free x64

Product: WinNt, suite: TerminalServer SingleUserTS Personal

Built by: 7601.17944.amd64fre.win7sp1_gdr.120830-0333

Machine Name:

Kernel base = 0xfffff800`0321b000 PsLoadedModuleList = 0xfffff800`0345f670

Debug session time: Fri Jan 25 15:24:16.759 2013 (UTC - 5:00)

System Uptime: 0 days 1:59:41.117

Loading Kernel Symbols




Loading User Symbols

Loading unloaded module list



* *

* Bugcheck Analysis *

* *


Use !analyze -v to get detailed debugging information.

BugCheck D1, {39, 2, 0, fffff880056bcef9}

Unable to load image \SystemRoot\system32\DRIVERS\Netwsw00.sys, Win32 error 0n2

*** WARNING: Unable to verify timestamp for Netwsw00.sys

*** ERROR: Module load completed but symbols could not be loaded for Netwsw00.sys

Probably caused by : Netwsw00.sys ( Netwsw00+9fef9 )

Followup: MachineOwner


0: kd> !analyze -v


* *

* Bugcheck Analysis *

* *



An attempt was made to access a pageable (or completely invalid) address at an

interrupt request level (IRQL) that is too high. This is usually

caused by drivers using improper addresses.

If kernel debugger is available get stack backtrace.


Arg1: 0000000000000039, memory referenced

Arg2: 0000000000000002, IRQL

Arg3: 0000000000000000, value 0 = read operation, 1 = write operation

Arg4: fffff880056bcef9, address which referenced memory

Debugging Details:


READ_ADDRESS: GetPointerFromAddress: unable to read from fffff800034c9100





fffff880`056bcef9 488b4728 mov rax,qword ptr [rdi+28h]




PROCESS_NAME: Wow-64.exe

TRAP_FRAME: fffff80000ba20f0 -- (.trap 0xfffff80000ba20f0)

NOTE: The trap frame does not contain all registers.

Some register values may be zeroed or incorrect.

rax=ffff008005123a48 rbx=0000000000000000 rcx=fffffa80096fa7a0

rdx=fffffa8007925020 rsi=0000000000000000 rdi=0000000000000000

rip=fffff880056bcef9 rsp=fffff80000ba2280 rbp=0000000000000000

r8=fffff80000ba2348 r9=00000000c0000001 r10=fffff880060e8840

r11=0000000000000002 r12=0000000000000000 r13=0000000000000000

r14=0000000000000000 r15=0000000000000000

iopl=0 nv up ei pl nz na po nc


fffff880`056bcef9 488b4728 mov rax,qword ptr [rdi+28h] ds:8600:00000000`00000028=????????????????

Resetting default scope

LAST_CONTROL_TRANSFER: from fffff80003299569 to fffff80003299fc0


fffff800`00ba1fa8 fffff800`03299569 : 00000000`0000000a 00000000`00000039 00000000`00000002 000...

0 Kudos
16 Replies
Community Manager

I am having this exact same problem connecting my Windows 8 Lenovo W510 Thinkpad; Intel Advanced-N 6200 AGN Centrino adapter; latest available Intel provided driver. Abends and restarts after a few minutes when connected to my Verizon Nokia 822 Windows 8 phone hotspot. Problem happens only with the phone hotspot. Seems to work fine with non-mobile hotspots.

Community Manager

Same problem with Nokia 822 and Windows 7 laptop, rolling back to earlier version of intel driver seems to have solved the problem so far.

Community Manager

An update.... I resolved the issue by going into Device Manager and reverting from the latest Intel driver to the driver that Microsoft bundles with Windows 8 for this adapter, dated 10/7/2011. No further problems. There is another thread on this bug:

/message/175477# 175477 Advanced-N 6230- Driver + Win 8

Thank you for posting.

We are taking note of your findings.

Community Manager

I'm having a very similar problem also. The problem occurs every time I try to use my cell phone as a wireless hotspot. I've noticed that there seems to be a correlation between volume of network traffic and how quickly the Blue Screen of Death (BSOD) occurs. The more network activity I create after connecting to my cell phone wireless hotspot, the more quickly the BSOD appears. That being said, so far I have never been able to use the connection for more than a few minutes and in many cases the BSOD occurs immediately after the wireless hotspot connection is established.

I see the same Netwsw00.sys file identified in the BSODs I'm getting that the original poster saw. I have the same DRIVER_IRQL_NOT_LESS_OR_EQAL 0x000000d1 but my arguments differ slightly from the original poster. For example, in my latest BSOD I saw:

Arg1: 0x0000000000000029, memory referenced

Arg2: 0x0000000000000002, IRQL

Arg3: 0x0000000000000000, value 0 = read operation, 1 = write operation

Arg4: 0xfffff880066caef9, address which referenced memory

I have the following configuration specifics. Let me know if you need more configuration information or memory dumps...I have plenty of the latter.

  • Nokia Lumia 920 Black
    • Windows Phone 8 (8.0.10211.204)
    • 1232.5962.1314.0001 Firmware
    • Hardware revision
    • 1.0.20209MT.3 Radio software version
  • Dell Precision M6600 Mobile Workstation
    • Intel i7-2760QM @ 2.40 GHz
    • Intel 82579LM Gigabit Network Connection (Intel v12.2.45.0 driver)
    • Intel Centrino Ultimate-N 6300 AGN Wireless (Intel v15.3.1.2 driver)
    • Windows 7 Ultimate SP1 64-bit

Let me know if you need any mini-dumps or need me to run some additional tests. I plan on trying the driver rollback mentioned by some previous posters within the next few days because I need to have this working soon. I need my phone as a hotspot when I travel and I have a trip coming up next week.

Thank you.

Community Manager

I'd like to chime in with similar findings. I can reproduce this problem consistently with my HTC 8X Windows Phone (Verizon) when being used as a hotspot with multiple machines using Intel WiFi adapters, including the latest shipping models of:

- Dell E6230

- Lenovo X1 Carbon

- Latest builds of OEM and Intel driver releases.

The same problem does not occur when using a MiFi 4G hotspot.

BSOD is always in Netwsw00.sys. I can provide minidumps if that would help the engineering/qa team.


Community Manager

Everyone, I may have a workaround that I found on the Nokia community forum that seems to have resolved the problem for me. Hopefully it will work for you too. I found this on the Nokia forum and although you may not have a Nokia phone, I'm confident that the problem is not specific to the phone.

Disclaimer: I don't work for Nokia or Intel and I've only tried this with my own system. Your results may vary. Please post any errors you find with the workaround procedure I've provided below. Here's the link to the discussion in the Nokia forum: http://discussions.nokia.com/t5/Nokia-Lumia/Lumia-920-Shared-Internet-causes-Win8-Laptop-Blue-Screen... Lumia 920 Shared Internet causes Win8 Laptop Blue ... - Nokia Support Discussions. IMHO, Intel still needs to address this problem with the WiFi driver, perhaps this workaround will help Intel Engineering isolate and fix the problem.

The following workaround procedure assumes you're allowing Windows to manage your WiFi connections rather than Intel's PROset utility. Make sure that your WiFi card is enabled and that you do not have an established WiFi connection with your wireless phone hotspot (otherwise your PC may BSOD in the middle of the procedure). You will need to know your phone's hotspot SSID to complete this workaround.

  1. Open Network and Sharing Center in the left margin of the Network and Sharing Center click "Manage Wireless Networks" the "Manage Wireless Networks" window should open with a list of WiFi hotspots that you connect to automatically.
  2. If an entry for your wireless phone hotspot already appears in the list of wireless networks, right-click that entry and select "Properties" from the context menu and proceed to step 10. Otherwise, click "Add" from the "Manage Wireless Networks" window menu. You should be presented with a dialog with two choices: "Manually create a network profile" and "Create an ad hoc network. Click on "Manually create a network profile". You should be presented with the "Manually connect to a wireless network" dialog.
  3. Enter your phone's hotspot SSID in the "Network name: field.
  4. Choose the WiFi security type used by your phone when it serves as a hotspot (typically "WPA2-Personal") from the "Security type" drop-down list.
  5. Choose the Encryption type that matches your phone hotspot from the "Encryption type" drop-down list.
  6. Enter your phone's hotspot password (a.k.a. shared key) in the "Security Key" field.
  7. Check the "Start this connection automatically".
  8. Leave the "Connect even if the network is not broadcasting" checkbox unchecked (unless your configuration specifically require it to be checked). Click "Next". You should get a "success" message that the new entry was added along with an option to "Change connection settings".
  9. Click the "Change connection settings".
  10. The "xyz Wireless Network Properties" dialog should open (where "xyz" is the name or SSID of your phone when you use it as a hotspot).
  11. Click the "Security" tab.
  12. Click the "Advanced settings" button. The "Advanced settings" dialog box should open.
  13. Check the "Enable Federal Information Processing Standards (FIPS) compliance for this network.
  14. Click Ok button to close the "Advanced settings" dailog.
  15. Click Ok button to close the "xyz Wireless Network Properties" dialog box.
  16. Click the "Close" button to close the "Manually connect to a wireless network" dialog box.
  17. Enable your phone's wireless hotspot (i.e. internet sharing). Your computer should automatically connect to your phone's hotspot. If it does not, check the settings above to make sure the computer and phone are using the same communication parameters.

This Works for the Wifi Link 4965AGN. Thanks!!!


Many many thanks! This solved my problem of BSOD when trying to use my LG Nexus 4 phone as a hotspot with my Samsung Series 5 laptop.

Thanks again, you saved my day

It was just basically a question of tweaking the "Check the "Enable Federal Information Processing Standards (FIPS) compliance for this network." setting. Cheers!

Message was edited by: Arttu TenkilS


Thanks so much for your detailed info on this workaround. I had this exact BSOD problem constantly on a ThinkPad w/ Intel Centrino 6250 connecting to a Nexus 4 hotspot. Your steps to create a manual profile with FIPS enabled did the trick! I'm posting this now via that same connection, and can confirm that it's running stable.


This solved the BSOD for me, thanks!

Community Manager

I would like to add that I have updated my drivers to v15.4.1.1 from the Intel website and I am still seeing the problem.


I see this option on my Win7 Machine but not my Vista one. Is this workaround still viable on Vista?


It looks like Intel may have finally fixed this bug in the latest PROset/Wireless package, version 16.1.1, which was just released a few days ago, on August 7. I haven't tried it on Windows 8 yet, but I installed this package on my laptop with an internal Centrino Advanced-N 6230 adapter, running Windows 7 64-bit, and it brought the driver to version 15.9.05, dated 6/16/2013. I am apparently now able to successfully connect to the wireless hotspot on my Verizon Incredible 4G LTE (aka HTC Fireball model ADR6410LVW) running Android 4.0.4 without bluescreening. Prior to installing this latest driver, the laptop would consistently BSOD in under minute after connecting to the hotspot.


I have a Lenovo Thinkpad X300, Win7 Professional (32 bit), Intel(R) Wireless WiFi Link 4965AGN, T-Mobile Hotspot on a Samsung Galaxy 4S Relay 4G, and have been getting the BSOD for months when I try to connnect. T-Mobile had a fix, then it didn't work when I reset the phone, and t-Mobile finally told me it was a BIOS problem.

Rather than believing them about the BIOS problem, I followed the advice here and on a related thread, /thread/33377 https://communities.intel.com/thread/33377, here's what I did:

  • rolled back to earlier driver, (dated 03/26/09), but still got BSOD.
  • In - "Enable Federal Information Processing Standards (FIPS) compliance for this network." is unchecked.
  • In - - -, disabled 802.11n Mode.

That seems to have solved the problem: no BSOD after an hour of using the Hotspot, speed roughly comparable to what I get on my Netgear router.


Hello everyone,

I've been having the BSOD issue whenever I try to connect my old Getac B300 laptop to either of the two new Sony Xperia V Android phones I had purchased recently. Before these two, I never had any issues with the two Xperia U's or the much older Xperia Rays, and likewise with the Huawei 4G WiFi modem I run at home.

I've read through some posts here and there, and figured that some common sense would be in order. I've seen it suggested somewhere that the Intel Wireless Wifi Link 4965BGN adapter might be having some issues with 802.11n mode, so I wanted to try to disable it and see what happens:

I haven't had any issues so far.