Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7086 Discussions

Bluetooth card not detected in Windows 10 (AC 3160)


Computer model: Inspiron 5559

OS: Win 10 64 bit

Bluetooth card: Intel Dual Band Wireless-AC 3160 (802.11 wireless + Bluetooth in one)

Problem: Bluetooth driver not working (Bluetooth card not recognized by Windows)

I recently did a clean install of Win 10 on a new hard drive, and I have been unable for the life of me to get my bluetooth card working. Windows doesn't detect it, and it doesn't show up in device manager as an unrecognized device.

When I install the bluetooth driver, the card appears under device manager (but not settings or the action center) until the computer is restarted. It seems that windows is "updating" the drivers and removing the (in its view) absent device. I've installed all the versions of driver available on the Dell support website, and on the Intel support website here.

Given that a number of other people on this forum (linked below) have what seems to be the same problem across a number of different computer manufacturers, I presume that this problem is unrelated to the manufacturer and instead either with Intel's firmware or Windows' device detection.

The card is a 802.11 + bluetooth in one card, and the 802.11 aspect of it works perfectly. This issue is specifically with the bluetooth aspect.

To answer the obvious questions, yes, I do a full uninstall of the existing driver and restart the computer before installing a new driver, and yes, I'm downloading the 64-bit version of the driver to match my system. The installer completes and doesn't give any error messages. I choose the 'complete' option when installing the driver package. And my UEFI does have an option in the boot settings to enable/disable the bluetooth card, but that's set to 'enable'.

This Intel support article suggests the existence of a wireless diagnostic utility, but after I installed the PROSet package I didn't see any such tool. For a 400MB install it appears to be a very limited program.(I clicked on 'custom' and installed everything listed.)

My situation is different from the other posters in this forum in that my laptop came with Windows and all drivers preinstalled, and on that install the bluetooth card works fine. It's only with this clean install that Windows doesn't recognize the bluetooth card. I haven't formatted that drive, so I'm able to swap out my new hard drive (an SSD) for the old one (an HDD) to check the setttings. The driver version on the HDD is 19.10.1635.483, which is currently available on Intel's site but not Dell's. (Yes, I've tried installing that version as well.)

I've done some reading about how to backup/extract installed drivers and will likely give that a shot, but I'm doubting it would make a difference since this issue seems unrelated to any particular specific driver version.

Has anyone else had problems (or success) getting Bluetooth to work this particular card or driver on a clean install of Windows?

How can I get Windows to recognize that there is a Bluetooth-capable card in the computer?

Is extracting the drivers from the HDD install where the bluetooth card works worth the effort?

Are there any settings from the working HDD install that I should be looking at or comparing with the SSD install?

Thanks for any help you can provide.

For reference, here are the specific drivers I've tried and their associated download pages:

Dell support website (http://www.dell.com/support/home/us/en/04/product-support/servicetag/2s0wnc2/drivers/advanced http://www.dell.com/support/home/us/en/04/product-support/servicetag/2s0wnc2/drivers/advanced, under 'network):

19.1.1627.3533 ,A02

17.1.1524.1353 ,A00

Intel support website (https://downloadcenter.intel.com/download/26510/Intel-Wireless-Bluetooth-Software-for-Windows-10%3Fproduct%3D75442%29: https://downloadcenter.intel.com/download/26510/Intel-Wireless-Bluetooth-Software-for-Windows-10?product=75442):






And the other forum threads where people seems to be describing the same issue:

/message/430122# 430122 https://communities.intel.com/message/430122# 430122

/message/408703# 408703 https://communities.intel.com/message/408703# 408703

/message/403294# 403294 https://communities.intel.com/message/403294# 403294

/message/323677# 323677 https://communities.intel.com/message/323677# 323677

/message/246210# 246210 https://communities.intel.com/message/246210# 246210

0 Kudos
5 Replies

Hello thbsp,

We understand you're having some issues with the Bluetooth* Module of your Intel® Dual Band Wireless-AC 3160.

Before we start, I'd like to make sure I fully understand the issue, feel free to correct me if I'm mistaken anywhere:

  • You have a Dell Inspiron* 5559 Laptop. Your computer came with a hard drive which was recently upgraded to an SSD.
  • After the upgrade, you performed a clean installation of Windows® 10 on the SSD, and this is where the issues started.
  • The card does not show up in Device Manager at all, until after you've installed the Bluetooth* driver (you're correct, this is an odd behavior).
  • After getting the driver installed and the card to show up in Device Manager, if you reboot the PC the Bluetooth* module disappears again.
  • You've performed some troubleshooting, but so far the issue remains.

I also understand that this adapter came preinstalled in your system. The only change from when it was working to now is that you've upgraded to an SSD.



Don't worry, while the storage media upgrade may just be a key point here, we do not believe that your SSD is to blame.



One of the most attractive features about both SSDs and Windows® 10 is how fast they will allow your system to boot up. It's also quite possible that this is where the issue lies.



Since your SSD is booting much faster than your hard drive, it's possible that the Bluetooth* Module of your adapter is not being initialized (or woken up) properly. We will provide you with a couple of things to try. You may perform all of these steps together, or one by one testing your system in between steps.
  1. Update your BIOS. It's not uncommon for such issues to be resolved after a BIOS update.
    1. http://www.dell.com/support/home/us/en/4/product-support/product/inspiron-15-5559-laptop/drivers/advanced Support & Downloads for Inspiron* 5559 > Drivers & Downloads > Find it myself > BIOS
  2. Disable the Windows® 10 Fast Startup Feature:
    1. Open the Control Panel > Power Options > Select the "Choose what the power buttons do" option on the left hand panel > "Change settings that are currently unavailable" > Scroll down and remove the check mark from "Turn on fast startup" > Click "Save Changes."
  3. Set your wireless adapter to Maximum Performance.
    1. Open the Control Panel > Power Options > Select your plan and choose to "Change plan settings" > Click on the "Change advanced power settings," which will open the advanced power options windows > Scroll down and extend your Wireless Adapter Settings > Power Saving Mode > Set your adapter to Maximum Performance while on battery and plugged in.
  4. If the issue remains, you may need to disable the Fast Boot option in your BIOS. This feature may be located in different places depending on how your BIOS is configured, it may also be called different things (Fast Boot, Fast BIOS Mode, Quick Boot, etc). If you're unable to find this setting, or are unsure for any reason, please contact your computer manufacturer for guidance.

NOTE: Any links provided for third party tools or sites are offered for your convenience and should not be viewed as an endorsement by Intel® of the content, products, or services offered there. We do not offer support for any third party tool mentioned here.

We look forward to hearing back from you.

Best regards,


Carlos A.
0 Kudos

Those are all clever troubleshooting steps. I wasn't aware that the power settings allowed for adjusting of individual adapters, and I certainly wouldn't have guessed that booting quickly could be the source of the problem.

Unfortunately, my problem remains unchanged. Details regarding your suggestions:

1. There was a UEFI ("BIOS") update available, and it seems intended to address exactly what you believed to be the problem (i.e. card not receiving enough power). "Fixes: Wlan and Bluetooth device show "None" with BIOS Setup Menu." I installed the update, but there was no change.

(Details here: http://www.dell.com/support/home/us/en/04/Drivers/DriversDetails?driverId=7J2DH&fileId=3587260248&osCode=WT64A&productCode=inspiron-15-5559-laptop&languageCode=en&categoryId=BI Dell Inspiron 5459/5559/5759 SKL System BIOS Driver Details | Dell US)

3. I checked the power settings, and the wireless adapter was already set to "maximum performance" on AC, which is how I've been using the computer. I set the on battery option to maximum performance as well, just to be sure.

2 & 4. I disabled fast startup in the windows settings and fast boot in the UEFI settings. No change. I should say that, before I changed these settings, I noticed that the system information screen of the UEFI had the line "Bluetooth Device = Installed". Also, I used a stopwatch to check the difference in boot time: they were virtually identical (~15.2 seconds, from pressing the power button to when the windows log on screen appears). I haven't timed the boot time on the HDD install, but it's noticeably slower (one of my big reasons for switching to an SSD in the first place).

(I did try uninstalling and reinstalling the latest Dell driver after going through all of these steps. I haven't yet gone through the process of fully uninstalling the wireless drivers as well before attempting a reinstall. I've seen that recommended on other threads but it seems unrelated to this issue. That said, I can do that if you think it's worth trying.)

Since the actual boot time didn't change, it's possible that power up time remains a problem.

On the other hand, if the bluetooth module is powered up enough for the UEFI to detect it, then it's powered up enough for windows to detect it as well, no? I don't understand why windows wouldn't recognize a device that it supports and the UEFI is aware of. The UEFI passes all hardware information on to windows, no? It should at least appear as "unknown device" or something to that effect.

I must say that at this point I'm stumped. My next step would be to acquire a second HDD and do a clean install of windows on it to see if the boot time really is the key factor or if the driver that came preinstalled on the original HDD had some kind of fairy dust in it that makes it and only it get the bluetooth card working .

Is there really no information to glean from digging through the properties listed for the bluetooth module (device manager --> bluetooth adapter --> right-click --> properties --> details --> list of 70+ attributes)? Interpreting them is far beyond my level of knowledge but perhaps they could be of use to your engineers.

I appreciate your assistance, and hopefully what I've described above gives you enough information to suggest further troubleshooting steps.

0 Kudos

Hello thbsp,



We'll definitely need to research this further.



Please download our https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility System Support Utility. This app will scan your system and allow you to save the results. Please run this tool while your Bluetooth* module is detected, and once again when it's no longer detected. You may attach the file by switching to the "advanced editor" at the top right while replying, feel free to attach any other logs or files that you would like us to take a look at.



While your Bluetooth* module is not being detected, do you see any error message similar to the main one in the following post:



- /thread/110210 https://communities.intel.com/thread/110210



So far, that issue has not been reported for your adapter model, but it's always good to make sure.



Best regards,


Carlos A.
0 Kudos

Well, my issue is resolved, but not in the way I expected.

Shortly after doing the clean install of windows, I installed a driver package called SCPToolkit to allows PS3 controllers to be read by windows as XBOX 360 controllers (since 360 controllers have much better support on windows). I wasn't aware of it at the time, but that driver package included a bluetooth driver to allow PS3 controllers to connect via bluetooth. Uninstalling that package and then and reinstalling the dell bluetooth driver resolved the problem. I've now restarted my computer 5 times just to be sure because I'm having trouble believing that the issue was something so small and something I completely overlooked. There must be a problem with that SCP package not properly supporting the wireless card I have. Not having bluetooth support for my PS3 controller isn't a big loss so I'll gladly give that up to have bluetooth working properly with everything else.

Anyways, my bluetooth module appears in device manager and settings and I've tested it by pairing it with my phone. Everything's working as it should. This is now an issue for the SCP people to solve and I'm not going to pursue this any further.

If you'd like, I can recreate the problem by installing that driver package again to provide you with the diagnostic results you requested. I did save them, but they were made after I uninstalled the SCP package so they won't show anything


Much thanks for your help, and after 15+ tedious hours of fiddling with bluetooth settings I will now happily return to my regular evening routine.

For people who find this thread via google in the future:

- installing SCP and skipping the bluetooth driver installation has let me have working bluetooth and use my PS3 controller (through a wired connection).

- when the issue was present, installing the bluetooth driver caused a new group to appear in device manager: Bluetooth --> Intel Wireless Bluetooth. Now that everything's working, installing the bluetooth driver also produces 'Microsoft Bluetooth Enumerator' and 'Microsoft Bluetooth LE Enumerator', and under Network adapters 'Bluetooth Device (Personal Area Network)' and 'Bluetooth Device (RFCOMM Protocol TDI)'. I imagine those details would vary from system to system, but if there's only one new item in device manager after installing the bluetooth driver then there's likely a problem.

0 Kudos

Hello thbsp,



We're very glad to hear that your issue has been resolved.



Believe it or not, I actually had "Check for VPN, AV (antivirus/firewall) software, or anything possibly making modifications to the BT driver" as a to-do item on my case notes.



Thank you for sharing your solution, I'm sure this will definitely help prevent quite a few headaches for other users.



If you have any further questions or concerns, just let us know. We're always glad to be of assistance.



Best regards,


Carlos A.
0 Kudos